WebSite X5Help Center

 
Claudio R.
Claudio R.
User

Browser web non legge .php  it

Autore: Claudio R.
Visite 218, Followers 1, Condiviso 0  

Salve a tutti, oggi finalmente ho deciso di passare dalla versione 13 alle 17, entrmabe PRO, dopo pochi minuti

`però mi sono pntito.

Importato un sito fatto con 13, fatto piccole modifiche, pubblicato e con grande scooncerto non va più:

- pagine di ingresso scelta lingue

- parti di sezioni dello shop

Mi sono accorto che tutto avviene con le pagine con estensione .php...

Qualcuno può dirmi perchè? 

Non funione ne con safari ne con explorer...

Grazie in anticipo a chiunque voglia darmi una mano. Saluti Claudio

Postato il
11 RISPOSTE - 3 UTILI - 1 CORRETTO
Claudio D.
Claudio D.
Moderator
Utente del mese IT

Ciao!

la versione 17 di Website richiede come versione di PHP almeno la 5.6

quindi chiedi all'host di attivarti almeno quella...

su alcuni Host , puoi farlo direttamente tu dal pannello di contollo online presente nell'host...

Leggi di più
Postato il da Claudio D.
Claudio R.
Claudio R.
User
Autore

Purtroppo non va, e non va nemmeno la pagina di ingresso....

Leggi di più
Postato il da Claudio R.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Claudio R.
Purtroppo non va, e non va nemmeno la pagina di ingresso....

... sbaglierai qualcosa, e forse potresti avere una pagina index.html di risulta e da eliminare...

... controlla il pannello www.tuosito/admin/ e che sia tutto regolare e "pass"...

... posta anche il LINK... ed allega gli STAMP di quello che vedi tu e di quello che dovrebbe essere...

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Claudio R.
Claudio R.
User
Autore
 ‪ KolAsim ‪ ‪
Claudio R. Purtroppo non va, e non va nemmeno la pagina di ingresso.... ... sbaglierai qualcosa, e forse potresti avere una pagina index.html di risulta e da eliminare... ... controlla il pannello www.tuosito/admin/ e che sia tutto regolare e "pass"... ... posta anche il LINK... ed allega gli STAMP di quello che vedi tu e di quello che dovrebbe essere... .

www.sitisa.ch, ora ho ripubblicato la versione creata con 13 e funziona tutto, con la 17 

- non si vede pagina di ingresso

- non si vede home

- non si vede Shop-t-shirt

Ho parlato con il mio "coso" dell'host e mi ha fatto creare un file txt da importare nella root del sito e da rinomminare in .htaccess (#PHP7.1 ecc...) ma in ogni caso non ha funzionato

Forse é effettivamente solo un questione di aggiornamento del .php

Leggi di più
Postato il da Claudio R.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Claudio R.
 ‪ KolAsim ‪ ... ... ...  Forse é effettivamente solo un questione di aggiornamento del .php

...!... sì, il problema sta lì; ... sul tuo server hai in uso il PHP/5.2.17; ...per la v.17, come anticipato dal Claudio  tuo omonimo, devi selezionare sul server, o farti assegnare come minimo il PHP/5.6++

... confermo, attualmente tutti i siti, De,It,Fr, risultano essere stati esportati ieri con la v.13_PRO (lastmod 2019-03-12)...
... verifica nel tuo pannello online : www.sitisa.ch/admin/

... quando avrai fatto e modificato il PHP avvisa che nel caso si andrà a controllare...
... occhio a come si usa ".htaccess" e se non necessario per casi particolari (404,301, SSL, ...) evitare di produrlo...

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Luciana Ciolfi
Luciana Ciolfi
User
Claudio R.
‪ www.sitisa.ch, ora ho ripubblicato la versione creata con 13 e funziona tutto, con la 17  - non si vede pagina di ingresso - non si vede home - non si vede Shop-t-shirt

OT

Il tuo banner per l'informativa sulla privacy e sui cookie non ha nessun link all'informativa o alla pagina per la gestione dei cookie. E non c'è nemmeno un link relativo nel footer del sito.

Leggi di più
Postato il da Luciana Ciolfi
Claudio R.
Claudio R.
User
Autore

Questo è lo shot dell impostazioni del server database

Leggi di più
Postato il da Claudio R.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator

.. da quel che vedo dal tuo STAMP, se il PHP/7.1.1 l'hai attivato, (mi pare di no!), allora dovresti essere a posto... ... eventualmente contatta direttamente il tuo server...

... vedo che in rete il sito è ancora quello di ieri...

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Claudio R.
Claudio R.
User
Autore

Allora, il problema ü del provider che, per quanto faccia sebrare che il php sia 7.1.1 in effetti fa girare il DB con php ancora alla versione 5.2.7 quindi sono in attesa di risposta da parte loro, vi aggiorno....

Leggi di più
Postato il da Claudio R.
Claudio R.
Claudio R.
User
Autore

Buon gionro a tutti, ho risoldo il problema della versione PHP del mio host, vi metto in allegato il file .htaccess che hanno caricato loro, anche se secondo me hanno fatto altro per risolvere il probelma...

GRAZIE a tutti per l'aiuto

Leggi di più
Postato il da Claudio R.