WebSite X5Help Center

 
Francesco R.
Francesco R.
User

Problema database  it

Autore: Francesco R.
Visite 158, Followers 1, Condiviso 0  

Ho appena aggiornato alla versione 2019.2.3 e ho notato che in due siti che ho convertito a questa versione non funziona piu' la fase carrello dopo aver scelto il tipo di pagamento e il tipo di spedizione cliccando su avanti dovrebbe apparire o la registrazione o l inserimento password e nome utente invece rimane su pagina bianca lo fa da qualunque browser (i siti in querstione sono www.enotekando.it e www.autofiumesrl.it. infatti se uso due siti che ancora non sono stati aggiornati alla nuova versione tutto funziona regolarmente.

Postato il
8 RISPOSTE - 1 UTILE - 1 CORRETTO
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator

... in ambedue hai un errore PHP 500 del server...

... nel FilesManger o PremissionManager del server prova a selezionare un PHP inferiore a quello che hai in uso (PHP/7.3.6), ma superiore  PHP/5.6+

... eventualmente contatta il server stesso...

... altrimenti resta in attesa degli esperti...

...!... intanto vedo che è stato segnalato un errore simile anche qui:   https://helpcenter.websitex5.com/it/post/213528

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Francesco R.
Francesco R.
User
Autore

niente ho selezionato php 7.1 e 7.3 ma niente stesso problema 

Parse error: Invalid numeric literal in /customers/a/e/3/enotekando.it/httpd.www/res/x5settings.php on line 205

Leggi di più
Postato il da Francesco R.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator

... per eliminare dubbi su un eventuale BUG del programma, intanto che aspetti gli esperti, prova a fare una rapida prova...
1) - crea nel sito in rete un cartella chiamata "prova" per esempio nel sito enotekando.it;
2) - avvia in WebSiteX5 un Nuovo Progetto, VUOTO, con solo la HOME (vuota);(*);
3) - avvia l'esportazione di questo progetto, selezionando nel pannello FTP del Passo_5 la cartella "prova";
4) - quindi controlla se il pannello /admin/  funziona a questo indirizzo:
http://www.enotekando.it/prova/admin/
...
... se il .4) funziona, allora il tuo precedente problema potrebbe dipendere da qualche carattere extra/riservato utilizzato nelle descrizioni coinvolte nel codice PHP, per esempio ("), ('), (&), ecc....
... se il .4) NON funziona, allora potrebbe essere un problema del programma, nel qual caso dovrà farsene carico lo STAFF...
.

(*) - al Passo_1 l'indirizzo del sito da dichiarare sarà nella opzione Indirizzo URL del Sito:   http://www.enotekando.it/prova/

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Francesco R.
Francesco R.
User
Autore

facendo come dice KolAsim cioe' pubblicando sito in prova funziona

Leggi di più
Postato il da Francesco R.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Francesco R.
facendo come dice KolAsim cioe' pubblicando sito in prova funziona

...!... azzardo una ipotesi...!...

... osservando velocemente nel modulo contatti  in Trattamento dati*  vedo questa descrizione:

Autorizzo il trattamento dei miei dati personali ai sensi dell' art. 13 del Regolamento europeo (UE) 2016/679.

... ecco, se vuoi, prova ad eliminare tutto il Trattamento dati*...oppure ad eliminale l'apostrofo (') in (dell' art.)...

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Francesco R.
risolto https://helpcenter.websitex5.com/it/post/213509 come suggerisce questa discussione sono andato alla riga 205 e ho sostituito nell' array il punto alla virgola.

... ottimo! ... controlla quindi se per caso non dipendesse da eventuali valori inseriti nel progetto...

...

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪