WebSite X5Help Center

 
Arne T.
Arne T.
User

Test fail. My SQL Database settings (1), (2) og (3)  en

Autore: Arne T.
Visite 382, Followers 1, Condiviso 0  

Good morning, when trying to upload modified webside to internet, i got a message about following test fail.... My SQL Database settings (1), (2) og (3).  Then I followed the link 'More information about www.websitex5.com/server-requirements'.

There I am informed that "Only for some advanced functions, PHP 5.6 and MySQL are also required".

This information tells me very little.

My webhotel host informs me that I have 'PHP-version 7.3'. For me, it sounds like I have an up to date version.

My webhotel also informs me that my settings for 'PHP-configuration' is not set to anything, but I can choose between 'Zend Guard loader for php' or 'ionCube loader for php'.

I have no idea what this actually means, or where to go from here.

I am not into computer talk, so maybe that is the reason, but so far, WebSiteEx5 has had the advantage for us users that we actually do not need to know "computer language", so I hope there is a solution.

Postato il
5 RISPOSTE - 2 UTILI
Paul M.
Paul M.
Moderator
Utente del mese EN

Hello Arne,

First of all, don't worry overly at this stage.  The compatibility checks which have been introduced in version 2019.2 are very useful, but they can also be temporarily ignored.  If you were happy with the performance of your WebSite X5 project in 2019.1 then it is likely you will notice no working issues in 2019.2.

Having said that, there must be a problem somewhere which hasn't yet come to your attention, and this is why the new compatibility check is helpful.

Your error message relates to MySQL settings, so this is where we need to check for correct operation.

WebSite X5 Pro includes an online control panel which has built-in tests which can help you narrow down the cause of any trouble.  You can access it by following the instructions at the following link (read the 'Commands in the WebSite Test Section'):

WebSite X5 online control panel

You must be using WebSite X5 to read/write to a database somewhere.  This could be via a Contact Form Object, or perhaps the ecommerce section, etc.  -  the database access credentials which you supply to WebSite X5 must match those which your webhost supplies.

Check the error log on your server (or ask your hosting provider to do this on your behalf) as in almost all cases there will be useful information there on any failed database operations, which can give you a pointer as to how to remedy the situation.

In defence of WebSite X5, it is powerful software which relies on correct configuration of server side components, and this is something which Incomedia have no control over.

Please keep us updated.

Kind regards,

Paul

Search the WebSite X5 Help Center

Leggi di più
Postato il da Paul M.
Arne T.
Arne T.
User
Autore

Thank you, I will try to follow your instructions, and will let you know if I succeed.

Leggi di più
Postato il da Arne T.
Wsx5.afsoftware.fr  
Wsx5.afsoftware.fr  
User

Hello,

could be also some timeout issues between your PC and hoster.... Click ignore to continue and check if your project is running fine.

https://wsx5.afsoftware.fr

Leggi di più
Postato il da Wsx5.afsoftware.fr  
Aleksej H.
Aleksej H.
Moderator

Hello.

  1. Use PHP 7.1, not 7.3.
  2. Temporarily try disabling your antivirus and firewall.
  3. Check the server logs for errors.
  4. Ask your hosting provider if they block your IP or not.
Leggi di più
Postato il da Aleksej H.
Arne T.
Arne T.
User
Autore

Hello, thank you very much for your answers:-)

The solution: I went to my webhotel, who informed me MySQL database was not activated, so I "Provide a new database" - and now it works. That is all I did. Noe more messages about 'test fail' so it seems like this was all that is needed.

By the way, if interesting: My provider of webhotel informs me that PHP 7.1 is outdatet, and that 7.3 is "standard" - even though I can choose 7.2.

Leggi di più
Postato il da Arne T.