WebSite X5Help Center

 
Gabriele C.
Gabriele C.
User

Margine Contenuto della Pagina Dedicato  it

Autore: Gabriele C.
Visite 206, Followers 5, Condiviso 0  

Salve ragazzi,

in alcune pagine ho necessità di settare un margine al contenuto della pagina, specifico per la singola.

Attualmente uso il codice opzionale CSS per il margine superiore:

#imContent {
margin-top: 30px;
}

Tuttavia ho notato che W5 non gradisce tale codice, specialmente nelle pagine "Articolo" del Blog.

Qualche consiglio per impostare tale opzione senza incorrere in tali problemi?

Postato il
14 RISPOSTE - 2 UTILI - 1 CORRETTO
Claudio D.
Claudio D.
Moderator
Utente del mese IT

non so se è quello che cerchi e non ho provato ...

ma io proverei col padding

<style>
#imContent {
padding-top: 30px;
}
</style>

Leggi di più
Postato il da Claudio D.
Gabriele C.
Gabriele C.
User
Autore

Buongiorno Claudio. Provo subito!

Leggi di più
Postato il da Gabriele C.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Gabriele C.
Attualmente uso il codice opzionale CSS per il margine superiore: #imContent { margin-top: 30px; }

... sei sicuro che sia il selettore e l'attributo giusto da usare...?...

... non dovresti avere difficoltà, ...ma senza LINK non si può valutare...

.

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Gabriele C.
Gabriele C.
User
Autore

Un esempio pratico lo puoi trovare qui (https://www.stiac.it/preview/theme/organicworld/blog/). Devo ancora applicare il codice consigliato da Claudio.

Quando scorri verso il basso gli oggetti laterali diventano timidi. Sono troppo "suscettibili" in quanto ho riscontrato molti problemi.

Es.

Leggi di più
Postato il da Gabriele C.
Giancarlo B.
Giancarlo B.
User

Gabriele io sul mio blog utilizzo

#imContent {margin-top: 50px;}

come hai scritto tu all'inizio...

Leggi di più
Postato il da Giancarlo B.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator

... se devi assegnare il margine al riquadro in rosso indicato dalla freccia, il selettore è: #imBlogSidebar

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Gabriele C.
Gabriele C.
User
Autore

Perdonate il ritardo.

No, il mio intento è assegnare un bordo superiore ovvero tra l'Header e il Contenuto della Pagina (indicato in arancio).

Il problema è che il codice indicato causa un bug che si manifesta con lo scroll verso il basso, per lo più da mobile, causando la scomparsa dei blocchi laterali.

È un bug che ho scoperto nel 2019 ma non ho segnalato in quanto ho dato per scontato il rigetto dal team essendo codice opzionale.

Anche io usavo il codice citato sul blog Stiac, tuttavia sono stato costretto a rimuoverlo.

Mi piacerebbe molto personalizzare tale aspetto, per il semplice motivo che ci sono siti con un design particolare e non sempre è possibile usare un bordo univoco.

Spesso uso un bordo pari a 0px nelle pagine normali e 30px nelle pagine create direttamente dal programma.

Leggi di più
Postato il da Gabriele C.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator

... mo' è un'altra cosa...

... bug...!?...

... quel codice che ho suggerito più di un anno fa, ha sempre funzionato in passato, vedo che è ancora valido, e non c'entra con la scomparsa dei blocchi laterali...

.



Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Gabriele C.
Gabriele C.
User
Autore

L'oggetto del post cita proprio quello che ho cercato di specificare. Se provi ad andare sul link indicato, da mobile, ed effettui uno scorrimento verso il basso noti che i contenuti evidenziati di rosso spariscono (ergo oggetti laterali).

Fatto sta che se elimino il codice in questione il problema non si presenta, tuttavia mi rimane irrisolto l'oggetto di tale topic.

Bug o non bug... questo è il dilemma! 

Leggi di più
Postato il da Gabriele C.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Gabriele C.
L'oggetto del post cita proprio quello che ho cercato di specificare. ... ... ... ... ... Bug o non bug... questo è il dilemma! ... ....

... non è un bug!... ...non c'entra con il programma...undecided

 ...ti spieghi a singhiozzo tirandone sempre una diversa...laughing

... ... devi avere le idee chiare e sapere di quel che vorresti ottenere...

... quindi, in base al tuo ultimo post, ovviamente viene a cambiare il selettore di riferimento...

...!... se era chiaro, sarebbe stato molto più semplice sin dall'inizio:

<style> #imBlogPage { margin-top:30px;} </style>

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Gabriele C.
Gabriele C.
User
Autore

Dal mio punto di vista mi sono espresso con chiarezza, tuttavia apprezzo il riscontro per poter migliorare i miei futuri post.

Ho appena provato offline e sembra funzionare senza alcun problema.

Le idee chiare diciamo che nella mia capoccia ci sono, il problema è esporle correttamente.

Detto ciò, vorrei ringraziarti, come sempre, per la gentile disponibilità.

P.s. Se lascio in altre pagine (es. Ricerca Prodotti, Login etc.) il codice con #imContent va bene?

Leggi di più
Postato il da Gabriele C.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Gabriele C.
... ...  P.s. Se lascio in altre pagine (es. Ricerca Prodotti, Login etc.) il codice con #imContent va bene?

... ... ... ... wink..

... in linea di massima, penso di sì, ... in genere non ha mai dato problemi, ed in caso si presentassero, prova con altre opzioni più adatte allo scopo, come per esempio è emerso qui...

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Gabriele C.
Gabriele C.
User
Autore

Grazie ancora! Se per voi va bene chiuderei il post.

Leggi di più
Postato il da Gabriele C.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Gabriele C.
Grazie ancora! Se per voi va bene chiuderei il post.

... puoi chiudere, ... e in caso di bisogno poi puoi anche riaprire ... ciao ...

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪