WebSite X5Help Center

 
Игорь Е.
Игорь Е.
User

Error in xml  en

Autore: Игорь Е.
Visite 487, Followers 1, Condiviso 0  

When working in X5, there was a failure, the program hung. After reopening the project I bug "error in xml". I wanted to restore the project from the "Backup" folder, but it was empty. Tell me, is it possible to fix this?

Postato il
5 RISPOSTE
Franz-Josef H.
Franz-Josef H.
Moderator

Perhaps there is another file in the internal backup management that can be taken. The backup management can be found in the project folder in the Backup directory. There you take the penultimate file or, if only one is available, the only file (* .iwprj2), copy it and rename the copy to project.iwprj2. You copy this into the project folder and overwrite the existing file. Then start the project; maybe it works. You will find the project directory after starting WebsiteX5 in the window with the advertisement on the left side under "Settings" (gear symbol).

Leggi di più
Postato il da Franz-Josef H.
Franz-Josef H.
Franz-Josef H.
Moderator

I just see that the backup folder is empty. then you only have a chance if you have created an iwzip file as a backup under step 5, export project, or if you have a complete backup of the hard drive.

Leggi di più
Postato il da Franz-Josef H.
Игорь Е.
Игорь Е.
User
Autore

How do I set up backup? In other projects, backup files are created, here the folder is empty for some reason.

Leggi di più
Postato il da Игорь Е.
Andreas S.
Andreas S.
Moderator
Utente del mese DE

You are still working with V13 or?
Check if there is data in your path in the project folder.

C:\Users\Documents\Incomedia\WebSite X5 v13 - Professional\Name Project

There should be folders "Preview", "Upload", "Backup" and also a project.iwpj file!
If there are no folders or files, then you can only save your project with a real backup. You can only get a real backup under "5" Export project where an iwzip file is created.

Leggi di più
Postato il da Andreas S.
Luis S.
Luis S.
User

From Ver. 13 x5 was a notorious PITA for this bug, only in 16 it got better, I remember getting that error, it made me lose all work many times, it's something like:

XML 0,0 index out of range

...or something like that, it means x5 just corrupted the whole project (not leaving backup).

Leggi di più
Postato il da Luis S.