Locked Page Error 
Autore: Ruth S.
Visite 397,
Followers 1,
Condiviso 0
Hi, I have an issue logging into my locked, password set page. I've gone through everything as deep as possible with Chat GPT and their advice to let you know the following:
WebSite X5 Pro 2026.2.5. Manual Registration. Administrator credentials successfully log into /admin/, but the same administrator credentials return ‘Wrong username and/or password’ on imlogin.php for a locked page. Manual users are rejected too. PHP 7.4.33 and session support pass Website Test, and the whole website has been fully re-exported. 'Admin' credentials work, while submitting the same credentials to 'imlogin.php' results in loginstatus=-2, with no server or security errors recorded.
Can you please advise on what to explore next?
Thanks
Postato il

Hello Ruth,
I am sorry about the issue.
Could you first of all test the situation with a more up-to-date version of PHP, in case this may be affecting the situation?
For the current version of WebSite X5 one between 8.2 and 8.5 is suggested.
Autore
Hi, I've just updated the PHP and still not working, thanks
Hello Ruth,
could you provide me with a copy of the project to investigate more closely and also see if the error can be reproduced on another hosting space?
You can export it in Step 5 - Export, choosing the “Export the project” option to generate an IWZIP file, making sure not to use the options to include backup and preview files so that the size of the file is reduced.
You can then upload the file with SwissTransfer, TransferNow or similar services, and provide a download link to support @ incomedia.eu (without the spaces).
Thank you.
Autore
great, thank you. I't on its way to you now via WT, thanks
Hello Ruth,
I tested the websites with 2 different clean exports: one on my hosting space, and one into a subfolder I temporarily created on your hosting space.
Both of these versions of the website have no issues when logging in with either user in the Download page.
I suspect the issue lies with either some leftover files or some settings of the /public_html folder that are affecting the situation, I would recommend checking your options for a restore to its initial state and then go ahead with a fresh export, using CTRL + Preview to regenerate all files and choosing to upload all files.
I remain available.
Autore
Hi Eric,
Thanks for this, I'll looking into thsi further, much appreciated
Autore
Hi Eric,
So I've gone ahead with this as suggested but I'm still not getting any joy with a fresh export. Neither username/password allows me in.
Do you have any other suggestions?
Many thanks
Ruth
Hello Ruth,
I would recommend contacting your hosting provider to investigate whether there could be any other elements affecting the situation compared to when the website is published in a subfolder rather than the main one.
I remain available.
Autore
Hi Eric,
So my hosting provider has looked into this further and have said the following:
We have reviewed both the Access Management settings and the Locked Page permissions. The permissions appear to be correctly configured. The Downloads page is set as a Locked Page.
Therefore, we don't believe any changes to the page permissions are required at this stage.
As we have previously confirmed from our server-side checks that the login request is reaching imlogin.php successfully and is not being blocked by the server or firewall, and the issue has also persisted after the PHP update and fresh export, we recommend going back to WebSite X5 Support with these latest findings.
Could you please ask WebSite X5 Support to review the authentication configuration and advise what could cause both users to be rejected by imlogin.php with loginstatus=-2 despite both users being explicitly authorized for the locked page?
Please ask them specifically whether there are any WebSite X5 authentication, session, project configuration, or generated-file issues that we should check on the live installation.
If WebSite X5 Support identifies anything that needs to be checked or changed on the hosting/server side, please send their recommendations to us and we'll be happy to investigate those from our end.
Many thanks
Ruth
Hello Ruth,
to confirm, was anything done to the main destination folder, such a reset or restore to its initial status?
Thank you.
Autore
Hi Eric, yes it was restored ok, thanks
Hello Ruth,
may I export to the main folder, to ascertain whether there is any difference when the exported filed are generated on a different device?
This could help confirm whether the issue is actually due to something in the software itself, or if the behavior is indeed isolated to the main folder only, regardless of the source of the export.
If the IWZIP you sent is no longer up-to-date because the project has been modified, I would ask for the current version first.
Thank you.