WebSite X5Help Center

 
Francesco Della Torre
Francesco Della Torre
User

Spazi bianchi sotto ai moduli  it

Autore: Francesco Della Torre
Visite 1355, Followers 1, Condiviso 0  

Sono un neofita di WebsiteX5 (uso la versione Evolut10n, aggiornata) e chiedo scusa se, magari, farò perdere tempo a qualcuno con una domanda "stupida". Ho cercato a lungo fra le discussioni, ma non ho trovato risposte.

Quando inserisco dei moduli, si crea uno spazio bianco esagerato nella parte inferiore, fra il modulo ed il piè di pagina. Lo spazio è all'interno della cella, allego uno screenshot di esempio (non ho ancora pubblicato il sito). Lo spazio che intendo è quello fra i "pulsanti di invia e reset" ed il piè di pagina verde, per entrambi i moduli (sinistro e destro).

La stessa cosa mi succede anche con altri moduli, ad esempio con il guestbook-

Preciso che ho già provato:

  • a mettere a zero i margini della cella, della pagina, ecc.
  • a ridurre ad 1 l'altezza massima della pagina
  • a rifare da capo le pagine con i moduli
  • a rifare da capo il progetto
  • a mettere un solo modulo nella pagina
  • a lavorare su più righe, espandendo il modulo sulle stesse

ma non è cambiato nulla...
Ho notato che per alcuni dei siti di esempio con WebsiteX5 è presente lo stesso problema, per altri no...quindi una soluzione deve pur esserci!
Ringrazio in anticipo quanti vorranno aiutarmi Laughing.

Postato il
37 RISPOSTE - 5 UTILI - 1 CORRETTO
Mirko Boschetti
Mirko Boschetti
Moderator

Io ho provato e mi funzia...dipende come hai inserito i moduli...su quante righe orizzontali...

Leggi di più
Postato il da Mirko Boschetti
Mirko Boschetti
Mirko Boschetti
Moderator

Prova a mettere cosi...l'oggetto testo sopra a sx lo ho messo con alcuni "a capo" vuoti per far scendere il modulo mail di sx.... Wink

Leggi di più
Postato il da Mirko Boschetti
Francesco Della Torre
Francesco Della Torre
User
Autore

Grazie per la risposta!

Dunque, il problema sulla "colonna" di sinistra lo posso risolvere come mi hai scritto tu, inserendo del testo con un po' di "a capo", ok: funziona, mi sposta il modulo in giù..

Rimane però il problema dello spazio sotto al modulo di sinistra, che non posso risolvere come dici tu...anche perchè qui il problema è lo spazio bianco proprio dentro al modulo!!!

Ti allego uno screenshot completo di tutta la pagina (non è perfetto, scusa la brutalità ma ho dovuto montare tre screenshot assieme...).

Leggi di più
Postato il da Francesco Della Torre
Mirko Boschetti
Mirko Boschetti
Moderator

Elimina un po di righe orizzontali fino a che non ti va a fine pagina...se va a me deve andare anche a te... Wink

Leggi di più
Postato il da Mirko Boschetti
Francesco Della Torre
Francesco Della Torre
User
Autore

Scusa, non vorrei farti perdere tempo per niente: probabilmente sono io che non capisco bene quello che mi consigli!

Ecco lo screenshoot della schermata di progetto di Website; ho due righe, due colonne. La prima riga interamente occupata dal testo, la seconda dai due moduli.

Che righe orizzontali potrei eliminare???

Tieni presente che ho lo stesso problema nella pagina del guestbook, dove, addirittura, ho una sola riga ed una sola colonna.

Grazie...Embarassed

Leggi di più
Postato il da Francesco Della Torre
Mirko Boschetti
Mirko Boschetti
Moderator

Visto il mio ultimo allegato sopra...?

Prova come ho messo io, aggiungi un bel po di colonne e righe, e vedrai che funzia... Wink

Leggi di più
Postato il da Mirko Boschetti
Francesco Della Torre
Francesco Della Torre
User
Autore

Ho provato a fare come dici tu, con molte righe e colonne. Ho fatto varie prove, mettendo i tre oggetti su righe e colonne differenti (cioè variando le dimensioni deegli oggetti). Nulla da fare, sempre uguale,

Ho però provato a fare un'altra prova: a lasciare il testo iniziale (che occupa tutta la larghezza della pagina) ed uno solo dei due moduli mail.

Lasciando solo quello di sinistra è tutto perfetto (no spazio sotto). Lasciando invece solo quello di destra, il problema è identico.

E' per caso possibile che il tutto sia causato dal fatto che il modulo di destra è molto "lungo"?

Per sicurezza ho ricontrollato tutti i margini (anche di pagina) e l'altezza minima della pagina: tutto come avevo scritto...

Leggi di più
Postato il da Francesco Della Torre
Mirko Boschetti
Mirko Boschetti
Moderator

se il modulo a dx è molto lungo, aumenta un po di righe orizzontali, e poi allungalo più in giù...

Leggi di più
Postato il da Mirko Boschetti
Francesco Della Torre
Francesco Della Torre
User
Autore

Ho fatto così: ho eliminato tutto quello che "funziona" (testo orizzontale in alto e modulo a sx) ed ho lasciato solo il modulo "troppo lungo".

Ho aumentato le righe, portandole fino a 100. Ho inserito il modulo e l'ho allungato fino all'ultima riga. Nulla da fare.

Poi ho fatto un po' di prove allungandolo non fino all'ultima riga, ma a qualche riga più sopra. Idem. Poi ho rifatto le prove lasciando qualche riga sopra il modulo. Idem ancora.

Allego uno screenshoot. Il problema rimane lo spazio bianco compreso fra i bottoni "Invia" e "Reset" ed il bordo inferiore della cella.

Domanda: siamo sicuri che si tratta di un problema risolvibile e non di un bug? Ho girato nuovamente nei vari topics, notando che altri lo hanno segnalato, anche se per oggetti differenti (animazioni flash, caselle di testo, ecc.).

Grazie ancora...e buona giornata!

Leggi di più
Postato il da Francesco Della Torre
Mirko Boschetti
Mirko Boschetti
Moderator

Fosse stato un bug, non avrebbe funzionato neanche il mio esempio...

Leggi di più
Postato il da Mirko Boschetti
Francesco Della Torre
Francesco Della Torre
User
Autore

Ma tu hai provato con un modulo lunghissimo come il mio di dx?

Scusa se insisto, ma è molto importante: vorrei mettere il sito on-line entro la fine della settimana...

Altrimenti mi tocca spostare il modulo di dx su un'altra pagina, almeno in via provvisoria, e togliere il bordo della cella (soluzione di compromesso, non mi piace molto ma almeno posso procedere...).

Posso farti avere qualcosa d'altro, oltre ai soliti screen-shot? Qualcosa che ti possa aiutare a capire meglio se e dove sbaglio?

Leggi di più
Postato il da Francesco Della Torre
Incomedia
Riccardo P.
Incomedia

Bongiorno Francesco,

io ho riprovato a ricreare un form lungo ma lo spazio in basso non è presente.

Prova a eliminare il form e ricrearlo iniziando con pochi elementi e provando di volta in volta l'anteprima per vedere se lo spazio rimane corretto.

Fammi sapere.

Leggi di più
Postato il da Riccardo P.
Francesco Della Torre
Francesco Della Torre
User
Autore

Buongiorno Riccardo, grazie per la risposta.

Per scrupolo, ho provato a cercare lo stesso topic in lingua inglese, sempre all'interno di Website Answer.

"Orrore": pare che lo stesso problema si sia verificato ad una marea di utenti... Ad esempio, guarda qui: http://answers.websitex5.com/post/4011 E' del 2011 e non risulta risolto...

Ho fatto come mi hai scritto, ma il problema rimane. Ti segnalo che lo stesso problema mi si presenta con la pagina del guestbook (vedi screenshot). Anche in questo caso ho seguito tutti i consigli che mi ha dato in precedenza Mirko (impaginazione su più righe e colonne, ecc.), ma purtroppo non è cambiato nulla...

Leggi di più
Postato il da Francesco Della Torre
Mirko Boschetti
Mirko Boschetti
Moderator

Prova a creare un nuovo progetto con solo una pagina, e se non ti funzia neanche quello, crea il file iwzip, poi lo comprimi con winzip, e lo metti qui...

Leggi di più
Postato il da Mirko Boschetti
Francesco Della Torre
Francesco Della Torre
User
Autore

Ciao Mirko, ecco qui il file zippato.

Per non introdurre elementi "personali", ho semplicemente utilizzato il template di base di Website, eliminando due pagine e lasciando la horme page e la pagina 1, che contiene il modulo di invio mail lungo.

Ho ricostruito da zero questo modulo, senza fare copia-incolla dal progetto al quale sto lavorando.

Non ho toccato praticamente nulla, salvo mettere a zero tutti i margini della cella che contiene il modulo. Ho impaginato su molte righe e colonne il modulo, come vedrai (in base al consiglio che mi hai dato tu in precedenza). Ho messo ad 1 l'altezza minima della pagina.

Però...anche qui il problema si presenta...

Leggi di più
Postato il da Francesco Della Torre
Template By Silver™
Template By Silver™
User

aprendo il modulo e cliccando su OK lo spazio si azzera

Leggi di più
Postato il da Template By Silver™
Francesco Della Torre
Francesco Della Torre
User
Autore

Ragazzi, grazie ancora per l'interessamento...

Mi spiace, forse vi sto facendo perdere solo tempo, dato che a voi funziona tutto.

Come scritto in precedenza, sono assolutamente "nuovo" con Website, non faccio il webdesigner, mi serve solo aprire UN sito per la mia attività (cioè: non credo che farò altri siti in vita mia, salvo per amici e parenti e certamente non a pagamento...).

Detto questo: onde evitare "equivoci informatici", ho eliminato il progetto di prova creato in precedenza, poi ho importato il progetto dal file iwzip che vi ho inviato prima. Ho aperto il modulo emal, ho cliccato OK (come ha fatto Silver) ed infine ho salvato.

Apro l'anteprima e...tutto come in precedenza: grosso spazio sotto al modulo (inutile inviarvi ancora lo screenshoot).

Domanda: non è che questa cosa succede solo nell'anteprima e quando pubblicherò il sito on-line il problema si risolverà da solo? Chiedo scusa se non l'ho chiesto prima (ma ho specificato in un precedente post che ad ora il sito è solo off-line).

Se così fosse, entro la fine della settimana lo pubblicherò e poi, visto cosa succederà, vi riporterò i link alle pagine "incriminate". Ditemi voi, please...

N.B.: uso Website versione 10.0.6.31.

Leggi di più
Postato il da Francesco Della Torre
Mirko Boschetti
Mirko Boschetti
Moderator

No dopo l'OK a me funzia esatto anche in anteprima...Surprised

Leggi di più
Postato il da Mirko Boschetti
Mirko Boschetti
Mirko Boschetti
Moderator

Prova ad aprire il mio (tuo) ora che lo ho salvato...

Leggi di più
Postato il da Mirko Boschetti
Francesco Della Torre
Francesco Della Torre
User
Autore

Mirko, sei grande!!!Smile

Con il tuo iwzip è tutto ok, perfetto e senza spazi; vedi screenshoot.

Scusa, puoi spiegarmi cosa diavolo hai fatto che io non faccio??? So che è la "domanda del secolo"...

Leggi di più
Postato il da Francesco Della Torre
Mirko Boschetti
Mirko Boschetti
Moderator

Niente di più di quello che hai fatto tu...come detto da Silver aperto e dato l'OK...ma hai detto che lo hai fatto anche tu e non ti ha funzionato...Surprised

Leggi di più
Postato il da Mirko Boschetti
Mirko Boschetti
Mirko Boschetti
Moderator

A questo punto prova per curiosità un altro modulo, giusto per sapere se effettivamente non ti funzia il tuo....poi salvi iwzip, e lo riapri e vedi se va...

Leggi di più
Postato il da Mirko Boschetti
Francesco Della Torre
Francesco Della Torre
User
Autore

Ho aggiunto una pagina ed ho inserito il modulo guestbook (Pagina 4).

Giusto per fare come facevamo negli anni '80 con i primi PC (...Laughing), ho esportato/cancellato/importato il progetto tre volte (si sa mai...so che è stupido...).

Nulla da fare, ancora uguale, stesso problema. Anche con il modulo email (che si trova ancora a Pagina 1).

Allego il nuovo iwzip...

Leggi di più
Postato il da Francesco Della Torre
Francesco Della Torre
Francesco Della Torre
User
Autore

Chiedo scusa: ecco l'allegato.

Leggi di più
Postato il da Francesco Della Torre
Mirko Boschetti
Mirko Boschetti
Moderator

Riguarda il mio link...funzia tutto anche il guestbook...a sto punto io proverei a reistallare il programma di nuovo....disinstalla il tuo, e poi preleva dal tuo profilo il programma...poi come sempre disattiva antivirus e firewall, e fai ripartire l'installazione con tasto dx come ammistratore...  Wink

Leggi di più
Postato il da Mirko Boschetti
Mirko Boschetti
Mirko Boschetti
Moderator

Dimenticavo...il guestbook lo avevi messo altezza 650...per forza era alto... Laughing

Leggi di più
Postato il da Mirko Boschetti
Francesco Della Torre
Francesco Della Torre
User
Autore

Sì, mi sono accorto dell'altezza del guestbook solo dopo aver allegato il file qui. Chiedo scusa.

Ho riguardato il tuo link, hai ragione...

Va bene, allora faccio così: prima finisco il sito (ormai mi manca pochissimo), poi provo a reinstallare il tutto. Prima della fine della settimana ritorno qui e racconto com'è andata (spero bene!).

Grazie ancora e buona serata.Smile

Leggi di più
Postato il da Francesco Della Torre
Mirko Boschetti
Mirko Boschetti
Moderator

Ok, nel frattempo, non so se funzionerà, prova a copiare dal mio progetto il modulo mail e incollarlo nel tuo...aprendo tutti e 2 i progetti contemporaneamente, cosi se funzia, lo esporti già giusto....ciaooo

Leggi di più
Postato il da Mirko Boschetti
Francesco Della Torre
Francesco Della Torre
User
Autore

Buongiorno Mirko. Per il guestbook tuto a posto, come ho già scritto non avevo ridotto l'altezza; ora l'ho fatto anche nel mio progetto ed è tutto ok. Quindi questo problema è risolto. Laughing

Per il modulo email, ho provato a fare come mi hai scritto.

Inizialmente: perfetto, funzionava alla grande! Niente spazio vuoto sotto al modulo mail.

Poi, però, ho provato a modificare le condizioni di accettazione: sul modulo che abbiamo usato come prova (preso dal tuo progetto e copiato nel mio) sono scritte in una sola riga (dentro al campo ho scritto solo, per semplicità, "Condizioni di accettazione"), mentre io avrei bisogno di una quarantina di righe. E così ho fatto.

E, purtroppo, sono tornato al punto di partenza. Ho allora provato ad ampliare il parametro "Numero di righe", che nel nostro modulo di prova sono 5; nulla da fare.

Allora mi sono detto: va bene, nessun problema, torno al punto precedente. Quindi ho cancellato le mie 40 righe di testo, ne ho lasciata solo una ed ho rimesso a 5 il parametro "Numero di righe". Curioso di vedere cosa sarebbe successo.

Incredibile: lo spazio vuoto è ritornato, anche con il nostro modulo di prova (preso dal tuo progetto e copiato nel mio).

La cosa assurda è che se rifaccio tutto da capo (cancello e ricreo la mia pagina, copio il modulo dal tuo progetto e lo incollo nel mio), la cosa funziona di nuovo.

Però non è bello che io debba scrivere delle condizioni di accettazione che stanno in 4-5 righe...non mi sembra una limitazione accettabile...

Sinceramente, a questo punto, spero che intervenga anche qualcuno di Incomedia: i moltissimi post scritti in inglese (più qualcuno in italiano ed altri in altre lingue) dimostrano che il problema è abbastanza diffuso...

Certo che se avessero messo un parametro "Altezza" anche per questo modulo, magari il problema non sarebbe neppure esistito... E' solo una mia impressione, naturalmente: come scritto in precedenza, non sono esperto di programmazione...

Per intanto grazie ancora per i consigli.

Leggi di più
Postato il da Francesco Della Torre
Mirko Boschetti
Mirko Boschetti
Moderator

Allora come detto sopra, io fossi in te, reinstallerei tutto da capo, visto che a me e anche Silver funzia bene, potrebbe trattarsi di una installazione corrotta... una volta fatto tutto importi da capo il tuo file iwzip, e dovrebbe essere a posto tutto...altrimenti prova a modificare il mio progetto visto che ti funzia, e vedi se rimane a posto o si scombina anche il mio....

Leggi di più
Postato il da Mirko Boschetti
Francesco Della Torre
Francesco Della Torre
User
Autore

Buona sera.

Allora: ho provato a fare come mi avete scritto, ma non è cambiato nulla.

Alla fine ho usato un'altra strategia per il modulo "lungo": apertura in una finestra di pop-up (così l'utente dovrebbe fare poco caso allo spazio bianco alla fine) e, dopo che l'utente ha compilato il modulo, nella stessa finestra esce un messaggio che dice che la richiesta è stata accettata. Poi, dopo qualche secondo, questa finestra si chiude automaticamente (ho inserito codice HTML per fare  questa ultima operazione...sto imparando!).

Potete vedere il tutto su www.bottegaenergia.com, l'ho appena pubblicato. Mi rendo conto che così non ho risolto il problema...però la mia esigenza era (ed è) quella di essere on-line il prima possibile (ho lavorato al sito notte e giorno...).

Fatemi sapere, per favore, che ne pensate...sia del sito, sia del mio "escamotage". Tenendo conto che uso Website X5 da pochissimo tempo (siate indulgenti...Embarassed).

Ora vi chiedo: ha senso chiudere questo post come "Risolto" oppure è meglio lasciarlo aperto, nel caso qualcuno - anche voi - avesse altre idee per risolvere il problema? Lo chiedo perchè, a quanto pare, è un problema soltanto mio e magari non interessa ad alcun utente.

Fatemi sapere, grazie!

Leggi di più
Postato il da Francesco Della Torre
Mirko Boschetti
Mirko Boschetti
Moderator

Secondo me, non è male neanche cosi...anzi direi che mi piace...per il Risolto, io aspetterei per sentire lo Staff se ha qualche consiglio in più...e nel frattempo che si risolve, se ti serve, visto che il tuo modulo lo ho, se vuoi ti inserisco le tue scritte, te lo rimando completo, tu copi incolli e lo metti online...(per chiudere la toppa, momentaneamente...) Wink

Leggi di più
Postato il da Mirko Boschetti
Francesco Della Torre
Francesco Della Torre
User
Autore

Va bene, grazie mille!

Approfitto per chiederti una cosa (ancora sul modulo mail...): ricevo via e-mail i dati inseriti dall'utente, con allegato file CSV; come mai nel campo "Condizioni di accettazione" non compare alcun valore?

Lo stesso succede all'utente che compila il modulo: quando riceve la mail di conferma, dove in coda si trova i dati inseriti, non compare il valore.

Ovvio che se mi arriva la mail le condizioni sono state accettate (altrimenti non si può cliccare su "Invia"), però è strano, non trovi?

Allego un file di esempio (Excel, convertito da CSV arrivato dal sito come prova) ed uno screenshoot.

Leggi di più
Postato il da Francesco Della Torre
Mirko Boschetti
Mirko Boschetti
Moderator
Francesco Della Torre
Va bene, grazie mille! Ovvio che se mi arriva la mail le condizioni sono state accettate (altrimenti non si può cliccare su "Invia"), però è strano, non trovi?

Va bene...quindi lo faccio e lo metto qui???

Non lo avevo notato, anche perchè come hai scritto tu, se arriva... Laughing

Leggi di più
Postato il da Mirko Boschetti
Mirko Boschetti
Mirko Boschetti
Moderator

Fatto... se serve preleva, altrimenti come non detto...ciaoooo

Leggi di più
Postato il da Mirko Boschetti
Francesco Della Torre
Francesco Della Torre
User
Autore

Ciao Mirko, grazie mille.

Il sito è on-line: www.bottegaenergia.com.

Grazie per tutti gli ottimi consigli!!! Smile

Leggi di più
Postato il da Francesco Della Torre