WebSite X5Help Center

 
Adrian G.
Adrian G.
User

Pro 2019.3 error  en

Autor: Adrian G.
Visitado 238, Seguidores 1, Compartilhado 0  

Hi, Every time I try and create a new website by selected the "Create a New Project" option it immediately comes up with an error saying "An error has occurred. This application will be closed and the project file will be saved in a temporary copy that can be restored at startup....." it then captures all this info and emails it to yourselves. This problem started in 2019.2.x and since then I have had no response from WebsiteX5 Support regarding this issue. I have even tried uninstalling and re-installing. Tried a different PC. But it is the exact same. However existing Websites works fine opening etc.

What can I do to fix this issue please as it is really frustrating now.

The error code is as follows:-

(Platform: x64) 11/8/2019 10:56:58 AM.430 [EXCEPTION] Unrecognized Image Type. Atalasoft.dotImage at Atalasoft.Imaging.Codec.RegisteredDecoders.GetDecoder(Stream stream) at Atalasoft.Imaging.AtalaImage.a(Stream A_0, Int32 A_1, ProgressEventHandler A_2) at WebsiteX5.BL.TemplateMetadata.GetPreview(Int32 width, Int32 height, Image noPreviewImage) at A.GIF.W(Object , Int32 , Int32 , Image ) at A.EN.W(String ) at System.Windows.Forms.ListView.OnSelectedIndexChanged(EventArgs e) at System.Windows.Forms.ListView.InsertItemsNative(Int32 index, ListViewItem[] items) at System.Windows.Forms.ListView.OnHandleCreated(EventArgs e) at System.Windows.Forms.Control.WmCreate(Message& m) at System.Windows.Forms.Control.WndProc(Message& m) at System.Windows.Forms.ListView.WndProc(Message& m) at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam) 11/8/2019 10:56:58 AM.024 [INFO] Loading System.Data, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 11/8/2019 10:56:57 AM.899 [INFO] Loading Atalasoft.dotImage.Lib, Version=9.0.2.43320, Culture=neutral, PublicKeyToken=2b02b46f7326f73b 11/8/2019 10:56:57 AM.867 [INFO] Loading Atalasoft.Shared, Version=3.0.0.4, Culture=neutral, PublicKeyToken=2b02b46f7326f73b 11/8/2019 10:56:56 AM.961 [INFO] Loading Microsoft.WindowsAPICodePack.Shell, Version=1.1.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35 11/8/2019 10:56:51 AM.355 [INFO] Loading Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null 11/8/2019 10:56:51 AM.230 [INFO] wizProjectSelection 11/8/2019 10:56:48 AM.023 [INFO] Loading System.ServiceModel, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 11/8/2019 10:56:47 AM.773 [INFO] wizStart 11/8/2019 10:56:47 AM.367 [INFO] Loading WebSiteX5.Resources, Version=2019.3.5.0, Culture=neutral, PublicKeyToken=55265808593be4c5 11/8/2019 10:56:47 AM.102 [INFO] Loading CefSharp.WinForms, Version=57.0.0.0, Culture=neutral, PublicKeyToken=40c4b6fc221f4138 11/8/2019 10:56:46 AM.742 [INFO] Loading CefSharp, Version=57.0.0.0, Culture=neutral, PublicKeyToken=40c4b6fc221f4138 11/8/2019 10:56:46 AM.680 [INFO] Loading CefSharp.Core, Version=57.0.0.0, Culture=neutral, PublicKeyToken=40c4b6fc221f4138 11/8/2019 10:56:46 AM.508 [INFO] Loading WebSiteX5.Browser, Version=6.0.1.0, Culture=neutral, PublicKeyToken=90163a1b10d8b8a5 11/8/2019 10:56:46 AM.383 [INFO] Opening the Main Window 11/8/2019 10:56:46 AM.383 [INFO] Creating Wizard Manager 11/8/2019 10:56:46 AM.336 [INFO] Configuring Form Main 11/8/2019 10:56:39 AM.917 [INFO] Creating WBE 11/8/2019 10:56:39 AM.901 [INFO] Updating Libraries - End 11/8/2019 10:56:39 AM.824 [INFO] Updating PluginApps 11/8/2019 10:56:38 AM.949 [INFO] Updating Tips 11/8/2019 10:56:36 AM.762 [INFO] Updating Templates 11/8/2019 10:56:33 AM.544 [INFO] Updating User Status 11/8/2019 10:56:33 AM.544 [INFO] Updating Libraries - Start 11/8/2019 10:56:33 AM.544 [INFO] Loading Libraries - End 11/8/2019 10:56:33 AM.529 [INFO] Loading Start Page... 11/8/2019 10:56:33 AM.482 [INFO] Loading Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null 11/8/2019 10:56:33 AM.482 [INFO] Loading Tips 11/8/2019 10:56:33 AM.404 [INFO] Loading Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null 11/8/2019 10:56:33 AM.388 [INFO] Loading Cart Steps Styles 11/8/2019 10:56:32 AM.857 [INFO] Loading Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null 11/8/2019 10:56:32 AM.404 [INFO] Loading Cell Formats 11/8/2019 10:56:31 AM.810 [INFO] Loading Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null 11/8/2019 10:56:30 AM.732 [INFO] Loading Atalasoft.dotImage, Version=9.0.2.43320, Culture=neutral, PublicKeyToken=2b02b46f7326f73b 11/8/2019 10:56:30 AM.732 [INFO] Loading Rebex.Ftp, Version=4.0.6426.0, Culture=neutral, PublicKeyToken=1c4638788972655d 11/8/2019 10:56:30 AM.700 [INFO] Loading Image Editor Properties 11/8/2019 10:56:30 AM.623 [INFO] Loading Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null 11/8/2019 10:56:30 AM.607 [INFO] Loading Templates 11/8/2019 10:56:30 AM.451 [INFO] Loading PluginApps 11/8/2019 10:56:30 AM.404 [INFO] Loading Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null 11/8/2019 10:56:30 AM.404 [INFO] Loading Buttons Styles 11/8/2019 10:56:30 AM.372 [INFO] Loading Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null 11/8/2019 10:56:30 AM.357 [INFO] Loading Buttons 11/8/2019 10:56:29 AM.372 [INFO] Loading Languages 11/8/2019 10:56:29 AM.341 [INFO] Loading Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null 11/8/2019 10:56:29 AM.326 [INFO] Loading Currencies 11/8/2019 10:56:29 AM.326 [INFO] Ensure Projects Folder Exists 11/8/2019 10:56:29 AM.169 [INFO] Loading Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null 11/8/2019 10:56:29 AM.138 [INFO] Loading Settings 11/8/2019 10:56:28 AM.951 [INFO] Loading Libraries - Start 11/8/2019 10:56:28 AM.951 [INFO] Installing Libraries - End 11/8/2019 10:56:28 AM.935 [INFO] Installing Libraries - Start 11/8/2019 10:56:28 AM.919 [INFO] Splash Screen 11/8/2019 10:56:28 AM.701 [INFO] Loading WebsiteX5.Localization, Version=2019.3.9.1, Culture=neutral, PublicKeyToken=9200094a554074ea 11/8/2019 10:56:28 AM.263 [INFO] Loading DevComponents.DotNetBar2, Version=12.7.0.3, Culture=neutral, PublicKeyToken=7eb7c3a35b91de04 11/8/2019 10:56:28 AM.044 [INFO] Starting Form Main 11/8/2019 10:56:27 AM.013 [INFO] Loading System.Management, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a 11/8/2019 10:56:26 AM.966 [INFO] Loading Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null 11/8/2019 10:56:26 AM.951 [INFO] Checking Licence 11/8/2019 10:56:26 AM.951 [INFO] Looking for Referrer 11/8/2019 10:56:26 AM.951 [INFO] Looking for Startup Arguments 11/8/2019 10:56:26 AM.919 [INFO] Loading System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a 11/8/2019 10:56:26 AM.919 [INFO] Loading System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35 11/8/2019 10:56:26 AM.888 [INFO] Loading System.IO.Abstractions, Version=2.1.0.178, Culture=neutral, PublicKeyToken=96bf224d23c43e59 11/8/2019 10:56:26 AM.872 [INFO] Checking Local App Data Folder 11/8/2019 10:56:26 AM.872 [INFO] Cleaning Startup Path

Publicado em
16 RESPOSTAS - 2 ÚTEIS
Aleksej H.
Aleksej H.
Moderator

Hello.I sent a request about your situation to the company employees.Expect an answer from them here in the comments.

Ler mais
Publicado em de Aleksej H.
A. Kris
A. Kris
User

Yes, I use 2019.2. I noticed this problem! I confirm!

Ler mais
Publicado em de A. Kris
Incomedia
Stefano G.
Incomedia

Hello Adrian

The issue you're reporting seems to indicate some kind of malfunction with the .NET libraries currently installed on your computer.

I would like to ask you to proceed as follows in order to analyze and attempt to fix this situation:

To repair the .NET Frameworks 3.5 and 4 you need as first to use following cleanup tool to remove .NET 4:
http://cid-27e6a35d1a492af7.skydrive.live.com/self.aspx/Blog_Tools/dotnetfx_cleanup_tool.zip
Once done go to Control Panel then choose Programs and Features and then click on Turn Windows features on or off. Clear the check box for Microsoft .NET Framework 3.5.1 and then click on OK. After Windows disables the feature you will need to go back to re-enable Microsoft .NET Framework 3.5.1
This procedure can take some time to deactivate and activate .NET 3.5.1 and once done reinstall .NET 4 after downloading it from following link:
http://www.microsoft.com/en-us/download/details.aspx?id=17718

Should this not work, you should give the .NET reparation tool a try:

Download this from https://msdnshared.blob.core.windows.net/media/MSDNBlogsFS/prod.evol.blogs.msdn.com/CommunityServer.Components.PostAttachments/00/08/99/90/04/netfx_setupverifier_new_2015_12_18.zip then open the .zip file and start the netfx_setupverifier.exe. This will check if your .net frameworks are corrupted and if it finds any errors, you can restore them with this https://www.microsoft.com/en-us/download/details.aspx?id=30135 (select NetFxRepairTool.exe and proceed to download) . If even this last tool is not able to fix the error there probably are there issues in your system you need to check out. We can eventually move on to analyzing this later on

Try this out and let me know if it fixes your issue

Thank you

Stefano

Ler mais
Publicado em de Stefano G.
Adrian G.
Adrian G.
User
Autor

Hi Stefano,

I tried your options above and even on the last one it says netfx 4 is verified 100%.

However the problem still occurs.

When I open WebsiteX5 Pro and click on the link to create a new website it immediately comes up with an error as stated above.

Please can someone assist me to resolve this issue once and for all properly as it is very urgent please.

Thank You!!

Stefano G.
Hello Adrian The issue you're reporting seems to indicate some kind of malfunction with the .NET libraries currently installed on your computer. I would like to ask you to proceed as follows in order to analyze and attempt to fix this situation: To repair the .NET Frameworks 3.5 and 4 you need as first to use following cleanup tool to remove .NET 4: http://cid-27e6a35d1a492af7.skydrive.live.com/self.aspx/Blog_Tools/dotnetfx_cleanup_tool.zip Once done go to Control Panel then choose Programs and Features and then click on Turn Windows features on or off. Clear the check box for Microsoft .NET Framework 3.5.1 and then click on OK. After Windows disables the feature you will need to go back to re-enable Microsoft .NET Framework 3.5.1 This procedure can take some time to deactivate and activate .NET 3.5.1 and once done reinstall .NET 4 after downloading it from following link: http://www.microsoft.com/en-us/download/details.aspx?id=17718 Should this not work, you should give the .NET reparation tool a try: Download this from https://msdnshared.blob.core.windows.net/media/MSDNBlogsFS/prod.evol.blogs.msdn.com/CommunityServer.Components.PostAttachments/00/08/99/90/04/netfx_setupverifier_new_2015_12_18.zipthen open the .zip file and start the netfx_setupverifier.exe. This will check if your .net frameworks are corrupted and if it finds any errors, you can restore them with this https://www.microsoft.com/en-us/download/details.aspx?id=30135(select NetFxRepairTool.exe and proceed to download) . If even this last tool is not able to fix the error there probably are there issues in your system you need to check out. We can eventually move on to analyzing this later on Try this out and let me know if it fixes your issue Thank you Stefano
Ler mais
Publicado em de Adrian G.
Esahc ..
Esahc ..
Moderator

Adrian, it is not simply a case of 3rd party antivirus/malware/firewall causing this issue?

Perhaps try disabling (or preferrably temporarily uninstalling any 3rd party protection and try again after re-boot).

If this does not work, my apologies for the inconvenience.

Ler mais
Publicado em de Esahc ..
Adrian G.
Adrian G.
User
Autor

Hi Esahc

It is a very valid point, but yes I have tried that as well. I even tried a different PC with nothing on except a fresh installation of Windows and WebsiteX5 Pro. Still the same.

I am sitting at this stage with new clients work to do and cannot use WebsiteX5. 

So unless we get this resolved very soon I will need to look at alternative Web Design Packages, which will be sad as I have been a client of WebsiteX5 since V5 upwards and have purchased all the various addons.

Esahc ..
Adrian, it is not simply a case of 3rd party antivirus/malware/firewall causing this issue? Perhaps try disabling (or preferrably temporarily uninstalling any 3rd party protection and try again after re-boot). If this does not work, my apologies for the inconvenience.
Ler mais
Publicado em de Adrian G.
Esahc ..
Esahc ..
Moderator

Adrian, my apologies.

Which template are you opening when creating a new project? Does the same thing happen if you open a blank (empty) template?

If you go to step 5 and export an existing project, can you import that project (this will not overwrite your project)?

I assume all PC's are win 10

Ler mais
Publicado em de Esahc ..
Adrian G.
Adrian G.
User
Autor

Hi Esahc, 

The error occurs the moment I click on the Open WebsiteX5 Pro, then click Start.

On the page where it shows the websites and the top option saying "Create a new project".

I click on "Create a new project", with the arrow and immediately it gives me the error which I have attached as the screenshot below.

It does not even allow me to get to the point of selecting a blank or any other template.

Both PCs tested on is Windows 10.

Esahc ..
Adrian, my apologies. Which template are you opening when creating a new project? Does the same thing happen if you open a blank (empty) template? If you go to step 5 and export an existing project, can you import that project (this will not overwrite your project)? I assume all PC's are win 10
Ler mais
Publicado em de Adrian G.
Esahc ..
Esahc ..
Moderator

Adrian, this makes no sense. You say 2 different PC's, one a clean Windows install, if this is the case there must be some common factor.

Are you working across the network, on a USB device or perhaps one drive? All of these things are problematic. WX5 should only be worked on locally (although multiple sata hard drives in the one PC cause no issue). If a user is using one of the above I can only implore that they make frequent use of Step 5, export project.

None of the above?

Please disconnect from the internet and/or lan and then start WX5 (perhaps you modem or network has an issue?)

Still no joy? That only leaves software running that is common to each machine but is in conflict (like the old lavasoft software issue). Or perhaps a required component (C++ 64bit & 32bit) is missing from both. If all else has failed, are you in a position to totally wipe and re-install Windows on the second PC and install C++ (32 & 64bit) + .net?

https://helpcenter.websitex5.com/pt/post/188230

And just a question, in your first post you said "However existing Websites works fine opening etc." - is this still the case?

I look forward to a reply, I am more than a little intrigued.

Ler mais
Publicado em de Esahc ..
Adrian G.
Adrian G.
User
Autor

Hi Esahc,

Yes it is a wierd fault.

I tried now again with the internet/network disabled totally and still the same.

As I mentioned, I did set up a complete new PC with ONLY WIndows 10 Pro 64 Bit Installed and Website X5 Pro. 

Nothing else on that machine and still the same fault.

On the one I am working on it is a laptop, with Windows 10 SL, Avast/AVG Business, MS Office 365, Corel Draw X8, WebsiteX5 Pro, Ashampoo Photo Commander. Thats it.

When I open existing websites designed on WebsiteX5 Pro, they open 100%.

However it is just when I want to create a new website.

I have taken a video to show you but it is 15Mb so it is to big to upload here.

Do you have a whatsapp number I can send you the video to see?

My whatsapp number is +27607860001.

Thanks

Esahc ..
Adrian, this makes no sense. You say 2 different PC's, one a clean Windows install, if this is the case there must be some common factor. Are you working across the network, on a USB device or perhaps one drive? All of these things are problematic. WX5 should only be worked on locally (although multiple sata hard drives in the one PC cause no issue). If a user is using one of the above I can only implore that they make frequent use of Step 5, export project. None of the above? Please disconnect from the internet and/or lan and then start WX5 (perhaps you modem or network has an issue?) Still no joy? That only leaves software running that is common to each machine but is in conflict (like the old lavasoft software issue). Or perhaps a required component (C++ 64bit & 32bit) is missing from both. If all else has failed, are you in a position to totally wipe and re-install Windows on the second PC and install C++ (32 & 64bit) + .net? https://helpcenter.websitex5.com/pt/post/188230 And just a question, in your first post you said "However existing Websites works fine opening etc." - is this still the case? I look forward to a reply, I am more than a little intrigued.
Ler mais
Publicado em de Adrian G.
Esahc ..
Esahc ..
Moderator

I do not have what's app, but will get it if all else fails. Can you bypass your modem, perhaps tether your phone to either laptop or PC. 

I once had a modem that had a poisoned DNS.

(snatching at straws now)

Ler mais
Publicado em de Esahc ..
Esahc ..
Esahc ..
Moderator

And, can you create an iwzip of an existing/working project. If yes, can you import it?

With the new PC, if avg, photo commander etc is also installed, please uninstall. Windows must be bare bones.

PS but with C++ 32&64 bit + .net

Ler mais
Publicado em de Esahc ..
Adrian G.
Adrian G.
User
Autor

Hi Esahc

On any of my existing websites I can export and import no problems.

It is just the problem with the new files.

I have also tried installing the latest dot net and c++ but still the same.

On the 2nd PC there is only Windows 10 and WebsiteX5 Pro, nothing else.

Esahc ..
And, can you create an iwzip of an existing/working project. If yes, can you import it? With the new PC, if avg, photo commander etc is also installed, please uninstall. Windows must be bare bones. PS but with C++ 32&64 bit + .net
Ler mais
Publicado em de Adrian G.
Adrian G.
Adrian G.
User
Autor

Incomedia / WebsiteX5 Support is there anybody who can give me an answer to this problem please?

It has been submitted numerous times via the crash report app, and now here.

Surely from the error code you can confirm what is wrong with the program?

Ler mais
Publicado em de Adrian G.
Esahc ..
Esahc ..
Moderator

I am sure incomedia will step in soon. I will step back. Good luck.

Ler mais
Publicado em de Esahc ..
Adrian G.
Adrian G.
User
Autor

Hi Esahc, 

I appreciate your assistance.

It is very frustrating as it should be straight forward to resolve with the info supplied. 

But at the moment I do not know what to do.

Thanks Esahc have a Blessed Day.

Esahc ..
I am sure incomedia will step in soon. I will step back. Good luck.
Ler mais
Publicado em de Adrian G.