WebSite X5Help Center

 
Larry W.
Larry W.
User

Unable to connect to Server.Temp Error. -TLS2.1 deemed insecure  en

Autor: Larry W.
Visitado 184, Seguidores 1, Compartilhado 0  

My host has recently upgraded his servers and no longer supports anything older than TLS2.1.

As such I can no longer updae any of my webpages as i get an 'unable to conenct to server. Temporary error, please try later" message. I have contacted my host and they advise it it WX5 evo. Please see below.

From my host:

Here is the error.

 Apr 27 17:05:46 uranus pure-ftpd: (?@106.71.221.251) [INFO] New connection from 106.71.221.251

Apr 27 17:05:46 uranus pure-ftpd: (?@106.71.221.251) [WARNING] Sorry, cleartext sessions and weak ciphers are not accepted on this server.#012Please reconnect using TLS security mechanisms.

Seems like the client you are using does not support latest security protocol. Please update to the latest version. Anything that is older than TLS1.2 today is deemed insecure as there are known hack method to them.

Publicado em
7 RESPOSTAS - 2 ÚTEIS
Esahc ..
Esahc ..
Moderator

Many years have passed since the release of v13 and as such it is no longer supported or being upgraded so if your host has implented a protocol that is not supported by v13 you will not be able to use the internal WX5 FTP.

You can use FileZilla or similar to upload your website by first exporting to disk.

Ler mais
Publicado em de Esahc ..
Larry W.
Larry W.
User
Autor

Thank you Esahc..Lovely, another piece of now crap software. I only updated about a year ago. Who on earth would I want to invest in WX5 again. You would think they would look after the exisitng customer. I now am in search of a similar product.

Ler mais
Publicado em de Larry W.
Larry W.
Larry W.
User
Autor
Larry W.
Thank you Esahc..Lovely, another piece of now crap software. I only updated about a year ago. Who on earth would I want to invest in WX5 again. You would think they would look after the exisitng customer. I now am in search of a similar product.

I just saw on WEbSite X5 site that "ALL of the paid options include: 'Updates and New versions' Saw does tha tmean I can get the latest vesion for free?

Ler mais
Publicado em de Larry W.
Esahc ..
Esahc ..
Moderator

According to the part of your profile I get to see you are only entitled to v13 evo, but perhaps you purchased a newer version last year under a different email address??

Is v13 (released in 2012) the only version you have available on your PC ?

If you did purchase under a different email address, log out of the helpcenter and log in again with the alternate address. Under your profile (top right) click on download to see which versions you are entitled to download, you will also find your license keys under Licences.

If you only have v13 it will continue to function perfectly. Exporting to disk and uploading via Filezilla (if necessary) only adds a couple of mouse clicks to the process. Should you choose to upgrade go back to your profile and click on Offers.

Before upgrading, please advise your hosting providers name so we can confirm it is not one that has recently been "troublesome".

Ler mais
Publicado em de Esahc ..
Paul M.
Paul M.
Moderator

Hello Larry,

Further to Gordon's (Esahc) helpful advice, don't forget that there is also the option in WebSite X5 to upload to the server via a secure shell (SSH) connection.

This option has existed in WebSite X5 since the earliest versions, and version 13 definitely had it (I recall using it in version 10 too!).

This would bypass your existing issue completely as the transfer is made using an entirely different protocol.

If you want to use it then be aware that the credentials and port settings will be different to that used for FTP/FTPS  -  check with your host and they should be able to sort it out for you.  It's a very secure and safe protocol.

SFTP - SSH File Transfer Protocol: this is an Internet protocol that guarantees secure data transfer, using remote encrypted sessions and remote file manipulation.  https://help.websitex5.com/en/v13/pro/esp_internet.htm

Kind regards,

Paul

Search the WebSite X5 Help Center

Ler mais
Publicado em de Paul M.
Larry W.
Larry W.
User
Autor

Thanks Esahc and Paul. I dont believe I used an different email address.

The website is a little misleading, ie: "one off payment" and "All of the paid options include Updates and New versions",  when in fact it doesn't appear to be the case at all. Otherwise I would have had the option to upgrade to evo 14 at no additional cost to myself.

Ler mais
Publicado em de Larry W.
Esahc ..
Esahc ..
Moderator

Larry, "update protection" came into existance during v14, it did not exist in v13

The wording you refer to is accurate from v14 onwards, if you now purchase WX5 you will be entitled to any new releases or versions for a period of 12 months.

However, if you are happy with the features available to you in v13 then Paul indicates the FTP should reliably work with your host if you change the settings.

Ler mais
Publicado em de Esahc ..