WebSite X5Help Center

 
Joe H.
Joe H.
User

H1 header  en

Autor: Joe H.
Visitado 387, Seguidores 1, Compartilhado 0  

I want control of my header tags (h1-h6).     What I think I'm designating as the 'h1' tag is completely something else.  Why is this?   

I understand it can be either the page title or website title, which I'm completely fine with.    I think that the h1 tag did change when I went to manual on the settings, but I can't locate where to change it to what I want.       

When I check all my headers online, h1 is the only one I'm having a problem with, the rest are good.

Publicado em
7 RESPOSTAS
Andre E
Andre E
Moderator

Why is it bad?

If there is an error it's a different colour red and you will get a small pop up why it s not good.

So if you worry about the colour then don't.

You can set the H1-6 tags in step1 -> advanced TAB -> website optimization seo -> HTML-tag TAB

But it looks good to me it's set on your header object and that is good readable. For SEO use it does not make a difference if you use h1 or h2.

maybe i don't understand the question, in that case please elaborate.

THX

Ler mais
Publicado em de Andre E
Joe H.
Joe H.
User
Autor

The color is not the problem, that was used to point out that the h1 tag used for the site is , Badman Charters, I need to use different word(ing).  I read that it is supposed to use the WEBSITE TITLE or PAGE TITLE.  This is neither.  In our business we must appropiate keywords in the h1 header.  I haven't been able to achieve that.  

My website title and page title both use the both very similar keywords.  In our business here, it's very competitive and using correct keyword/phrases is important.    This is neccessary for my SERP's. 

Ler mais
Publicado em de Joe H.
Joe H.
Joe H.
User
Autor

I guess what I'm trying to say is I want to manually control all header tags (h1-h6), especially the h1.   It seems  I do not have control of my h1 heading, I want it to be of what I choose or possibly my Page Title or Website Title in this structure.   In manual, where is the h1 chosen from in my website on Pro, that is viewed in the source code used as the h1 tag simply found?  Because what's there is not what I want to use.  

Ler mais
Publicado em de Joe H.
Andre E
Andre E
Moderator

Hello Joe,

ok, clear.

does this help then?

https://guide.websitex5.com/en/support/solutions/articles/44001796925-how-to-manually-set-tag-title-and-description-for-a-page

check also the link in this guide document.

****

Else do it completly manualy, set it to off inx5.

use a text or html object ( if text set HTML on with button in text object)

then set tag's your self by writing <h1>this is my most important description</h1>

see also: https://www.w3schools.com/tags/tag_hn.asp

****

check results here:

https://adresults.nl/tools/heading-tag-checker/


to see how it's set.

Ler mais
Publicado em de Andre E
Joe H.
Joe H.
User
Autor

Ok, to begin with what you were telling me may be somewhet correct.  I was aware of what you sent me and the end result was the image I sent you at the first entry of this post.  My h1 showed a title for the site (which I don't know and could not figure out where it came from).    It also had a link in the code, a href="index.html".....Is this normal?

Getting creative, I went to   settings--> website optimization, seo  -->  clicked  'html tag'.  The row 'tag format for site pages'  I went to the right and there was 3 options : website tag or  title tag or a blank option.   I used the 'blank option' and below I used  'none' for automatic heading tag management and marked the set h1 - h6 tag for the ..........., saved work.   

I then went to pages --> and opened the top row for the page, added my h1 header, saved and went to preview and checked my page sources and it was correct.    I also earlier went to map --> page I was working --> properties and made the changes.

Does this look correct?  Why was a link for the page itself "a href="index.html" in the first place?  Do you see a problem with this code?

<div class="imTALeft"><h1 class="imHeading1">Lake Erie Fishing Charters for Walleyes, Smallmouth Bass, Perch</h1><div class="imTACenter"><b class="fs20lh1-5">Lake Ontario Salmon Charters</b></div></div>

Ler mais
Publicado em de Joe H.
Andre E
Andre E
Moderator

The code is not complete so it's hard to check. you can check code for error's by using ctrl-U in your browser. red with a popup, is mostly incorrect code.

i suspect you set a link on the image to return to the home page, then it's corrcet. it's normal to do that so there is an easy way for visitors to return to the home page.

I see only 1 thing wrong in code:

<metaname="robots" content="noodp" /><linkrel="dns-prefetch" href="https://https://analytics.google.com/analytics/web/?et" target="_blank" rel="nofollow">https://https//analytics.google.com/analytics/web/?et&authuser#/home/a3495406w6619838p6850678/.com">https://https://analytics.google.com/analytics/web/?et&authuser#/home/a3495406w6619838p6850678/.com">

probably in the head text you set twicelike:  https://https:// .

check step1 advanced tab -> statistics and code -> Code TAB -> i gues before closing the head tag pulldown.

Ler mais
Publicado em de Andre E
Joe H.
Joe H.
User
Autor

That is an easy fix.  I'll keep playing with the software and sooner or later figure out what I'm trying to accomplish.  We're a really small market here, but very competitive.  Making the move to the Pro version alone has help the site improve on google audits.   Loading speed is just one very important factor for our ranking.  My biggest adversary is simply the google algorithem.    Thank you!

Ler mais
Publicado em de Joe H.