WebSite X5Help Center

 
Виталий С.
Виталий С.
User

Не выгружаются страницы  ru

Автор: Виталий С.
Просмотрено 285, Подписчики 1, Размещенный 0  

Здравствуйте. При выгрузке сайта, на сервер не выгружаются некоторые страницы, в том числе index, хотя в списке выгружаемых файлов они есть.

Размещено
17 Ответы - 1 Полезно - 1 Корректно
Виталий С.
Виталий С.
User
Автор

Нашел, выгружаются, но не открываются.

Читать больше
Размещено От Виталий С.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator

... LINK ...?...

ciao

Читать больше
Размещено От  ‪ KolAsim ‪ ‪
Aleksey K.
Aleksey K.
User

а нсли на диск сайт скинуть работает?

Читать больше
Размещено От Aleksey K.
Виталий С.
Виталий С.
User
Автор
Aleksey K.
а нсли на диск сайт скинуть работает?

Да, с диска работает. Не открываются только .php-файлы. Может хостер виноват?

Читать больше
Размещено От Виталий С.
К У
К У
User
Лучший пользователь месяца RU
Виталий С.
Aleksey K. а нсли на диск сайт скинуть работает? Да, с диска работает. Не открываются только .php-файлы. Может хостер виноват?


Версия PHP 7.1 на хостинге, или нет?

Читать больше
Размещено От К У
Виталий С.
Виталий С.
User
Автор
К У
Версия PHP 7.1 на хостинге, или нет?

Версии PHP 5.2, 5.3, 5.4 и 5.6

Читать больше
Размещено От Виталий С.
К У
К У
User
Лучший пользователь месяца RU
Виталий С.
К У Версия PHP 7.1 на хостинге, или нет? Версии PHP 5.2, 5.3, 5.4 и 5.6


Для нормальной работы PHP-сайта нужна версия PHP не ниже чем 7.1 (при этом выше чем 7.1 не нужно ставить).

Читать больше
Размещено От К У
Виталий С.
Виталий С.
User
Автор
К У
Для нормальной работы PHP-сайта нужна версия PHP не ниже чем 7.1 (при этом выше чем 7.1 не нужно ставить).

Раньше все работало.

Читать больше
Размещено От Виталий С.
К У
К У
User
Лучший пользователь месяца RU
Виталий С.
К У Для нормальной работы PHP-сайта нужна версия PHP не ниже чем 7.1 (при этом выше чем 7.1 не нужно ставить). Раньше все работало.


Раньше земля была плоская и держалась на трёх китах. ©
На старых версиях PHP, новые версии PHP-сайтов нормально работать не будут.

Читать больше
Размещено От К У
Виталий С.
Виталий С.
User
Автор
К У
Раньше земля была плоская и держалась на трёх китах. © На старых версиях PHP, новые версии PHP-сайтов нормально работать не будут.

Но, меня все устраивало, пока работал в старух версиях программы. Теперь, что, хостинг менять?

Читать больше
Размещено От Виталий С.
Aleksey K.
Aleksey K.
User

версию php поменять и все

Читать больше
Размещено От Aleksey K.
Виталий С.
Виталий С.
User
Автор
Aleksey K.
версию php поменять и все

Где поменять?

Читать больше
Размещено От Виталий С.
Виталий С.
Виталий С.
User
Автор

Ответ провайдера:

Ошибка 500 говорит о проблемах самого сайта (Настроек, ошибок скриптов и тд) и пишется в логе в панели хостинга в разделе Журнал
Сейчас видим следующую ошибку:
[Wed Apr 17 13:41:51 2019] [error] [client 217.65.0.2] PHP Parse error: syntax error, unexpected '[' in /var/www/vh206748/data/www/saksonovv.ru/res/class.phpmailer.php on line 304
Как видите ошибка в символе.

Читать больше
Размещено От Виталий С.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Виталий С.

(It > Ru) ... у вас неадекватная, недостаточная версия PHP на вашем сервере, это: PHP/5.3.29
... вам нужно связаться с сервером и получить минимальную назначенную версию PHP/5.6+ ... еще лучше, если это PHP/7x

.

ciao

.

Читать больше
Размещено От  ‪ KolAsim ‪ ‪
Виталий С.
Виталий С.
User
Автор
 ‪ KolAsim ‪ ‪
(It > Ru) ... у вас неадекватная, недостаточная версия PHP на вашем сервере, это: PHP/5.3.29 ... вам нужно связаться с сервером и получить минимальную назначенную версию PHP/5.6+ ... еще лучше, если это PHP/7x
В предыдущем посте я написал ответ провайдера, что ошибка в сайте.

Читать больше
Размещено От Виталий С.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator

... у вас есть > PHP/5.3.29  ...!...
... минимум должен быть > PHP/5.6+ ... или выше

.

Читать больше
Размещено От  ‪ KolAsim ‪ ‪