WebSite X5Help Center

 
Kurt Hiller
Kurt Hiller
User

Menu Tree in Shopping Cart Malfunctioning  en

Autor: Kurt Hiller
Besucht 133, Followers 1, Geteilt 0  

I added a product to my shopping cart.  When I pressed the Preview icon WebSiteX5 Professional 13 created the project files and opened the preview in the web browser.  The product that I had put in the shopping cart did not appear in the preview with the rest of the products.  I closed the preview window to return to Website X5 to see what I might have done wrong and found that the product that I had listed had disappeared from the Shopping Cart menu as well as had half of the previous products I had listed.  I closed WebSite X5 thinking that there was some initiation malfunction and opened it again.  When I went to the shopping cart, my products were still missing from the menu, so I did another preview, In the preview window I could see all of my products, but not the last one I had added and two of the products were missing their photographs.  I don't understand what is happening because a week ago when I added a product I had no problems.

Best regards, 

Kurt

Best

Gepostet am
7 ANTWORTEN - 1 NüTZLICH
Aleksej H.
Aleksej H.
Moderator

Hello. Try clearing the embedded browser cache. To do this, press CTRL button and preview.

The situation you described may be related to cookies.

I recommend testing the online store on a hosting or on a local server such as XAMPP.

Mehr lesen
Gepostet am von Aleksej H.
Kurt Hiller
Kurt Hiller
User
Autor

Thanks Aleksej.  This did restore my product index in the Shopping Cart and the missing photos from previous listings.  However, the new product I listed is not showing in the preview and a product that I listed and deleted yesterday must still have a remenent, because I can not add this item again.  When I "OK" the entry I get an error message saying that I cannot list the same item twice.

Best regards

Kurt

Mehr lesen
Gepostet am von Kurt Hiller
Aleksej H.
Aleksej H.
Moderator

I recommend testing site on a local server or hosting.I also recommend testing sites from different browsers.Browsers must be current version, with default settings and without additional plug-ins and extensions.

Mehr lesen
Gepostet am von Aleksej H.
Kurt Hiller
Kurt Hiller
User
Autor

I installed XAMPP and it seems to be installed okay -- I don't have any warnings.  I don't see anything that would directly connect XAMPP to the website.  The problem still exists even when I try to view the shopping cart in the other browsers on my computer.  I've looked over the browsers and they do seem to be on the default settings.  I put a post on the blog and there does not seem to be any problems there.  Also the listings in the shopping cart disappear and reappear in the menu tree when I preview them.  Is there a problem, possibly with WebSite X5 13 being outdated.  Apparrently, I have a license number for WebSite X5 16, but I haven't migrated to a higher version because I can't find instructions on how to make the transfer.

Best regards, 

Kurt 

Mehr lesen
Gepostet am von Kurt Hiller
Aleksej H.
Aleksej H.
Moderator

"Is there a problem, possibly with WebSite X5 13 being outdated." - for the 13th version on the hosting you need PHP 5.6.

"but I haven't migrated to a higher version because I can't find instructions on how to make the transfer.":

1) Export the site project to version 13.


2) Import the site project into the 16th version.


3) Check the entire site and make changes to it, if necessary.

Mehr lesen
Gepostet am von Aleksej H.
Kurt Hiller
Kurt Hiller
User
Autor

Hi Aleksej, 

I solve the problem the Shopping Cart products not appearing in the preview.  I had had a simular problem a few years ago when I had to move a product to a new catagory and the product wasn't showing in the preview.  I had to go to the Product Catalog Object and tick a box to have it appear.  That is what I had to do in this case as well.  But it had been so long ago I had forgotton to even look at the Product Catalog Object.  

Thank you for the instructions on how to migrate my site to an upgraded version of WebSite x5.  I've been paying for these upgrades but not utilizing them out of fear that I would be practically rebuilding the site.

Thank you for all of your help and patience dealing with this issue.

Best regards, 

Kurt

Mehr lesen
Gepostet am von Kurt Hiller
Aleksej H.
Aleksej H.
Moderator

Glad your problem is resolved.

Mehr lesen
Gepostet am von Aleksej H.