WebSite X5Help Center

 
Jose Raúl H.
Jose Raúl H.
User

Urgente. Generic Error al finalizar la compra  en

Autor: Jose Raúl H.
Besucht 411, Followers 1, Geteilt 0  

He actualizado la web y no funciona correctamente el carro de la compra,

Cuando llgas al último paso, confirmación de compra tras aceptar las condiciones, el navegador se bloquea y lanza un mensage "Generic Error". El comprador no puede finalizar la compra, aunque tanto a él como a mi nos llegan los emails del pedido, el comprador puede finalizar su compra desde el botón efectuar pago que recibe en el mail con el resumen del pedido, pero no desde la web.

Restauré la web a una ersión anterior y funciona bien, pero h vuelto a actualizar y vuelve el problema, por lo que no es problema del servidor, es el programa el que sube algún archivo defectuoso y por eso no funciona bien.

Pueden hacer un pedido de prueba para comprobar mejor lo que ocurre?, no implica ningún compromiso de compra, por supuesto.

Necesito darle solución rápido al problema, por favor

Gepostet am
10 ANTWORTEN
Daniel W.
Daniel W.
User
Nutzer des Monats EN

(de)

Wird PHP 8.x verwendet und wurden die PHP-Fehlermeldungen beim Webhoster auf "off" eingestellt?

Ich wohne in Deutschland und bei meinem Webhosting-Anbieter Hosteurope kann man hier die PHP-Fehlermeldung im Kundenbereich deaktivieren, siehe Screensot unten

Oder Sie können den Webhoster bitten, die PHP-Fehlermeldung auf der Website zu deaktivieren.

(es)

¿Se está utilizando PHP 8.x y los mensajes de error de PHP se han configurado como "desactivados" en el servidor web?

Vivo en Alemania y con mi proveedor de alojamiento web Hosteurope puedes desactivar el mensaje de error de PHP en el área de clientes aquí.

O puede pedirle al proveedor de alojamiento web que desactive el mensaje de error de PHP en los sitios web.

-----

Mehr lesen
Gepostet am von Daniel W.
Franz-Josef H.
Franz-Josef H.
Moderator

¿Cuál es el nombre del sitio web?

Mehr lesen
Gepostet am von Franz-Josef H.
Jose Raúl H.
Jose Raúl H.
User
Autor
Franz-Josef H.
¿Cuál es el nombre del sitio web?

Hola, la web es www.artelicor.com

La version PHP del servidor 8.1.16

Si restauro los archivos del servidor a una versión anterior la web funciona, pero si actualizo la web deja de funcionar, como ahora mismo, la dejo así para ver si podeis ver una solución, yo pienso que es del programa, pero no lo se seguro.

Gracias

Mehr lesen
Gepostet am von Jose Raúl H.
Incomedia
Stefano G.
Incomedia

Hola Jose

Revisé el sitio web ahora mismo y puedo ver que funciona correctamente.

¿Ya solucionaste el problema o subiste una versión del sitio web que funciona? Si no es así, ¿podrías hacer que el error vuelva a aparecer para que pueda comprobarlo por ti?

Sigo disponible aquí

Stefano

Mehr lesen
Gepostet am von Stefano G.
Jose Raúl H.
Jose Raúl H.
User
Autor

Funciona porque restauré los archivos a una versión anterior, si actualizo no funciona, ahora son fechas de recibir pedidos en nuestro caso, si no funciona la web pierdo ventas, por eso tuve que restaurar,

Si quieres confirmame que día y horario te va bien para comprobar y actualizo para que lo veas durante unos momentos y luego vuelvo a restaurar para que funcione, hasta que sepamos donde está el fallo.

Gracias

Mehr lesen
Gepostet am von Jose Raúl H.
Daniel W.
Daniel W.
User
Nutzer des Monats EN

(de > es)

Puede exportar la versión incorrecta del sitio web a un subdirectorio (por ejemplo, /123test) en el espacio web.

----- WEbSite X5 -----

5 Exportar > Exportar el sitio web a Internet

URL del sitio web: https://example.org/123test/
Directorio de destino: /public_html/123test

------------------------

Luego, publique esta dirección web de prueba aquí para que los empleados de Incomedia puedan verificarla.

Mehr lesen
Gepostet am von Daniel W.
Incomedia
Stefano G.
Incomedia

Hola Jose

Revisé su sitio web y puedo confirmar que el problema es como se informa aquí:

Su proveedor de alojamiento contiene algún código que requiere que PHP v7.3 o superior esté habilitado. Probablemente tengas uno más antiguo activo en este momento

¿Podría pedirle a su proveedor de hosting que actualice PHP a 7.4?

Sigo disponible aquí

Stefano

Mehr lesen
Gepostet am von Stefano G.
Jose Raúl H.
Jose Raúl H.
User
Autor

Hola Stefano, como indique en un post anterior, la version php del servidor es la 8.1.16, la web ha estado funcionando perfecto hasta la última actualización, quieres decir que ahora volvamos a la version php 7.4?

Mehr lesen
Gepostet am von Jose Raúl H.
Incomedia
Stefano G.
Incomedia

Hola Jose

El error que encontré, según mi captura de pantalla, se refiere a algo llamado "Composer" que nuestro software no utiliza.

Esto significa que el error lo genera este componente "Composer", que probablemente esté siendo operado por el propio espacio de alojamiento.

No dudes en reenviarles la captura de pantalla que te envié para que puedan verificar esto por su parte.

Por lo que puedo ver, su sitio web en sí no tiene ningún problema, pero es causado por el componente "Composer" utilizado por el hosting.

Sigo disponible aquí

Stefano

Mehr lesen
Gepostet am von Stefano G.