WebSite X5Help Center

 
Sang Moon
Sang Moon
User

V17.0.4 PHP error  en

Autor: Sang Moon
Visitado 715, Followers 1, Compartido 0  

I have just upgraded from v16.3.1 to v17.0.4 and submit forms (php forms) do not work. 

So I uploaded my website using the v16.3.1 and the submit forms (php forms) do work.

Can anyone help?

Publicado en
6 RESPUESTAS
Claudio D.
Claudio D.
Moderator
Usuario del mes IT

version 17 need at least php version 5.6 or  higher on host

Leer más
Publicado en de Claudio D.
M. Sodré
M. Sodré
User

Atualizei para a versão 17.0.4 e quando publiquei meu site para teste a página do blog deu erro: PHP Parse error: syntax error, unexpected T_FUNCTION in E:\home\donamana\Web\res\x5engine.php on line 2015. Voltei para a versão anterior e o erro continuou.Como corrigir esse problema?

Leer más
Publicado en de M. Sodré
Alexandr T.
Alexandr T.
User

I confirm this error.

Incomedia WebSite X5 Evolution 17.0.4.0
Server: Apache/1.3.41
PHP Version: 5.2.17
x5engine.php, line 2015

"version 17 need at least php version 5.6 or  higher on host"
Where are these requirements stated?

Leer más
Publicado en de Alexandr T.
Wayne B.
Wayne B.
User

I am not happy that this was not stated clearly on the Changelog for the new version! Luckily I only updated one of my sites by using v17. I may have to roll back as well.

Leer más
Publicado en de Wayne B.
Alexandr T.
Alexandr T.
User

I changed the PHP version on the server.
Now this: Apache / 1.3.41 (Unix) mod_wsgi / 3.3 Python / 2.7.2 PHP / 5.5.5
Incomedia WebSite X5 Evolution 17.0.4.0 works without errors!

P.S. PHP version 5.5.5 is the highest possible version supported on the server (my host provider).

Leer más
Publicado en de Alexandr T.
Incomedia
Stefano G.
Incomedia

Hello everyone.

I can confirm that as reported by Claudio, the newest version requires at least PHP 5.6 installed.

I apologize for the trouble this change might have caused, but consider that most hostings are going to discontinue version 5.6 as well, since it is now an outdated version of PHP, and are moving towards the newest PHP 7.x

Version older than 5.6 are nowadays very rare and might bring along several performance and security issues, for which I'd suggest upgrading your hosting's PHP as soon as possible, or considering swapping hosting in case such possibility is not offered.

Thank you for your understanding

Stefano

Leer más
Publicado en de Stefano G.