WebSite X5Help Center

 
Wes D.
Wes D.
User

Access to Locked Pages Fails  en

Autor: Wes D.
Visitado 244, Followers 1, Compartido 0  

I recently upgraded to EVO 2019.1.6 and access after uploading my project, access to all locked pages fails. Normally with each new start of the website, when someone first tries to access a locked page, it would go to the "Register/Login" pages. Now it fails (see attached); can't seem to open the login page. This not been changed from when it worked with previous versions of Evo. The attached failed page shows our website's address so happy for you to give it a try.

This is critical because, since nearly all the pages are locked on this website, so I effectively don't have a website.

If you do not have a readily availabe solution, then how do I go back to my previous version?    

BTW - a have already given up on my move to X5 PRO which had even worse failures. Can you mind me how I request a refund?

Wes Dayton

Publicado en
11 RESPUESTAS - 1 CORRECTO
Paul M.
Paul M.
Moderator

Hello Wes,

The actual error message you are getting when trying to access that particular page suggests strongly that there is a problem server side.  I investigated further and notice that you have old version 12 WebSite X5 files still resident on the server along with the new 2019.1 files.

My advice in the first instance would be to purge all older/redundant WebSite X5 files from your site directory.

You could do this on a file by file basis, but by far the quickest and surest way is to delete ALL files in your site directory (on the server), then do a full and complete upload from WebSite X5 version 2019.1

Please keep us updated.

As regards a refund on the Pro version, please wait for an official reply from the Incomedia team: I have marked this post for their specific attention.

Kind regards,

Paul

https://webx5.pro

Leer más
Publicado en de Paul M.
Incomedia
Stefano G.
Incomedia

Hi Wes

As correctly mentioned by Paul, the error you're showing in the screenshot most likely indicates an issue at server level.

Make sure your server is running PHP v5.6 or higher (even better if 7.x). It is mandatory for your website to work correctly since v17.

Contact your hosting support in order to get your PHP upgraded easily, it should be a default possibility for all hostings

Try this out and let me know if this helped

Thank you

Stefano

Leer más
Publicado en de Stefano G.
Wes D.
Wes D.
User
Autor

Thanks very much - sounds like a possible solution. Problem is that I have poor technical skills and when you suggest remove files from my site directory. Paul obviously got to it, but I have never had any direct contact with my service provider (Melbourne IT) after initial set-up other than to push the X5 Export button.

But if Paul was able to find it, maybe some simple directions how I can do it?

Many thanks for quick response - Wes

Leer más
Publicado en de Wes D.
Paul M.
Paul M.
Moderator

Hello again Wes,

You can delete files and folders on the server yourself using WebSite X5 in Step 5...  see this page from the help file (look in the Reference: Commands for going online section):

https://help.websitex5.com/en/v2019.1/pro/index.html?esp_internet.htm&utm_source=software&utm_medium=Pro_2019.1

However, if you are not comfortable in doing that then I'm sure your web host would oblige.  Or you can follow their step-by-step guide for using FileZilla, which makes working with files and folders on the server as easy as working with the same on your own PC:

https://support.melbourneit.com.au/articles/help/How-do-I-upload-and-download-files-via-FTP/?q=ftp&fs=Search&pn=1

Unfortunately this is not something that we can assist with ourselves unless you were to divulge your web hosting access credentials, and to be honest you should never do that on a public forum.

Likewise, only your webhost can help you to ensure that you are running the recommended version of PHP on your server, and that it is correctly configured.  You can contact them here:

https://www.melbourneit.com.au/contact-us/

Kind regards,

Paul

Leer más
Publicado en de Paul M.
Wes D.
Wes D.
User
Autor

Just letting you know that all is fixed and your assessment of the problem was correct. I enlist the help of my son-in-law who sait it was indeed a PHP problem, so he shanged the PHP-level for me (see attachment) which, as I understand ir caused PHP to reboot, which fixed the problem. Hope that makes sense. 

Thanks for your help - Wes

p.s. I haven't heard from anyone about cancelling/refunding my X5-PRO. Still doesn't work. 

Leer más
Publicado en de Wes D.
Esahc ..
Esahc ..
Moderator

Wes, your post is already marked for attention by incomedia, so I am sure they will address your refund request. 

If you do not wish to use pro you shouldn't have to, but be assured, if any project runs in EVO it will run in PRO absolutely as reliably.

Congratulations on resolving the PHP problem. Can we assume you achieved all you required using WX5 2019 Evolution, because if the project is currently in Professional (or has been opened and saved in PRO) then Evolution will not be able to open it.

Pro surely is a premium price compared to Evo, so I understand your wish to stay with the cheaper option (I did it once myself and stayed on evo for 2 version releases), but there are a number of PRO features I cannot live without (eg adding extra breakpoints to responsive sites, controlling breakpoints under responsive settings in step 4, Analize and SEO optimisation and the Optimiser (image shrinker) feature that is now only available in PRO and is no longer a standalone product) These few features make my life easy enough to justify the cost.

Good luck. . . . . 

Leer más
Publicado en de Esahc ..
Wes D.
Wes D.
User
Autor

I would very much like to move to PRO but still haven't managed to get anything to load, including the project we've just been working on. I have been doing some experimenting and I wonder if PRO handings large photos in galleries etc differently than EVO? In the past I didn't pay much attention to the size of photos because it seemed that EVO automatically cut them down to a suitable size for website viewing. From what I can see, PRO seems to load them "as is" and since most of my photos are about 20M, it never quite finishes loading the website. Is there any truth to my observations?

Wes

Leer más
Publicado en de Wes D.
Esahc ..
Esahc ..
Moderator

Wes, I am sure someone will correct me if I am wrong, but I believe pro handles photos and images exactly the same as evo. If you have the project in evo, have you gone to step 5, export project to create an iwzip file or are you simply attempting to open the existing project in pro?

If you open WX5 pro and select IMPORT then choose the iwzip file, does the project open?? (yes this could take some time but not forever).

If you can get the project into pro you have the option of returning to step 5 export and selecting optimize on export to significantly trim down picture sizes.

Please advise if you can successfully create an iwzip file.

Leer más
Publicado en de Esahc ..
Wes D.
Wes D.
User
Autor

Okay - I now have PRO running and have decided to persist. Not sure what the problem was but the version up now is PRO. One thing I thought might be of interest to be was I thought I once saw an option to export "with reduced sized images" but now I can't find it.

Thanks for everyone's help and tell the admin people I no longer want to cancel.

Wes  

Leer más
Publicado en de Wes D.
Esahc ..
Esahc ..
Moderator

Wes, go to step 5, export project. There is an option to optimize (reduce image sizes). When the iwzip has been created restart WX5, select import and use the new iwzip.

This will recreate your project (but will NOT overwrite the existing project) and the images will be optimised for website display.

Leer más
Publicado en de Esahc ..
Wes D.
Wes D.
User
Autor

Thanks - exactly what I was look for.

Wes

Leer más
Publicado en de Wes D.