WebSite X5Help Center

 
Randall H.
Randall H.
User

Error No conformation email sent to customer  en

Autor: Randall H.
Visitado 204, Followers 1, Compartido 0  

SMTP connect() failed In the Website Test on WebSite X5 worked fine for days check all settings

Publicado en
2 RESPUESTAS - 1 ÚTIL
Aleksej H.
Aleksej H.
Moderator

Hello.

  1. Check different mail sending scripts and their settings.
  2. Check that you have PHP 7.1 on your hosting.
  3. Try to delete all site files and upload it to hosting again.
  4. Check the recipient's spam folder.
  5. Check the spam level of your emails.
Leer más
Publicado en de Aleksej H.
Paul M.
Paul M.
Moderator
Usuario del mes EN

Hello Randall,

If this issue has just suddenly occurred and you have not made any changes to your WebSite X5 mail settings like you say, then it is almost certainly an issue on the server side rather than the client side.  Webhosts can and do make silent regular updates to their software, which is of course good in the interests of security; however, sometimes things can get 'broken' (this is exactly what happened in this thread)

This link from the official PHPMailer troubleshooting guide affirms this:

https://github.com/phpmailer/phpmailer/wiki/troubleshooting#smtp-error-could-not-connect-to-smtp-host

You will notice that the error is commonly caused by local network issues, but you say you have checked all settings (which should by the way include anti-virus/firewall configurations!)

So in the first instance I would recommend approaching your webhosting provider, describing the issue to them and asking for their comments and input.  You could also give them a link to this forum thread to help them understand better what it is you are asking of them.

Secondly, rule out any accidental changes to your email configuration on the server side (as opposed to client/Website X5 side) by using an email client like Windows Mail to send a test message using the exact same settings which you have currently specified in WebSite X5 Step 1 Settings > Advanced > Data Management > Email  -  if this also fails then check your email account settings in cPanel and compare them with the ones in WebSite X5...  do they match?

Another thought...  if you are using authenticated email over an SSL/TLS connection, has your certificate suddenly expired?

Please let us know how you get on.  We are all here to help if we can.

Kind regards,

Paul

https://webx5.pro

Leer más
Publicado en de Paul M.