WebSite X5Help Center

 
Kent B.
Kent B.
User

Error occurred while loading a project  en

Autore: Kent B.
Visite 390, Followers 1, Condiviso 0  

There is an error in XML document (991,2557)
I assume the numbers refer to line number and position.  I do not have any XML file that large (that I could find).  If I load the index file into browser all appears to be correct.  The problem is loading the project into X5 v16 again.  All worked OK a couple of days ago... AND of course dumbo forgot to backup.  Any solutions simple or otherwise?

Postato il
9 RISPOSTE
Esahc ..
Esahc ..
Moderator

Kent, this is a corrupted xml file in the project directory. You may be able to successfully restore your project by highlighting it, click backup, select a suitable candidate and click redo.

Good luck!!

Leggi di più
Postato il da Esahc ..
Kent B.
Kent B.
User
Autore

Esahc,  thanks for the reply.  There was nothing in project restore list.  I notice in another project (created in v16) the backup dir contains a heap of .iwprj2 files.  In this project there is a dir 'project.iwprj2' and the backup dir is empty.... is this related to my problem.  The current project was imported from an earlier version of X5pro to v16.  All the site files are OK and as previously said the site operates OK via local index file to browser.  Is it possible to use all the files and create a new version in X5??

Kent

Leggi di più
Postato il da Kent B.
Esahc ..
Esahc ..
Moderator

Kent

It is not directly possible to recreate the project from the files exported to a folder, although the site could be viewed in a browser and you could copy and paste to a new project.

If the backup files don't exist it will be because you have not uploaded the site to the internet using the built in FTP (when you do this a backup is automatically created), you could also have created a backup at any time by clicking the down arrow next to save.

I will assume that you upgraded the project from v16 to v17 by simply opening the project in v17 at which time WX5 would have offered to make a copy (backup), did you not let this happen??

In v17, v16 or earlier is there any chance you went to step 5 export, export project? If so you should still have the iwzip and this would make a great starting point to rebuild the site.

Can you provide a link to this site online?

Leggi di più
Postato il da Esahc ..
Kent B.
Kent B.
User
Autore

Esahc
The project was originated in v12/v13.  Is now in v16 (have not gone to v17).  I upload to web using the built-in X5 loader.  There are no files in the Backup dir.  I have a project, created in v16, which does have files in the Backup dir.  Is this a hangover problem from earlier versions?

members.iinet.net.au/~***

I have a recent version saved as a iwzip file. Is it possible to use this as a new version and copy and paste from the existing version?

Leggi di più
Postato il da Kent B.
Esahc ..
Esahc ..
Moderator

Kent, if you have a recent iwzip you have the perfect solution. Open wx5 v16, click import, select the iwzip and this will recreate your project to full working order. There should be very little need for cut and paste other than to update recent changes.

I cannot understand why there are no backups. Could it be that you have changed the default working directory at some time?

Leggi di più
Postato il da Esahc ..
Kent B.
Kent B.
User
Autore

Esahc,
There is some difference between the old and new.
I can not load the current version into X5, how then do I cut and paste existing files into the old zip version to reconstitute it?
Where does the corrupt xml file exist?  What do the numbers signify in the error message?

Leggi di più
Postato il da Kent B.
Esahc ..
Esahc ..
Moderator

Kent, open the replacement project in wx5

Either browse  in Windows explorer to where you saved the broken project and double click on index.html or simply open the online version if it is up to date.

Now you can simply copy from your version in the browser and paste that content into the he reborn project. If you have changed the structure in any way you will of course need to do this again in wx5.

  • Where is the corruption in the broken project? Probably in the project directory and the file called project.iwprj2 although there are other XML files in the directory as well.
Leggi di più
Postato il da Esahc ..
Kent B.
Kent B.
User
Autore

Esahc,  thanks for your replies. The problem is indeed the file, project.iwprj2.
I have a version of the project that works perfectly via a browser clicking on the index.html.  The problem is there is no .iwprj2 file, hence can not load it into X5.  can not modify the project or load it to web.

Any way around this?  Can a .iwprj2 be made some way?  The alternative of going to the last saved zip file is going to be pain.

Leggi di più
Postato il da Kent B.
Esahc ..
Esahc ..
Moderator

Kent, I have already explained this.

Import the iwzip you have from earlier. Fix it (update the project) by comparing it with your website when you open index.html in a browser.

Leggi di più
Postato il da Esahc ..