WebSite X5Help Center

 
Fabio B.
Fabio B.
User

Bugs multipli: url articoli del blog  it

Autore: Fabio B.
Visite 538, Followers 2, Condiviso 0  

Buongiorno Incomedia,

vorrei segnalare diversi problemi riscontrati relativi all'url degli articoli del blog.

  1. Di default come url viene impostato l'ip di localhost; il programma non segnala che al passo 5 non é stato ancora inserito l'url del sito e questo percorso locale rimane memorizzato nell'articolo; in seguito bisogna correggerlo manualmente; questo percorso se si usa come link per un livello della mappa non funziona; una volta inserito un percorso url per l'esportazione online al passo 5, questo verrà memorizzato come prima parte dell'url articolo solamente dopo un tentativo di esportazione e varrà solo per gli articoli creati successivamente.
  2. Qualora l'url del sito web sia troppo lungo per essere contenuto nel riquadro del programma, viene scorciato sostituendo la prima parte con tre puntini; se si copia/incolla questo url per creare un link da dare ad un livello della mappa verrà inserito tale e quale, cioè i tre puntini invece della prima parte dell'url giusto, e il link di nuovo non funzionerà; bisognerà correggere a mano il link.
  3. Se si vuole creare un menù fatto di livelli con links ad articoli del blog, é necessario copiare/incollare un pezzo per volta l'url degli articoli del blog (copia/incolla prima parte; copia/incolla seconda parte) con un continuo laboriosissimo apri e chiudi di finestre dall'articolo del blog alle proprietà del livello (e come ho detto sopra correggendo a mano gli stessi url uno per uno).
Postato il
10 RISPOSTE - 1 UTILE
Vincenzo Errico
Vincenzo Errico
User

+1

Leggi di più
Postato il da Vincenzo Errico
Fabio B.
Fabio B.
User
Autore

Io spero solo che queste correzioni vengano rese disponibili anche per la mia versione; non troverei affatto giusto dover comprare per forza la nuova versione per avere il programma funzionante a dovere.

Leggi di più
Postato il da Fabio B.
Mauro B.
Mauro B.
User

+1

Il problema del "localhost" viene segnalato da google nel testing data tool a questo indirizzo

https://search.google.com/structured-data/testing-tool/

Ci sono errori sui dati strutturati relativamente alle pagine del blog.

Provate anche voi inserendo il link del vostro blog.

Leggi di più
Postato il da Mauro B.
Giuseppe Guida
Giuseppe Guida
User

+1

Leggi di più
Postato il da Giuseppe Guida
Incomedia
Stefano G.
Incomedia

Buongiorno Fabio

Vorrei chiederti più informazioni sui punti in maniera da capire correttamente le problematiche:

1_ In poche parole, io apro un progetto nuovo e nel box grigio è indicato l'URL del localhost. Quello che intendi dire è che se tu decidi di fare copia e incolla di questo link per poterlo inserire all'interno di un livello, questo link non è aggiornato fino a che non lo metti al Passo 5 e poi esporti. Corretto? Quindi se tu volessi collegare un articolo ad un link, devi aspettare di aver esportato almeno una volta.

Se ho capito bene, una soluzione potrebbe essere che nel momento in cui io modifico l'URL al Passo 5, questo venga immediatamente cambiato anche al Passo 1 nel blog senza dover esportare?

2 & 3: Queste questioni credo di averle comprese e sono leggermente diverse. Se ho capito correttamente, tu vorresti poter copiare il link finale dell'articolo per poterlo usare in un livello. Sicuramente posso capire che sarebbe utile che il link venga scritto completo senza i puntini, tuttavia non lo considerei un errore da correzione, visto che il funzionamento è quello atteso. Direi che potrebbe senza dubbio essere una idea e quindi, se sei d'accordo, convertirei il topic di conseguenza

Fammi sapere cosa ne pensi qui

Grazie

Stefano

Leggi di più
Postato il da Stefano G.
Fabio B.
Fabio B.
User
Autore

1: Sì hai capito bene, ma non serve esportare, basta il tentativo senza connessione internet con dati fittizi

2 e 3: Sì, hai capito. Se credi converti pure in idea il topic, ma se questo é il comportamento atteso da voi non corrisponde al comportamento atteso da noi che il programma lo usiamo; noi ci aspettiamo di copiare e incollare in un colpo solo l'intero url completo delle 2 parti e con la stringa corretta, non con i puntini; magari per mezzo di uno specifico bottone Copia URL nell'interfaccia.

Spero che vi rendiate conto di quanto gravemente il problema del giusto url degli articoli infici la nuova funzionalità dei dati strutturati della v2020.2; questo problema vanifica interamente la nuova versione che ha puntato tutto su quella novità. Finché questo problema non sarà risolto non avrà senso acquistare la v2020.2.

Leggi di più
Postato il da Fabio B.
Giancarlo B.
Giancarlo B.
User

+1

Leggi di più
Postato il da Giancarlo B.
Fabio B.
Fabio B.
User
Autore

Una precisazione: la soluzione proposta per i punto 1 va bene ma deve includere anche un messaggio di avviso che non e' stato ancora inserito l'url al passo 5, cosi' uno aspetta a copiare/incollare il link nella mappa o in un bottone o altro che sia.

Meglio sarebbe anche se il collegamento invece di essere passato come stringa url fosse passato come variabile che lo contiene legata all'id dell'oggetto articolo, cosi' se in seguito modifichiamo la parte custom dell'url non dobbiamo andare a cercare e modificare a mano nel progetto tutti i collegamenti.

Inoltre cosi' si possono aggiungere gli articoli del blog nell'elenco dei links standard del programma.

Leggi di più
Postato il da Fabio B.
Incomedia
Stefano G.
Incomedia

Buongiorno Fabio

Per i punti 2 e 3 ho convertito il topic in Idea, così da tenere la questione evidenziata. 

Per il primo punto invece, ho informato direttamente gli sviluppatori così che la cosa possa venir verificata

Ti ringrazio per il tuo feedback

Stefano

Leggi di più
Postato il da Stefano G.