WebSite X5Help Center

 
Pasquale M.
Pasquale M.
User

Effetto parallasse fisso su ipad e cellulare non funziona  it

Autore: Pasquale M.
Visite 429, Followers 1, Condiviso 0  

Ho notato che impostando il parallasse fisso vedendo il sito su PC si visualizza correttamente, mentre andando a visionarlo con ipad o con uno smartphone l'effetto non funziona.

Qualcuno sa dirmi il motivo e se c'è da impostare qualche altra funzione?

Ho l'ultima versione di EVO.

Grazie

Postato il
16 RISPOSTE - 4 UTILI
Giuseppe Guida
Giuseppe Guida
User

Ciao. è normale così, il parallasse è stato disabilitato da Incomedia su tablet e cellulari, funziona solo su PC. Su tablet e cellulari dava problemi di varia natura (non tutti imputabili al software), ragion per cui si è deciso di disabilitarlo, scelta giusta a mio avviso.

Leggi di più
Postato il da Giuseppe Guida
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Pasquale M.
Ho notato che impostando il parallasse fisso vedendo il sito su PC si visualizza correttamente, mentre andando a visionarlo con ipad o con uno smartphone l'effetto non funziona. Qualcuno sa dirmi il motivo e se c'è da impostare qualche altra funzione? Ho l'ultima versione di EVO. Grazie

... ovviamente, senza LINK chi potesse e volesse farlo, ed anche su quegli i(!), non può verificare...

... comunque, nei dispositivi "mobile" se non ci fossero recenti novità, il parallasse dovrebbe essere > disabilitato...

... invece, con la v.PRO, di cui già ne sai(!), potrebbe funzionare in base a mie vecchie intuizioni, aggiungendo un ultimo e ridotto breakpoint finale, di cui una conferma > qui...

...!... prendendo spunto dalla mia invenzione EXTRA postata per es. > qui potresti sviluppare ed estendere...!...

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Pasquale M.
Pasquale M.
User
Autore

IL link provvidorio per visionarlo è: www.morba.altervista.com

Non ho purtroppo la versione PRO ma solo la EVO, non sono un professionista, quindi mi sembrava che la versione inferiore fosse adatta al mio utilizzo, invece noto molte "mancanze"

Leggi di più
Postato il da Pasquale M.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator

... mi pare che ci sia un solo parallasse fisso, con questa immagine, e se così fosse e se ti interessa, potresti sfruttarti ed adattarti la mia invenzione del Topic indicato prima...
... avvisami se incontri difficoltà, ...ed anche se io non ho il programma ne verremo lo stesso a capo, come hai visto di là, ...altrimenti fattene un ragione per la EVO, oppure resta in attesa di altri suggerimenti...

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Pasquale M.
Pasquale M.
User
Autore

Ti ringrazio per quanto indicato, però avendo con la EVO solo 4 breakpoint, significherebbe utilizzarli solo 2 quindi potrebbe poi non andare bene la visualizzazione del sito pertanto al momento preferisco che non si veda l'effetto parallasse né su ipad e né su smartphone.

Pensavo ad un mio errore invece non sono riusciti neanche i tecnici di x5 a risolverlo, tanto che hanno preferito disattivare i primi 2 breakpoint all'utilizzo di tale effetto. La cosa strana però è che nell'anteprima del sito vedendolo dal programma esso funziona, quindi, per logica, non dovrebbe funzionare neanche in quella visualizzazione ed è questo che mi ha tratto in inganno.... nell'anteprima lo vedo funzionare correttamente mentre una volta pubblicato non si vede l'effetto.

Grazie comunque, ne terrò conto in futuro quando scadrà la licenza, decidendo se rinnovare la EVO, passare alla PRO o se chiudere definitavamente la prova X5 passando ad altro.

Leggi di più
Postato il da Pasquale M.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator

... secondo me, una volta che lo sai più problema no è...

... per il parallasse fisso, o meglio, sfondo fisso, ostico negli smartphone, diversi utenti per lo più inesperti(!) hanno adottato la mia decennale invenzione compatibile con tutte le versioni del programma, e che in sostanza si ridurrebbe ad un semplice copia/incolla alla portata di tutti...

... per capire della potenza del mio codice, prova anche nello smartphone questi due siti di due utenti diversi (EN+DE), di cui il primo te lo avevo già indicato:

http://www.indesbilgisayar.com/emin2/
https://www.webdesign-markersdorf.at/Garden

... il resto dipenderà da te visto che il programma ha messo a disposizione gli strumenti adatti per questi scopi...

.

ciao

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Pasquale M.
Pasquale M.
User
Autore

OK, allora prima di desistere ho provato il tuo codice (copia incolla come hai detto) sostituendo il percorso dell'immagine.

IL codice è stato inserito al passo 3 Mappa poi Proprietà della pagina in questione, poi click su Esperto ed ho incollato il seguente codice prima della chiusura del tasto head.

<script> window.onload = function(){
divK='<div id="contenitoreK" style="position:fixed; top:0px; width:100%; height:100%; z-index:-1;"><div id="div_customK" style="position:absolute; top:0px; width:100%; height:100%; z-index:-1; background-repeat:no-repeat; background-image:url(\'http://www.morba.altervista.org/images/sfondo_parallasse_home.jpg\'); -webkit-background-size:cover; -moz-background-size:cover; -o-background-size:cover; background-size:cover; background-position: center center;"></div></div>'; document.body.innerHTML += divK; document.getElementById("imPageExtContainer").style.backgroundImage = "none";
}</script>

salvo e carico nello spazio free, questo l'url:
www.morba.altervista.com/index2.html

Lo apro da PC e va bene, quindi lo visione da smartphone e con 2 browser (Chrome e Firefox) ma il parallasse fisso non funziona, l'immagine scorre insieme al contenuto del sito come se fosse fissa.
Ho forse sbagliato qualcosa?

Leggi di più
Postato il da Pasquale M.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator

....!... togli l'errore di doppia chiusura script nel codice EXTRA che hai inserito nel BODY, al rigo nr.55:

</script> </script> 

....................................................

... per la pagina index2.html usa questo ultimo mio codice dedicato:

<style>
#imPageExtContainer, #imContentGraphics { background:transparent !important}
#imPageRowGraphics_9 { background: transparent url("") !important }
#imPageRow_4 {background: white !important ;opacity:0.85}
#imPageRow_5 {background: white !important ;opacity:0.6}
</style>

<script>
$( document ).ready(function() {
divK='<div id="contenitoreK" style="position:fixed; top:0px; width:100%; height:100%; z-index:-1;"><div id="div_customK" style="position:absolute; top:0px; width:100%; height:100%; z-index:-1; background-repeat:no-repeat; background-image:url(\'http://www.morba.altervista.org/images/sfondo_parallasse_home.jpg\'); -webkit-background-size:cover; -moz-background-size:cover; -o-background-size:cover; background-size:cover; background-position: top center;"></div></div>';
$("body").append(divK);
});
</script>

.......................................................................................

... da incollare qui:

>> Passo 3 - Mappa > Finestra 'Proprietà Pagina index2' > Le opzioni della Sezione Esperto | Codice personalizzato: > 3^opzione > Prima della chiusura del tag HEAD

.........................................................................

... quando avrai fatto, avvisa, così si va a controllare...

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Pasquale M.
Pasquale M.
User
Autore

Intanto grazie per il tuo prezioso e presente aiuto.

Allora ho integrato il codice e lo puoi vedere su www.morba.altervista.org/index2.html

Ci sono dei problemi:

1) l'immagine del parallasse si vede sotto alle scritte della descrizione (volendo potrebbe andare anche bene.. però se non ci fosse sarebbe meglio)
2) vedendolo da smartphone accade che si vedono 2 parallasse, il primo dove dovrebbe essere e c'è, solo che non si muove (quello più in alto), mentre il secondo parallasse appare sotto alla scritta Gold & Time e non si vede più il colore blu (la scritta è quella in basso prima dell'indirizzo, il telefono, la mail, ecc.) e questa sembra che scorra come effettivamente dovrebbe essere.

Probabilmente, non sono un genio, ma deduco che forse nel primo dei 2 script che hai postato, ci sono dei richiami che potrebbe richiamare dei comandi errati... ripeto non sono un genio in informatica, ma mi pare che la mia supposizione sia corretta. IL problema è capirlo per poterlo fare da solo, ma preferisco che sia tu a sistemarlo per bene e poi in base alle varizioni cerco di capire il codice

Leggi di più
Postato il da Pasquale M.
Pasquale M.
Pasquale M.
User
Autore

La mia deduzione era corretta. Ho infatti modificato nella prima parte dello script dove

#imPageRowGraphics_9con #imPageRowGraphics_8
ho quindi salvato e caricato con un altro index
www.morba.altervista.com/index3.html e vedendo il sito sul cellulare adesso il parallasse scorre come dovrebbe.

Il problema permane per l'immagine che si vede sotto alla descrizione, preferirei non averla, quindi ci sarà da modificare o togliere qualche riga o parte di codice, però qui attendo tua risposta.

Leggi di più
Postato il da Pasquale M.
Pasquale M.
Pasquale M.
User
Autore

Sono andato avanti ed ho eliminato dal primo script queste 2 righe:

#imPageRow_4 {background: white !important ;opacity:0.85}
#imPageRow_5 {background: white !important ;opacity:0.6}

quindi ho fatto un nuovo salvataggio con nuovo index:
www.morba.altervista.com/index4.html

Come si può vedere adesso l'immagine non appare più sotto alla descrizione.

Naturalmente non so se quello che ho fatto è corretto...


C'è però un altro problema: entrando nel sito subito sotto alle immagini grandi in alto c'è una pagina che appare dall'alto con la scritta (Restauro di Orologi Antichi, Orologi da tavolo, Orologi a pendolo, Orologi da....)

Ecco in questo spazio, prima che appaia la pagina con la scritta dall'alto, si vede l'immagine del parallasse, come si toglie?

Leggi di più
Postato il da Pasquale M.
Pasquale M.
Pasquale M.
User
Autore

Penso di aver risolto anche questo problem, infatti quella riga non aveva nessuno sfondo ma era selezionato TRASPARENTE, adesso ho messo il colore bianco e il parallasse che si vedeva è sparito
www.morba.altervista.com/index5.html

A questo punto "sembra" funzionare, però quello che ho fatto potrebbe non essere corretto, di conseguenza attendo una tua risposta, grazie.

Leggi di più
Postato il da Pasquale M.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator

... non ho visto il "5"(!), ...ma direi che index4.html  sia OK...
... lo scopo del mio codice stava proprio nello sfondo fisso full-screen in semi-trasparenza per apprezzarne la profondità, ma anche così a tua preferenza va molto bene...
... nello scroll testo in testa, lo sfondo per me non da fastidio, anzi lo apprezzo, ... però, ...se tu non vuoi vederlo, nel tag style prova ad aggiungere questa stringa:
#imPageRow_3 { background: white !important}

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator

... OK anche per index5.html 

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Pasquale M.
Pasquale M.
User
Autore

Intanto di nuovo grazie.

ho sistemato come da istruzioni aggiungendo anche un pò di opacità nella parte in basso dove sono riportati i vari dati del cliente (indirizzo, telefono, email...) in modo che si continui a vedere sotto l'immagine del parallasse.

Ho però un ultimo problema, che non riesco a risolvere e per questo ti chiedo un aiuto, se possibile, perchè non vorrei che il problema fosse creato dal tuo codice.

visionandolo da pc tutto ok, mentre se lo visiono da ipad o da smartphone in fondo alla pagina, proprio sotto al'indirizzo e alle note sulla privacy, appare una riga di una decina di pixel con il colore blu. Ho eliminato il footer portandolo a 0 pixel, ma questa riga non va via e non riesco a capire come fare. Volendo la potrei lasciare non è che disturba, però se non ci fosse sarebbe meglio.

Adesso lo puo vedere su www.morba.altervista.com

Leggi di più
Postato il da Pasquale M.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Pasquale M.
... ... ...  proprio sotto al'indirizzo e alle note sulla privacy, appare una riga di una decina di pixel con il colore blu. Ho eliminato il footer portandolo a 0 pixel, ma questa riga non va via ... ... ... 

... togli il colore al FOOTER, ed elimina l'oggetto vuoto che è posizionto al suo interno (h25px):

<footer id="imFooter">   <div id="imFooterObjects"></div>   </footer>

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪