WebSite X5Help Center

 
Giuseppe Guida
Giuseppe Guida
User

Video in stile righe e audio con partenza automatica  it

Autore: Giuseppe Guida
Visite 682, Followers 1, Condiviso 0  

Ciao, se si visita questo link di esempio:

https://www.test70.altervista.org/underwearshop02/

nella home page parte il video nello stile righe ma non l'audio abbinato (si sa che molti browser inibiscono in automatico l'audio). Ho caricato il video online, non è presente nel sito.

La cosa strana è che se dopo la home page vado in qualsiasi altra pagina anche per un attimo e poi ritorno nuovamente sulla home tramite il menù di navigazione,  il video parte con l'audio.  Il che è davvero strano.

Come mai? Fa così a tutti o solo sul mio pc/browser (Win 10 e Chrome)? Perchè non parte quando si va la prima volta sulla home? E c'è un modo per far partire anche l'audio oltre al video?

Postato il
53 RISPOSTE - 10 UTILI
Vincenzo Errico
Vincenzo Errico
User

Ciao Giuseppe, provato su tablet e l'audio non parte neanche ritornando sulla home da altra pagina.

Leggi di più
Postato il da Vincenzo Errico
Giuseppe Guida
Giuseppe Guida
User
Autore

Ciao Vincenzo, grazie per il riscontro... Io ho fatto la prova da PC.

Ciao :-) 

Leggi di più
Postato il da Giuseppe Guida
Roberto M.
Roberto M.
User

Ciao Giuseppe. Da PC A me parte il video con musica.Se mi sposto sullo shop e ritorno in home riparte video e musica. Lo fa con ▼

Browser Firefox ultima versione

Chrome ultima versione

Mentre ▼

Con Edge Parte il video ma non si sente la musica neanche se mi sposto tra le pagine.

Leggi di più
Postato il da Roberto M.
Giuseppe Guida
Giuseppe Guida
User
Autore

Grazie mille Roberto...

Strano, sembrerebbe che il video con audio abbia comportamenti diversi da PC a PC.

Ciao

Leggi di più
Postato il da Giuseppe Guida
Giuseppe Guida
Giuseppe Guida
User
Autore

Ho cancellato la cache del browser, ho controllato che Chrome sia aggiornato all'ultima versione, ma nulla, l'audio non si sente al primo accesso sulla home ma solo dopo aver cliccato su un'altra pagina e poi si ritorna sulla home. La stessa cosa avviene con Edge. Mentre con Firefox non si sente in nessun caso. Con Internet Explorer l'audio parte da subito appena si accede alla home (però tutto il resto del sito non va bene, è molto datato IE).

Che dire, aspetto un riscontro da parte dello staff. Grazie

Leggi di più
Postato il da Giuseppe Guida
Giuseppe Guida
Giuseppe Guida
User
Autore

Ho trovato questo sul web:

I criteri di riproduzione automatica di Chrome sono semplici:

Leggi di più
Postato il da Giuseppe Guida
Giuseppe Guida
Giuseppe Guida
User
Autore

Da quella descrizione sopra risultano chiare molte cose, ecco perchè da utente ad utente varia il modo in cui l'audio si avvia: al secondo punto sono spiegate le motivazioni. Nel mio caso, siccome io evidentemente "non ho superato la soglia dell'indice di coinvolgimento dei media" (in effetti riproduco pochissimi video con audio), l'audio si avvia solo se "interagisco con il dominio (click, tap, ecc.)".

Ora sono un po' più chiare le cose.

Leggi di più
Postato il da Giuseppe Guida
Pc Win
Pc Win
User

ciao Giuseppe

confermo che con chrome ed edge (base chromium) il sito si comporta come dici tu

con firefox non sento mai l'audio, neanche tornando indietro

entrambi i browser sono aggiornati ad oggi

Fabio

Leggi di più
Postato il da Pc Win
Giuseppe Guida
Giuseppe Guida
User
Autore

Grazie PC Win.

Leggi di più
Postato il da Giuseppe Guida
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Utente del mese IT

... l'inibizione dell'autoplay Video/Audio per convenzione presa è un fatto noto da diversi anni, (per Chrome dopo la v.49 dove funziona sempre, 2016), e riguardo al "mobile" è stato sempre riportato in tutte le Guide del Programma, anche delle vecchie versioni e quindi non è proprio un sorpresa di adesso...

... nel Forum forse potrebbero ancora trovarsi i miei vecchi escamotages a senso unico, sia per video sul server che per YT, tramite alcuni dei quali era possibile riattivare l'audio...

... i fatto nuovo ed apprezzabile è che il Programma solo nelle ultime versioni ha finalmente integrato il silenziamento dei Video, per cui il mio escamotage è diventato superfluo...

... non ho ancora avuto modo di verificare se ciò è stato applicato che per video YT, cosa che io avevo superato e suggerito già da diversi anni, e spero che ciò sia stato anch'esso implementato evitando così interventi EXTRA...

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Giuseppe Guida
Giuseppe Guida
User
Autore

Ciao Kol. Sapevo delle questioni relative all'audio inibito dai browser (lo avevo anche specificato nel mio post di apertura di essere a conoscenza di ciò). Io però mi riferisco al PC (anche questo specificato nel post di apertura e anche in seguito). La cosa che trovo strana é che passando dalla home ad un'altra pagina e poi ritornando sulla home (sempre tramite le voci di menù) l'audio parte in automatico sia su PC che su Smartphone. Addirittura a Roberto M. parte già la prima volta che "atterra" sulla home. Da ció si evince che la partenza automatica dell'audio non é inibita di default per tutti indistintamente. Queste differenze di comportamento mi sono state poi chiarite da ció che ho trovato sulle guide di Chrome e che ho riportato in uno dei messaggi sopra.

Leggi di più
Postato il da Giuseppe Guida
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Utente del mese IT

... questo fenomeno avveniva anche in passato per video con audio NON inibito e poteva avvenire anche nel "mobile", infatti a quei tempi mi ero illuso che il mio codice superasse tale limitazione perchè provavo su browser non recenti, ed invece non era così... 
... in alcuni casi il video si avviava anche con audio attivo, (vedi qui), anche se era improprio, ed al refresh invece il video veniva bloccato, ...quindi non in regola e non c'è spiegazione;...ogni browser ha le sue caratteristiche..
... la regola attuale come lo era per il "mobile" è che che l'audio deve essere attivato  volontariamente altrimenti il flusso non dovrebbe attivarsi...
... il programma attuale finalmente ha sopperito per gli inesperti che non sanno e che ben sia, ...ma secondo me l'audio dovrebbe essere disattivato a monte e non discriminato da codice JS incorporato, ma questo è solo un mio parere...

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Giuseppe Guida
Giuseppe Guida
User
Autore
 ‪ KolAsim ‪ ‪
.ogni browser ha le sue caratteristiche..

No, Kol, non è "ogni browser ad avere le sue caratteristiche" (vedi quanto scritto da Roberto M. che usa i miei stessi browser ma ottiene comportamenti totalmente differenti da quanto ottengo io). Se l'audio parte in automatico o non parte dipende dal comportamento sul web dello specifico utente: se io guardo in genere molti video con audio, è molto probabile che l'audio del mio esempio parta in automatico alla prima visita sul sito, come infatti avvenuto per Roberto M.:

dalle guide di Google (originale in inglese):

La riproduzione automatica con audio è consentita se:

Se invece come utente io non rientro in quanto indicato sopra, è sempre possibile riprodurre l'audio SENZA attivazione manuale (tra l'altro nel mio esempio online NON ci sono i controlli per l'audio!) a patto però che io interagisca con il dominio/sito web, infatti, sempre nelle guide di Google, troviamo:

La riproduzione automatica con audio è consentita se:

  • L'utente ha interagito con il dominio (click, tap, ecc.).

Quest'ultimo è il mio caso e di alcuni altri utenti: vado sulla home la prima volta e niente audio, "interagisco" con il dominio (quindi click su altra pagina del sito) poi ritorno sulla home e l'audio parte in AUTOMATICO senza che io abbia fatto nulla (questo sia da PC che da Smartphone).

Quindi, da quel che si evince, la questione va ben al di là di una inibizione automatica di default dell'audio sui vari browser e di un comportamento univoco del browser. Dipende dalle "abitudini" dell'utente e dalle interazioni con il dominio.

Ciao

Leggi di più
Postato il da Giuseppe Guida
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Utente del mese IT

... appunto, ...ma la regola è quella detta e  l'importante è saperlo, ed una volta che si sa se ne fa un ragione e più problema non è, che è anche aleatorio...

ciao

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Giuseppe Guida
Giuseppe Guida
User
Autore

Sì Kol, ora che dalle guide di Google ci ho capito qualcosa in più sono anche chiari i motivi del perchè a Roberto M. e sul browser del PC di mio nipote il video parte con l'audio attivo in automatico mentre a me no... Era questa differenza di comportamento che non mi era chiara.

Ciao :-) 

Leggi di più
Postato il da Giuseppe Guida
Giuseppe Guida
Giuseppe Guida
User
Autore

P.S. io al posto di Google avrei fatto il contrario, faccio partire l'audio ma lo posso disattivare subito con un click se non mi sta bene... Ci sono video che se partono senza la giusta colonna sonora perdono il 50% della loro efficacia comunicativa. 

Leggi di più
Postato il da Giuseppe Guida
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Utente del mese IT

... tutti i possibili test li avevo già fatti diversi anni addietro, ed avevo spiegato anche i motivi per problema autoplay...

... per me(!)  è meglio il video con audio sempre disattivato, specialmente per gli sfondi, ...e casomai mettere un pulsante EXTRA per poter attivare il suono, ... come per esempio con uno dei vari miei > metodi esclusivi  dispersi nel tempo e configurabile a piacere...

...

bye

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Pc Win
Pc Win
User

@ Giuseppe

quando devi testare siti come quello avvisa sempre..

innocent

Leggi di più
Postato il da Pc Win
Giuseppe Guida
Giuseppe Guida
User
Autore
Pc Win
@ Giuseppe quando devi testare siti come quello avvisa sempre..

Ti devo avvisare perchè ti piace guardarli così non te ne perdi neanche uno o perchè vuoi prevenire possibili "traumi emotivi"? laughinglaughing

Ciao :-D 

Leggi di più
Postato il da Giuseppe Guida
Giuseppe Guida
Giuseppe Guida
User
Autore

Un'altro quesito per gli esperti:

se inserisco un video presente su Youtube nello Stile Righe, il video parte in automatico con l'audio nell'anteprima in LOCALE di Website X5.

Se invece metto online il sito, lo Stile Righe con il video appare così e non parte nè video e nè nulla, come mai?

LINK prova online: https://www.test70.altervista.org/underwearshop03/

Leggi di più
Postato il da Giuseppe Guida
Giuseppe Guida
Giuseppe Guida
User
Autore

P.S. ho usato il browser Chrome 

Leggi di più
Postato il da Giuseppe Guida
Giuseppe Guida
Giuseppe Guida
User
Autore

P.P.S. Noto che appare la stessa schermata grigia anche con Edge e FireFox. Online il video di Youtube in Stile Righe non si vede

Leggi di più
Postato il da Giuseppe Guida
Giuseppe Guida
Giuseppe Guida
User
Autore

OK risolta la questione del video Youtube in Stile Righe: avevo l'AD Blocker attivo su Chrome e bloccava anche l'avvio del video oltre alle pubblicità

Leggi di più
Postato il da Giuseppe Guida
Giuseppe Guida
Giuseppe Guida
User
Autore

No, BUGIA... anche con l'AD Blocker disattivato e con il blocco popup disattivato dalle impostazioni di Chrome, il video non si vede, non parte e si vede quella schermata grigia postata in precedenza...

Non so più che pesci prendere... Forse meglio evitare i video di Youtube in Stile Righe.

Consigli? Dritte? Grazie

Leggi di più
Postato il da Giuseppe Guida
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Utente del mese IT
Giuseppe Guida
... ... ...  Consigli? Dritte? Grazie

... YT è un altro discorso a parte, se ne è già parlato in questi anni, ...e sotto le stesse regole...

... o usare le YT-API, ... oppure integrare YT+TUBULAR...

ciao

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Roberto M.
Roberto M.
User

In ogni caso il video di Giuseppe deve avere la musica altrimenti perde però mi immagino a vederlo per caso alle 2 di notte e con il cursore audio non abbassato. laughing

Leggi di più
Postato il da Roberto M.
Giuseppe Guida
Giuseppe Guida
User
Autore

Posso esprimere un mio modesto parere? Comunque è una gran caxxata il fatto che non parte in automatico l'audio al primo ingresso sulla home, poi basta cliccare su una qualsiasi pagina del sito, ritornare di nuovo sulla home dal menù di navigazione e... BUM l'audio parte ugualmente anche alle 2.00 di notte, alla faccia delle restrizioni del cavolo di Chrome sull'audio e sulla partenza automatica... A che pro un sistema del genere? Una logica davvero da stupidi, non ha per nulla senso, all'inizio no ma dopo sì, quindi qual è la conclusione? L'audio (sparato a mille o meno) l'utente se l'è beccato ugualmente nelle orecchie con il semplice ritorno sulla home... Siete dei grandi voi di BIG G laughing Vi stimo! 

Leggi di più
Postato il da Giuseppe Guida
Giuseppe Guida
Giuseppe Guida
User
Autore

Qui, con la pagina di ingresso abilitata, sembra che poi, entrando nel sito, parta il video con avvio dell'audio in automatico anche se si va per la prima volta sulla home (sia con Chrome che con Edge ma NON con FireFox):

https://www.test70.altervista.org/underwearshop05/

Qualcuno può provare? Grazie mille.

Ciao

Leggi di più
Postato il da Giuseppe Guida
Giuseppe Guida
Giuseppe Guida
User
Autore

P.S. intendo sempre da PC

Leggi di più
Postato il da Giuseppe Guida
Giuseppe Guida
Giuseppe Guida
User
Autore

La pagina d'ingresso non la vedo proprio da cellulare. Non so se è normale o meno.

Leggi di più
Postato il da Giuseppe Guida
Giuseppe Guida
Giuseppe Guida
User
Autore

La pagina di ingresso c'è ma alcuni la vedono altri no... non so più che pensare... nù casin di quelli mai visti... Online io la vedo... altri che ho contattato in privato non la vedono...

Leggi di più
Postato il da Giuseppe Guida
Giuseppe Guida
Giuseppe Guida
User
Autore

Spero intervenga qualcuno dello STAFF per chiarire un po' di aspetti... queste le impostazioni della pagina di ingresso. 

Leggi di più
Postato il da Giuseppe Guida
Roberto M.
Roberto M.
User

a differenza della mia prima prova che con EDGE era negativa ora vedo l'immagine intro poi faccio click e accedo al video con musica che sento REGOLARMENTE su:

CHROME

FIREFOX

EDGE

Vacci a capire....

Leggi di più
Postato il da Roberto M.
Roberto M.
Roberto M.
User

Provato con cellulare galaxynote 8 plus vedo l'enter e il video con la musichetta.

Sistema android browser chrome

Firefox per cellulari fa schifo e l'ho tolto.

Leggi di più
Postato il da Roberto M.
Giuseppe Guida
Giuseppe Guida
User
Autore

Grazie del riscontro Roberto, gentilissimo.

Leggi di più
Postato il da Giuseppe Guida
Giuseppe Guida
Giuseppe Guida
User
Autore

Sì, in pratica quel click sulla pagina di ingresso per entrare nel sito web è ciò che Google spiega in questo passaggio:

La riproduzione automatica con audio è consentita se:

  • L'utente ha interagito con il dominio (click, tap, ecc.).

infatti così si interagisce e il click nella pagina INTRO sostituisce il fatto di dover andare su una pagina diversa e poi ritornare in Home per sentire l'audio del video che parte in automatico.

A me però su FIREFOX non c'è verso di sentire l'audio in automatico e con Cellulare Android + browser Chrome la pagina INTRO non si vede affatto e si va direttamente in home, boh? Altro mistero.

Leggi di più
Postato il da Giuseppe Guida
Giuseppe Guida
Giuseppe Guida
User
Autore

CON FIREFOX bisogna attivare dalla barra degli indirizzi la riproduzione automatica di audio e video e tutto funziona perfettamente, l'audio e il video partono in automatico anche per il video Youtube nello Stile Righe...

Leggi di più
Postato il da Giuseppe Guida
Giuseppe Guida
Giuseppe Guida
User
Autore

Se mi sto dilungando è perchè sto facendo varie prove i cui risultati poi potrebbero servire a tutta la Community e a chi magari, un domani, andrà ad inserire un video con suono nel proprio sito web, non è che mi sono fissato su certe cose, è giusto per capirci qualcosa in più tutti.

Thanks

Leggi di più
Postato il da Giuseppe Guida
Teresa R.
Teresa R.
User

Quindi Giuseppe in definitiva per far partire un video con audio attivo in automatico bisognerà necessariamente creare una pagina di ingresso sulla quale poi cliccare per entrare nella home, come hai fatto in questo esempio https://www.test70.altervista.org/underwearshop05/

solo su firefox però se non si attiva il permesso per riprodurre anche l'audio, quest'ultimo non si sentirà in nessun modo. Corretto?

Leggi di più
Postato il da Teresa R.
Giuseppe Guida
Giuseppe Guida
User
Autore

Sì Teresa, esatto. Con la Pagina di Ingresso si supera il problema che non permette nella home page di avere un audio che parte in automatico.

Leggi di più
Postato il da Giuseppe Guida
Mirko Boschetti
Mirko Boschetti
Moderator
Giuseppe Guida
Sì Teresa, esatto. Con la Pagina di Ingresso si supera il problema che non permette nella home page di avere un audio che parte in automatico.

a me funziona solo con Edge al primo ingresso, con Chrome devo andare in altra pagina e tornare alla home e si sente la musica, con FireFox non sento niente in nessun modo... bhooooo... innocent

Leggi di più
Postato il da Mirko Boschetti
Giancarlo B.
Giancarlo B.
User
Mirko Boschetti
a me funziona solo con Edge al primo ingresso, con Chrome devo andare in altra pagina e tornare alla home e si sente la musica, con FireFox non sento niente in nessun modo... bhooooo...

infatti.... undecided

Leggi di più
Postato il da Giancarlo B.
Giuseppe Guida
Giuseppe Guida
User
Autore

Per Firefox ho scritto sopra qual è il "problema", bisogna abilitare in Firefox, nella barra degli indirizzi, il permesso a riprodurre in automatico anche l'audio...

Leggi di più
Postato il da Giuseppe Guida
Giuseppe Guida
Giuseppe Guida
User
Autore

Comunque rimane il fatto che io, dopo il "passaggio" dalla pagina di ingresso, sento l'audio in automatico sulla home, Roberto M. anche, un altro utente che ho sentito in privato idem (altri due utenti NON vedono proprio la pagina di ingresso! Mistero!), a Mirko e Giancarlo funziona solo su Edge... Insomma, ogni PC, ogni configurazione, è un caso a sé, sempre a patto che non sia Website X5, in questo caso non credo dipenda dal software, però sono uno che tende a non escludere nulla.

Leggi di più
Postato il da Giuseppe Guida
Giuseppe Guida
Giuseppe Guida
User
Autore

Dopo quanto scritto da Mirko e Giancarlo, sono sempre più sostenitore della mia stessa idea wink

Giuseppe Guida
Posso esprimere un mio modesto parere? Comunque è una gran caxxata il fatto che non parte in automatico l'audio al primo ingresso sulla home, poi basta cliccare su una qualsiasi pagina del sito, ritornare di nuovo sulla home dal menù di navigazione e... BUM l'audio parte ugualmente anche alle 2.00 di notte, alla faccia delle restrizioni del cavolo di Chrome sull'audio e sulla partenza automatica... A che pro un sistema del genere? Una logica davvero da stupidi, non ha per nulla senso, all'inizio no ma dopo sì, quindi qual è la conclusione? L'audio (sparato a mille o meno) l'utente se l'è beccato ugualmente nelle orecchie con il semplice ritorno sulla home... Siete dei grandi voi di BIG G Vi stimo! 
Leggi di più
Postato il da Giuseppe Guida
Incomedia
Stefano G.
Incomedia

Buongiorno Giuseppe

Posso confermare nella maggior parte ciò che hai indicato. Il codice di WebSite X5 in generale non è cambiato rispetto a quando l'autoplay era permesso. Quindi se abiliti l'autoplay sul tuo elemento, questo verrà configurato esattamente come venivano configurati gli elementi in autoplay prima di queste policy più stringenti.

Purtroppo queste policy però non sono "universali", nel senso che è assolutamente possibile che i browser si comportino in maniera diverso uno dall'altro.

Posso perciò affermare che a livello di software, il codice è sempre lo stesso di prima nonostante i browser possano ora decidere di permettere la riproduzione a seconda di condizioni diverse ad esclusiva scelta loro (come per esempio quella di aver interagito già almeno una volta col sito che si legge in Chrome)

Resto a disposizione

Stefano

Leggi di più
Postato il da Stefano G.
Giuseppe Guida
Giuseppe Guida
User
Autore

Grazie per la risposta Stefano. Ho trovato la soluzione che mi interessava come spiegato qualche post più su. Buon lavoro

Leggi di più
Postato il da Giuseppe Guida
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Utente del mese IT
Teresa R.
...... ...  in definitiva per far partire un video con audio attivo in automatico bisognerà necessariamente creare una pagina di ingresso sulla quale poi cliccare per entrare nella home, ... ... ... 

...... ...  e quindi per ovvie ragioni sarebbe da evitare, ...  a meno di applicare un gestore audio EXTRA, ... Il che non sarebbe agevole...

.

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪
Mirko Boschetti
Mirko Boschetti
Moderator
‪ Teresa R ‪ ‪
...  in definitiva per far partire un video con audio attivo in automatico bisognerà necessariamente creare una pagina di ingresso sulla quale poi cliccare per entrare nella home, ... ... ... 

e se si mettesse un redirect  di 0 secondi all'interno della pagina di ingresso???

forse potrebbe funzionare...

Leggi di più
Postato il da Mirko Boschetti
Giuseppe Guida
Giuseppe Guida
User
Autore

Sì, Kol, sarebbe da evitare ma le mie sono delle prove. In fondo poi basterebbe mettere come audio del video un audio a basso volume che anche se ascoltato al massimo non dia fastidio. Poi considera che se l'audio non è gradito lo si può sempre abbassare o silenziare totalmente con un tocco sui tasti del PC con il simbolo dell'altoparlante e simbolo del mute. 

Leggi di più
Postato il da Giuseppe Guida
Giuseppe Guida
Giuseppe Guida
User
Autore

Mirko non è la pagina di ingresso in sé che fa attivare in automatico l'audio ma è l'interazione su quella pagina (il click sul tasto "Entra") che soddisfa le richieste di google in quanto ad "interazioni con click" sul sito per far sì che l'audio parta in automatico. Alcuni post più sopra è spiegato tutto, ho riportato direttamente le indicazioni fornite da Google in merito. Però si può provare anche come dici tu e capire cosa succede. Appena possibile ci provo.

Leggi di più
Postato il da Giuseppe Guida
Mirko Boschetti
Mirko Boschetti
Moderator

azzzzz.... vero e lo avevo anche letto sopra... embarassed

allora penso non funzioni con il redirect...

Leggi di più
Postato il da Mirko Boschetti
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Utente del mese IT

... Si si, lo segnalavo a Teresa....

... Il sottofondo musicale è sempre da evitare, ...oppure predisporre un controllo audio si-no, specialmente in caso di altri eventuali suoni in  contemporanea...

Ciao

Leggi di più
Postato il da  ‪ KolAsim ‪ ‪