Area riservata non funziona 
Autore: Fabrizio T.
Visite 178,
Followers 1,
Condiviso 0
buongiorno
ho creato il sito www.scottisrl.net.
nel sito ho creato l'area riservata per accedere al catalogo con registrazione automatica.
ha funzionato fino a che ho acquistato una nuova versione poi non ha più funzionato.
cosa posso fare.
grazie
Postato il

Buongiorno Fabrizio,
mi dispiace per l'inconveniente.
Potresti fornire maggiori dettagli, ad esempio chiarire se l'errore avviene nel tentare di registrarsi, o nell'accesso?
Grazie.
Autore
Buongiorno Eric
durante l'accesso non chiede più nessun dato, ti fa entrare subito nella pagina riservata.
grazie
Buongiorno Fabrizio,
controllando la mappa del sito, la pagina in questione risulta contrassegnata come protetta?
...!... questa pagina non risulta essere stata PROTETTA:
https://www.scottisrl.net/catalogo.php
... prima di tutto devi risolvere questi problemi:
https://www.scottisrl.net/admin/login.php
...!... forse stai usando una versione del PHP inadeguata o superiore al programma in uso...!...
... per la v.WSx5.2023 che mi pare hai in uso dovresti provare ad usare, impostare, sul server il PHP tra PHP/8.0 e PHP/8.4 (max)...
... assegna la protezione, modifica il PHP, fai le varie prove online e fai sapere...
.
ciao
Autore
buongiorno
ho impostato il PHP sul server a 8.2, assegnato la protezione alla pagina. ma non funziona mi apre una pagina che dice: Unable to connect to DB
cosa posso fare?
grazie
Buongiorno Fabrizio,
se visualizzi questo errore significa che nei parametri della sezione Gestione Dati al Passo 5 - Esportazione ---> Esporta il sito su internet ---> Parametri c'è un errore, raccomando di verificarli.
... in primis segui il suggerimento di Eric...
... adesso online il PHP sembra PHP/8.2, inferiore al PHP/5 rilevato precedentemente, quindi potrebbe andar bene, magari provando sino al PHP/8.4...
... il sito risulta esportato oggi, ma la pagina catalogo.php segnalata prima risulta ancora non essere stata protetta...!...
... se la pagina è protetta, deve verificarsi quello che avviene cliccando qui, cioè non si apre:
https://kolasim.websitex5.me/protezione/paperino.php
... nella HOME trovi le PASS per accedere per prova...
...!... che risultati e risposte hai ottenuto dal pannello /admin/ indicato prima...?...
.
ciao
.
Autore
Buongiorno
ho modificato PHP a 8.4, ho protetto la pagina catalogo.
e questo e quello che succede.
ora ho rimesso come era prima
Buongiorno Fabrizio,
se visualizzi questo errore significa che nei parametri della sezione Gestione Dati al Passo 5 - Esportazione ---> Esporta il sito su internet ---> Parametri c'è un errore, raccomando di verificarli.
Autore
Buongiorno
si c'erano dei parametri errati ora funziona
Grazie