Base de données mariadb d'Infomaniak 
Autore: Laurent F.
Visite 79,
Followers 1,
Condiviso 0
Bonjour,
J’ai mis en œuvre la gestion d’accès sur un de mes site qui se nomme Lyceumcf.ch.
L’hébergeur est l’entreprise Infomaniak. Elle utilise une base de données qui se nomme MariaDb
(vous trouverez sa description ici : https://aws.amazon.com/fr/compare/the-difference-between-mariadb-vs-mysql/ ), ors lorsque je tente de publier le site, la publication est refusée avec le message suivant qui indique que les paramètres ne sont pas reconnus.
Ors les paramètres indiqués correspondent bien à ceux désignés par le fournisseur d’accès comme vous pouvez le constater par les images suivantes.



Je vous remercie de me dire quels éléments bloquent la publication du site.
Avec mes remerciements et mes cordiales salutations.
Laurent Frascotti
Postato il

Hello Laurent,
could you please try using localhost as the Hostname instead of the current one?
I remain available.
Online translation:
Bonjour Laurent,
Pourriez-vous essayer d’utiliser « localhost » comme nom d’hôte à la place de celui utilisé actuellement ?
Je reste à votre disposition.
Autore
Hello Eric,
Ca ne marche pas.
Voici ce que je reçois en retour
Et si publie bien entendu le message suivant et généré :
Unable to connect to DB
Merci pout l'aide, cordialement.
Hello Laurent,
I recommend making sure that all parameters were typed correctly, and that there are no spaces at the end of the fields, added accidentally.
If the issue persists even after checking this, I recommend contacting your hosting provider to check if they format of the parameters is correct, and if they detect any errors on their logs.
Additionally, I recommend making sure your PHP version is between 8.2 and 8.5 on your hosting space.
I remain available.
Online translation:
Bonjour Laurent,
je vous recommande de vérifier que tous les paramètres ont été saisis correctement et qu'il n'y a pas d'espaces à la fin des champs qui auraient été ajoutés accidentellement.
Si le problème persiste même après cette vérification, je vous recommande de contacter votre hébergeur afin de vérifier si le format des paramètres est correct et s'il détecte des erreurs dans ses journaux.
Je vous recommande également de vérifier que la version de PHP utilisée sur votre espace d'hébergement est comprise entre 8.2 et 8.5.
Je reste à votre disposition.
Autore
Hello Eric,
J'ai vérifié les paramètres qui sont tous corrects. La version du PHP est la 8.2 (j'annexe sous forme d'images les données complètes du PHP). Je vais contacter l'hébergeur pour lui soumettre également le problème et je vous communiquerer ensuite leur réponse.
Bonne journée
Autore
Bonjour Eric,
Pour une raison que je ne m'explique j'ai aujourd'hui tenté une nouvelle fois de publier le site avec gestion d'accès et cela a fonctionné.
Cela reste un mystère pour moi mais si cela continue de fonctionner on va en rester là.
merci beaucoup pour votre aide.