WebSite X5Help Center

 
Palden Jenkins
Palden Jenkins
User

Cell formatting  en

Autor: Palden Jenkins
Visited 1170, Followers 2, Udostępniony 0  

I am encountering a cell formatting problem which has arisen in Evolution 12. I had this problem in an earlier version (might have been v9).

When I enter text and pics into a cell, when the cell is saved there is a considerable amount of open space at the bottom of the cell. Example: http://ancientpenwith.org/bronze.html - look at the bottom of the page. The bottom margin for this page is just 30.

I cannot find a way to remove this problem. If I split up the text into smaller cells down the page, it just lands up with smaller gaps between each section.

Any tips?

Thanks, Palden

Posted on the
16 ODPOWIEDZI
Jan Procházka
Jan Procházka
User

Hi Palden,

One tip: check if your text in the cell hasn't on the it's end empty space by pushing Enter key or by pushing space key. I had similar problem and it everytime were the same solve - to delete epty space in the text cell.

Sincerely Jan

Czytaj więcej
Posted on the from Jan Procházka
Palden Jenkins
Palden Jenkins
User
Autor

Hello Jan

Thanks for the tip, though I've already been attentive to that and eliminated end-of-line spaces!  I've also tried deleting and pasting the text or pasting it into new cells. Also tried breaking the text down into smaller cells, but that just makes for smaller gaps at the bottom of the cells (example: http://www.ancientpenwith.org/iron.html ).

Perhaps I'll try reinstalling the program, though I suspect the errors will still be stored in the CSS files. My theory is that the cell height is miscalculated when I insert right- or left-aligned pictures into the text.

All the best, Palden

Czytaj więcej
Posted on the from Palden Jenkins
Palden Jenkins
Palden Jenkins
User
Autor

I am still getting the same problem with cell formatting - a large space appears at the bottom of the cell when viewed in a browser (whether it's the Incomedia preview browser or another one). Though it doesn't show up when editing the cell. This seems to happen even in cells where there is only text (no pictures or complex formatting). It makes my sites look really untidy and some of my clients are unhappy.

I remove all spaces at the end of lines. I'm using standard fonts (Tahoma, Trebuchet, etc). I have reinstalled the program. I've trawled through the Answers site. I still cannot get rid of this problem and it is now getting serious - reluctantly I might have to start using a different program after 6-7 years with X5.

I'd really appreciate some help with this!

An example is lower down on this page: http://ancientpenwith.org/map.html

or at the bottom of this page: http://ancientpenwith.org/bronze.html

Thanks, Palden

Czytaj więcej
Posted on the from Palden Jenkins
Paul M.
Paul M.
Moderator
Najlepszy Użytkownik miesiąca EN

Hello Palden,

Your CSS files show that you have customised the style of the cells which contain the Objects in question.

Go back to WebSite X5 and adjust the 'Inner Margin' setting in the Cell Style properties...

Step 3 Page Creation > Object > Cell Style

You need to reduce the padding you have applied to the 'bottom' of the cells.

In your first example the problem lies with the cell which holds the Text Object.

In the second example it is the column on the right which is causing the issue, the one which holds the images.

Remember that in WebSite X5 two or more Objects adjacent to each other on the same row in the page layout will assume the height of the tallest Object in that row.

Kind regards,

Paul

Czytaj więcej
Posted on the from Paul M.
Palden Jenkins
Palden Jenkins
User
Autor

Hello Paul

Thank you for your help.

However, what you suggest doesn't solve the problem. The gap at the bottom in each case is far larger that the bottom margin I have set, and even if I set the bottom margin to 0 it does not remove the gap. So something else seems to be causing this problem.

I thought at first that it was the insertion of pictures into a text box that was the source of the problem, but I'm getting the problem even when there is no image there, and even when there are no complications with the text (such as changing font sizes or fonts - and I am using common fonts).

So I am still at a loss for what to do!

Best wishes, Palden

Czytaj więcej
Posted on the from Palden Jenkins
Palden Jenkins
Palden Jenkins
User
Autor

I have just discovered something that might be a clue. When editing a text object, when I click 'Fit Content to Cell Width', the cell width shown when editing the cell is not the same as that when viewed in the Preview browser. See attached images.

The bottom margin of both left and right cells is set to 20. But the visible gap there is much bigger.

I find that when there's such a difference and a word or phrase overlaps onto a new line, it pushes the bottom of the cell downwards to create a gap at the bottom of the cell (as shown in image 3). In this case it looks as if the program is not measuring the cell width correctly.

I wonder if you have any advice, please? Thanks for your help and attention.

Palden.

Czytaj więcej
Posted on the from Palden Jenkins
Palden Jenkins
Palden Jenkins
User
Autor

BTW: the images attached above come from this page:

www.ancientpenwith.org/nutshell.html

Czytaj więcej
Posted on the from Palden Jenkins
Esahc ..
Esahc ..
Moderator

Palden, where are you inserting text from?

I have had a similar problem caused when I imported text from a word document, to fix it I cut all text from the text cell(s), pasted to notepad and then copied it back (although on a couple of pages it was simpler to start again).

My apologies if this is not relevant to your issue.

Czytaj więcej
Posted on the from Esahc ..
Palden Jenkins
Palden Jenkins
User
Autor

Hello Esahc

Thanks for your note. Yes, I've already learned that lesson, and I do the same.

I'm encountering this problem when writing text directly into the cell editor in X5, so there won't be hidden code from other programs affecting the text.

Earlier, when I had this problem, I found it was possible to overcome this problem by re-editing the text to add or remove odd words so that there are the same number of lines to each paragraph in the editor as there are when the page is loaded in a browser. But something has changed in my program that makes it more difficult to calculate this.

Best wishes, Palden

Czytaj więcej
Posted on the from Palden Jenkins
Incomedia
Riccardo P.
Incomedia

Hello Palden,

try to remove the return or last character of the text and try again.

You can also split the text in two cells and merge these modift the margin and padding.

If you have trobule you can also send me the file .iwzip so i can test use https://www.wetransfer.com/

Thenk you.

Czytaj więcej
Posted on the from Riccardo P.
Palden Jenkins
Palden Jenkins
User
Autor

Hello Riccardo

Thanks for your message.

I've already cleaned up all pages to remove spaces at the end of lines. I think the problem might be that my version of X5 might be corrupted, or that something has crept into the CSS files for the overall design of the site. I'm not sure about that though.

I have uploaded the iwzip file for the site in question (though the problem is happening on one or two other sites I run too). It's here:

https://dl.dropboxusercontent.com/u/38483674/Ancient Penwith.iwzip

Thanks, and wishing you well

Palden

Czytaj więcej
Posted on the from Palden Jenkins
Incomedia
Riccardo P.
Incomedia

Hello Palden,

thank you for your project, i remove the dot (.) in the text and the cells works correctly.

Try to remove dot or all text,Copy all text in notepad and re-paste it.

Czytaj więcej
Posted on the from Riccardo P.
Palden Jenkins
Palden Jenkins
User
Autor

Hello

Sorry for the late reply (been away). I still have the problem, even though I have tried what you suggest.

Do you think I should completely reinstall the program? Perhaps something has gone wrong on my computer. Any tips on uninstalling it, to remove all possible causes of the problem, or will a normal uninstallation completely clean away all traces of the program before I reinstall it? I'm on Windows 10.

Best wishes

Palden

Czytaj więcej
Posted on the from Palden Jenkins
Incomedia
Riccardo P.
Incomedia

Hello Palden,

have you tried to remove dot or all text, and copied all text in notepad and re-paste it?

Try in a new project or in another pc, please.

thank you and let me know.

Czytaj więcej
Posted on the from Riccardo P.
Palden Jenkins
Palden Jenkins
User
Autor

Hello again. Sorry, been away.

Yes, I have done what you recommended, on at least a few pages on my sites, but the problem remains.

I have now constructed a new page on another site I run, importing text through Notepad and inserting JPG images in the text, aligned left and right, and the problem with spacing at the bottom of the cell is happening again. It doesn't seem to be caused by the images, since it also happens in cells where there is Notepad-cleaned text only.

I think I ought to reinstall my copy of X5 12 - see whether that eliminates the problem.

Thanks. Palden.

Czytaj więcej
Posted on the from Palden Jenkins