WebSite X5Help Center

 
Shrena J.
Shrena J.
User

Save project and missing image  en

Autor: Shrena J.
Visited 576, Followers 1, Udostępniony 0  

I need urgent help on saves project with missing image. Here are my problem using X5 pro.

  1. Each time open project file prompt "The specified project is in use or has not been closed correctly. Do you want to continue?" I choose yes to continue. 
  2. All images missing althought it can preview. I decided to load image and save the project. 
  3. Exit and re-open again it repeat item 1. & 2. again. Tried restored backup won't help. 
Posted on the
16 ODPOWIEDZI
Andre E
Andre E
Moderator

Try these:

  1. start x5 as admin (left mouse button)
  2. press ctrl button then preview
  3. export project in step5, import the exported project.

Still missing images, set them again manualy in x5.

Czytaj więcej
Posted on the from Andre E
Shrena J.
Shrena J.
User
Autor

I have tried but I still get message every time I open the project "The specified project is in use or has not been closed correctly. Do you want to continue?" and all my images missing even after I set them manually

Czytaj więcej
Posted on the from Shrena J.
Esahc ..
Esahc ..
Moderator

Shrena can you confirm you are working locally, not across a network, usb or cloud connection and if so can you try running WX5 after temporarily turning off/disabling/uninstalling antivirus, malware, firewall, vpn and one drive if active?

Czytaj więcej
Posted on the from Esahc ..
Andre E
Andre E
Moderator

Another Idea, from when on you have this issue, have you set some custom code somewhere that might not be handeld well by x5?

Try to make in the copy project ( or in the original if you have an imported as well at the moment. And remove any page that might have strange coding.

See also that you have no empty object spaces on your pages, x5 does not like this and can give strange result because of this. Fill all empty objects or remove complete empty rows and colums.

if you have 1 object and want it to the left use inner and outer margins and style button to align left and not empty objects.

If you can''t get around an empty object then fill in an empty html object.

Save regurly during the process of removing empty spaces.

Another Idea, try it with responive set to off, save and open and save and open and see if this works, if ok, then set responsive on again and check again. The above tipp still stands even if this trick works. (step2 template, customization, resolutions and responsive design.

Hope this helps.

Czytaj więcej
Posted on the from Andre E
Shrena J.
Shrena J.
User
Autor

I did the following:

1. Retrieve back-up manage to open without problem but all images missing.
2. Load images -->save-->exit
3. Open file again --> ""The specified project is in use or has not been closed correctly. Do you want to continue?". all images missing.
4. No add-on coding. Files resite at local drive. Disable anti-virus & firewall.
5. Re-install X5 pro still the same.
6. Tried export saves project file and reimport nothing help.

This is killing me it takes months for me to do it all over again.

Czytaj więcej
Posted on the from Shrena J.
Esahc ..
Esahc ..
Moderator

Shrena

Is there any chance this website is (or could be put) online?

Next time you add some images (if possible, use a different image name - this can be achieved by simply using windows explorer to either copy (recommended) or rename each image (perhaps just add a number to the filename)), can you go to step 5, export project to disk. Select a suitable folder. Now without closing WX5, use windows explorer to browse to where you saved the website and double click on the index file.

In your default browser are the images there??

If so, could you return to WX5 and return to step 5 export and select export project as suggested by Andre earlier. This will create an iwzip. Now close WX5 and reopen it, select import. Select the iwzip you just created (this will not overwrite your existing project), open the project. Are the images still there?? If so, if you save it, close WX5, open WX5 select the "new" project does it open without error??

How big is the final iwzip? (It may be possible that we could download the project and take a look)

(where are your images stored? I have made it a habit to create a folder called source inside the project folder, into here I copy all files, images, etc that I will use in a project)

Czytaj więcej
Posted on the from Esahc ..
Esahc ..
Esahc ..
Moderator

Shrena

I have downloaded your project. I can open it, edit it and save it in v13. I can close WX5 and later open it, then open 3wiredsys project without issue (btw congratulations, that is a lot of work and it looks great, I can see why you have no wish to rebuild it).

I changed the image under digital signage and multimedia screen, and I also changed PROJECTORS to PROJECTORS! without a problem. If you can offer specific instructions to change something that always causes the problem, please advise and I will be happy to test it at my end.

Can I assume you have tested by importing from the iwzip and yet still have problems?

Can I ask if you use any synchonising on your documents directory (eg drop box, one drive, iCloud, backup sync, etc), if any of these are running can you disable them (one drive runs by default on all Win 10 installations, I have found it to be a major problem until I stop it loading at startup).

I look forward to your reply.

Czytaj więcej
Posted on the from Esahc ..
Shrena J.
Shrena J.
User
Autor

I re-install the entire win 10. I manage to open the file without problem but the content & preview is empty although I can see right content preview.

Czytaj więcej
Posted on the from Shrena J.
Esahc ..
Esahc ..
Moderator

Shrena, I am afraid I am at a bit of a loss - my aoplogies for repeating myself.

Did you open the project or import from the iwzip you made available (if not, please import)?

Are you using AVG? There is at least one post with similar issues (although not content going missing on restart) where removal of AVG solved the problem. If you are using any anti-virus/malware/firewall/vpn/cloud storage (anything not install by default by Windows) please make sure it is off or preferrably uninstalled.

You say you did a clean install of Windows, I recently had a need to install a clean copy of Win10 (I went from blank HD directly to Win10 1809). Every attempt to run WX5 failed until I installed all releases of visual c++ I believe it was also necessary to revisit .net

Interestingly it was necessary to install both X64 & X86 versions of Visual c++

I followed the instructions in this post.

https://helpcenter.websitex5.com/pl/post/188230

Your project obviously works on my PC and it must have previously worked on yours, do you have any recollection as to when the issues started?

Normally I would recommend you purchase v17 and point the bone at v13, but your project opens perfectly in v13 on my PC. It would none-the less be interesting to see if v17 on your PC offers stability, you may wish to download the demo https://www.websitex5.com/en/demo-pro-form.html (I do not know if the demo will allow you to import your project but it might be worth a try).

Czytaj więcej
Posted on the from Esahc ..
Shrena J.
Shrena J.
User
Autor

I  am trying to figure out whether it is windows problem despite installation on all visual c++ release. Have tried open the project file and iwzip and problem remains. Have tried the demo pro v17 while converting I get this error:

'The specified project cannot be opened because it was created with later edition of website X5 (professional)' 

Czytaj więcej
Posted on the from Shrena J.
Jiper 85
Jiper 85
Moderator
Najlepszy Użytkownik miesiąca FR

Hi Shrena!

I saw on your project that all the confidential data are visible (FTP access, private area ...) which could be dangerous if an unhealthy individual downloads your project and sows the mess on your site.

So I allowed myself to put your message "hidden" for security.

If you have to put it back in "Public" you tell us ...

J.P.

Note that support technicians and moderators can read this message.

Czytaj więcej
Posted on the from Jiper 85
Shrena J.
Shrena J.
User
Autor

Thanks Jiper,  manage to delete permanately. FTP for old sample files I already change to SFTP last year.

Thanks Esahc.., I manage to install other application software with visual c++ release. Finally get to open project file with all content intact.  As for v17 demo still can't get it converted.  Hope someone can share how to resolve the conversion problem.

Czytaj więcej
Posted on the from Shrena J.
Esahc ..
Esahc ..
Moderator

Shrena, I believe you need a full copy (not demo) to import and upgrade an older project. You would need to upgrade to v17 pro.

Czytaj więcej
Posted on the from Esahc ..
Dieter D.
Dieter D.
User

Hi!

I had the same problem and found the solution!

Problem in my case seems that I had 2 differing Windows language versions (DE / EN) on the PCs.
As Website X5 has the standard to store stuff in a subfolder below "USER/Documents" and this is different by installed Win language, this can be a problem.

Solution: Create a folder in a different path. I.e. "C:\X5Projects" and have X5 point to that (very first page when you open X5 on the left side you find "Settings" to change the path where everything is stored).
Do that and then import the project. That worked for me!

Incomedia: this is a bug as it shouldn't be a problem to switch from a PC with german windows to one with english windows!

Greetings,
Dieter

Czytaj więcej
Posted on the from Dieter D.
Shrena J.
Shrena J.
User
Autor

Just upgraded to pro 2019.1.6 unfortunately it does't work after converted. Try open the content all empty not able to preview same old problem. I have updated all visual c++ redistributable still the same.  I am stuck now with same old problem again.

Czytaj więcej
Posted on the from Shrena J.
Esahc ..
Esahc ..
Moderator

Shrena, is there any chance you can make the v13 iwzip file available again? I have had a cleanout and upgrade of my PC so older files are no longer available. When creating the iwzip (step 5 export project) please do not include backup or preview files.

I will see if I can bring it into v2019 either in one or multiple steps without loss of content.

Czytaj więcej
Posted on the from Esahc ..