WebSite X5Help Center

 
Jacek A.
Jacek A.
User

Problem z działaniem kotwicy  pl

Autor: Jacek A.
Visited 267, Followers 1, Udostępniony 0  

Dzień dobry,

Z jakiegoś powodu po raz pierwszy mam problem z działaniem kotwic.
Na stronie główniej znajduje się 6 kafelków, które w zamyśle odsyłają do różnych sekcji tej samej strony:
https://www.mugen.com.pl/IB/index

Niestety tylko pierwszy rzeczywiście odsyła tam gdzie powinien, a cała reszta na dół strony o naziwe Galeria.
Dodam, że na samym dole strony nie ma żadnej kotwicy!

Każdy z kafelków ma przypisaną odrębną kotwicę do osobnych Simple Separatorów - po jednym nad każdym z tytułów galerii.
Wszystko wydaje się być skonfigurowane prawidłowo.
W czym może leżeć przyczyna?

Posted on the
21 ODPOWIEDZI - 1 POMOCNY
P. G
P. G
User

Język ang na górze również nie działa

Czytaj więcej
Posted on the from P. G
Jacek A.
Jacek A.
User
Autor

@P.G., to jest póki co jeszcze niedokończona wersja strony, bez wersji angielskiej.
Tę będę tworzył dopiero na podstawie działającej polskiej wersji

Czytaj więcej
Posted on the from Jacek A.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator

(It > Pl) ... adres witryny pokazany w kroku 5 jest niepoprawny:
...!...    http://localhost/index.html    ...!...
... plus może istnieją sprzeczne reguły serwera „.htaccess” ...

.

Czytaj więcej
Posted on the from  ‪ KolAsim ‪ ‪
Jacek A.
Jacek A.
User
Autor

@KolAsim, adres witryny jest roboczy (wrzuciłem go tymczasowo na własny serwer)
Problem, o którym piszę występuje już w programie WebsiteX5, jeszcze przed eksportem.
Jest więc to z pewnością jakiś błąd w kodzie.
Pytanie brzmi jak go wyeliminować?

Czytaj więcej
Posted on the from Jacek A.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator

... aby ocenić, opublikuj projekt poprawnie dostosuj ...
... nadal możesz oczekiwać ekspertów ...

cześć

Czytaj więcej
Posted on the from  ‪ KolAsim ‪ ‪
Jacek A.
Jacek A.
User
Autor

Po sprawdzeniu zachowania ładowania się strony myślę, że znalazłem przyczynę (ale nie rozwiązanie).
Ponieważ kotwice na innych stronach działają prawidłowo, stworzyłem stronę Galeria od nowa, ale nie dało to żadnego efektu.
Zauważyłem jednak, że w pierwszym momencie wczytywania strony, w zależności od przekierowania do konkretnej kotwicy, ładujące się elementy są startowo na różnych wysokościach strony.
Trwa to mniej niż sekundę, bo później ładują się galerie Justified Gallery i wszystko się sypie.
Tak jakby strona otwierała się na właściwym poziomie, a sekundę później - po załadowaniu się Justified Gallery, - zjeżdżała na sam dół.
To zachowanie jest nawet wyraźniejsze na smartfonie (dłuższe ładowanie):
https://www.mugen.com.pl/IB/galeria

Proszę o informację jak mogę rozwiązać ten problem.
Podkreślam, że dzieje się to już na poziomie samego programu, przed eksportem.

Czytaj więcej
Posted on the from Jacek A.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator

(It > Pl) ... nie wiem, czy może to zależeć od tego, ale adres witryny nie jest zgodny ze standardem, nadal jest nieprawidłowy:
<loc>http://localhost/index.html</loc>  ...!...

... czekam na opinię ekspertów ...

.

Czytaj więcej
Posted on the from  ‪ KolAsim ‪ ‪
Jacek A.
Jacek A.
User
Autor

@KolAsim,as I wrote before, given url address is temporary - I've uploaded website to my server to show you the problem that I'm struggling with.
But I have the same problem while working with WebsiteX5 software - even before exporting project.

In my opinion problem's source lies in slow loading of Justified Galleries that you can find here:
https://www.mugen.com.pl/IB/galeria
Because of that slow loading, initial anchor's positions are different that after one second, when galleries are loaded and whole page scrolls down.

Please let me know what do you think about it.

Czytaj więcej
Posted on the from Jacek A.
Andrzej K.
Andrzej K.
User
Najlepszy Użytkownik miesiąca PL

A nie wydaje Ci się, że lepsze pozycjonowanie byłoby gdybyś każdą galerię zrobił jako oddzielną stronę, a na niej np. przyciski u góry lub na dole to reszty galerii? Poza lepszym seo zniknąłby też ten problem kotwic :)

A co do błędów kotwic spróbuj zrobić kotwicę nie do pustego separatora ale albo do tytułu galerii albo do justified gallery. Czasem w tym programie trzeba coś próbowac obejść bo na poprawki producenta czy choćby jego reakcję można się nigdy nie doczekać ;)

Czytaj więcej
Posted on the from Andrzej K.
Jacek A.
Jacek A.
User
Autor

@Andrzej K., sęk w tym że w tym przypadku odgórnie mam zalecenie umieszczenia całej galerii na jednej stronie.
Niestety przypisywanie kotwic do innych elementów daje ten sam rezultat :(

Czytaj więcej
Posted on the from Jacek A.
Andrzej K.
Andrzej K.
User
Najlepszy Użytkownik miesiąca PL

A użycie innych galerii powoduje ten sam efekt, skoro to może być wina uzywanej galerii? Spróbuj np. standardowej galerii, bo może przez te dopasowania wysokości galerii Justified Gallery to się dzieje - standardowa ma jasno określoną wielkość więc może przy niej nie będzie tych problemów.

Czytaj więcej
Posted on the from Andrzej K.
Jacek A.
Jacek A.
User
Autor

Niestety standardowa galeria działa na innej zasadzie.
Czy ktoś wie jak mogę wyeliminować w zwykłej galerii problem dużych odstępów między kolejnymi wierszami zdjęć?
Margines zewnętrzny mam ustawiony na 1%, ale zdaje się on nie dotyczyć odstępów między kolejnymi werszami.



Inna sprawa, że nie po to kupowałem dostęp do Justified Gallery, żeby wracać teraz do standardowej...
Może wypowie się na ten temat w końcu Promise?

Czytaj więcej
Posted on the from Jacek A.
Andrzej K.
Andrzej K.
User
Najlepszy Użytkownik miesiąca PL

Ostatnio wyjaśniałem problemy z galerią (nawet z Promise, ale bezowocnie jak zwykle) https://helpcenter.websitex5.com/pl/post/217181

Nie udało mi się wyeliminować tego problemu z odstępami w galerii, o której piszesz - tzn da się, musisz tylko wstawiać obrazki i zdjęcia kwadratowe do galerii, bo program w standardowej galerii tworzy wirtualne kwadraty, w które wpisuje wstawiane zdjęcia - nawet jak zaznaczysz obrazek pojawia sie obwódka wkoło kwadratu bo program tworzy miniatury zdjęć w postaci przezroczystych plików png.

Czytaj więcej
Posted on the from Andrzej K.
Jacek A.
Jacek A.
User
Autor

@Andrzej K. dziękuję za wyjaśnienie. Rzeczywiście braki, o których piszesz wołają o pomstę do nieba...
@Promise, proszę o wiadomość, w jaki sposób mogę rozwiązać opisany w głównym poście problem.

Czytaj więcej
Posted on the from Jacek A.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator

(It > Pl)  ... może odkryłem na czym polega problem ...
.. może to zależeć od galerii, które nie zostały jeszcze załadowane, może powodować problem z względnym położeniem punktu kotwiczenia ...
... może spróbujesz opóźnić załadowanie strony kodem EXTRA ...
... w rzeczywistości, gdy strona jest już otwarta, te linki działają:
https://www.mugen.com.pl/IB/galeria#inst-zew
https://www.mugen.com.pl/IB/galeria#lazienki
https://www.mugen.com.pl/IB/galeria#ogolnobudowlane
https://www.mugen.com.pl/IB/galeria#wentylacja
https://www.mugen.com.pl/IB/galeria#wezly

.

ciao

.

Czytaj więcej
Posted on the from  ‪ KolAsim ‪ ‪
Promise SA
Promise SA
Icm Partner

Witaj Jacek,

Tak jak już napisali nasi poprzednicy, ten problem wynika ze sposobu w jaki przeglądarki wczytują stronę (tekst pojawia się od razu, przeglądarka nie zna jeszcze docelowych rozmiarów obrazków z galerii, które dopiero się wczytają) i jej elementy. Na chwilę obecną nie widzimy innej możliwości poradzenia sobie z tym problemem niż zmiana rodzaju galerii.

Pozdrawiamy

Czytaj więcej
Posted on the from Promise SA
Jacek A.
Jacek A.
User
Autor

@Bogdan P. tak, dokładnie o taki efekt chodzi.
Czy możesz wyjaśnić, jak to osiągnąłeś?
Stronę wykonałeś za pomocą Website X5?

@KolAsim, thank you for your feedback. It was also my lead, but I don't know how could I delay loading of seperate elements.

Czytaj więcej
Posted on the from Jacek A.
Bogdan P.
Bogdan P.
User

Wszyscy którzy zabierali głos w tej dyskusji po trosze mieli rację. Sedno sprawy tkwi w ustaleniu stałej wyskości div-a galerii i obijętnie jaka oba będzie kotwice powinny działać poprawnie. W przypadku który jest zastosowany umieszczone są obiekty Tekst (i tutaj jest kotwica) opisujący galerię oraz sama galeria. Wysokość galerii ustawiamy za pomocą kodu a następnie wstawiając galerię należy dobrać w obiekcie jej wysokość. W moim przypadku było to 780px i 450px. W mapie zaznacz stronę galeria następnie otwórz właściwości strony i zaawansowene. Po tagu otwierającym sekcję HEAD wstaw następujęcy kod:

<style> #imCell_14,#imCell_58,#imCell_61,#imCell_67,#imCell_71,#imCell_72 { height: 780px !important; }</style>

To jest kod który ustali wyskość div-a (na 780px) każdej galerii. Teraz należy ustawić jedynie wysokość poszczególnych galerii (w obiekcie) na około 100 (na zasadzie prób i błędów).

Czytaj więcej
Posted on the from Bogdan P.
Bogdan P.
Bogdan P.
User

W uzupełnieniu kod do wstawienia ustaliłem na podstawie kodu Twojej strony która jest w internecie. Będzie on działał tylko wtedy gdy wstawisz go we wskazane miejsce. Jeżeli coś zmienisz to program może zmienić identyfikatory div-ów i kod nie zadziała.

Czytaj więcej
Posted on the from Bogdan P.