WebSite X5Help Center

 
Krzysztof P.
Krzysztof P.
User

PRELOADER - Po implementacji nie działają niektóre komponenty strony  pl

Autor: Krzysztof P.
Visited 1539, Followers 1, Udostępniony 0  

Witam,

Zaimplementowałem PRELOADER jeden z tych:

https://simbyone.com/demo/30-css-page-preload-animations/

na stronie testowej: http://www.bigjeans.nazwa.pl/test2/

Po tym zabiegu nie działaja galerie: Justified gallery oraz Masonry (jest prawdopodobne że inne galerie tez nie zadziałaja - nie sprawdzałem)

fot. poniżej lub pod linkiem powyżej.

Dodam iż PRELOADER używa do działania script które sa umieszczone w "_scripts" fot. poniżej

plik: main.js - uruchamia skrypt aby preloader się zakończył w chwili załadowania strony

plik: jquery-2.0.2.min.js - i to pewnie sprawca całego zamieszania ?

Po usunieciu z programu jquery-2.0.2.min.js wszystko powraca do normy ale nie działa PRELOADER (tak jak by się jquery kłuciły z wersja zaimplementowana w programie?) 

Jest na to jakiś sposób?

Bardzo prosze o pomoc!

Posted on the
4 ODPOWIEDZI - 1 PRAWIDłOWA ODPOWIEDź
Promise SA
Promise SA
Icm Partner

Witaj Krzysztof,

Program WebSite X5 korzysta z biblioteki jQuery w wersji 3, skrypt który próbujesz użyć wykorzystuje starszą wersję. Niestety ale ta biblioteka może być użyta na stronie tylko raz, w jednej wersji i stąd właśnie problemy o których piszesz.

Pozdrawiamy

Czytaj więcej
Posted on the from Promise SA
Krzysztof P.
Krzysztof P.
User
Autor

Rozumiem, ale czy niema jakiegoś uniwersalnego sposobu aby to pogodzić ?

Skoro website X5 wykorzystuje nowsze biblioteki to chyba lepiej tyle że ta biblioteka nie uruchamia skryptu main.js który jest odpowiedzialny za chowanie preloadera.

Czy może trzeba podmienić bibliotekę? lub wskazać w jakiś sposób załadowanie jej?

Bardzo brakuje takiej funkcjonalności w Website X5 a z tego co zdołałem już sprawdzić wszystkie proleadery potrzebują bibliotek jQuery lecz ta biblioteka zaimplementowana nie wspiera skryptów.

Czytaj więcej
Posted on the from Krzysztof P.
Promise SA
Promise SA
Icm Partner

Witaj Krzysztof,

Nowsza wersja biblioteki jest kompatybilna wstecz więc prawdopodobnie wystarczy usunąć starszą bibliotekę z Twojego skryptu i ewentualnie dostosować go do zmian w nowszej wersji. Dwóch wersji tej biblioteki nie można używać jednocześnie. Skrypt "main.js" jedynie wykorzystuje funkcji z biblioteki jQuery, nic sam nie uruchamia.

Pozdrawiamy

Czytaj więcej
Posted on the from Promise SA