WebSite X5Help Center

 
Per G.
Per G.
User

Php 7.1 downgrade  en

Autor: Per G.
Visited 474, Followers 1, Udostępniony 0  

Is it possible to downgrade the requirement of php 7.1-version from X5?

My web-provider runs php 7.0 on their servers and have no plans of opgrading.

So if i shall have my website up and running, i have to switch to another web-site-provider - og what?

Posted on the
2 ODPOWIEDZI - 1 POMOCNY - 1 PRAWIDłOWA ODPOWIEDź
Paul M.
Paul M.
Moderator

Hello Per,

There is no alternative way to run WebSite X5 PHP scripts from version 2020.1 onwards: version 7.1 is the absolute minimum required for compatibility:

Version 2020.1 requires PHP 7.1

Having said that, PHP is not essential for all WebSite X5 sites.  But if you want to make use of certain features (such as Contact Forms) then it is required.

A webhost who has no plans to upgrade PHP on their server from version 7.0 is demonstrating a serious lack of concern with regards to web security, speed and optimisation on behalf of their clients.  The current stable release of PHP is version 7.4.7  -  the list of bug fixes and improvements since version 7.0 is enormous.  Version 7.0 dates back to 2015.  Version 8.0 (alpha) has just been released.

PHP version 7 changelog

Kind regards,

Paul

Search the WebSite X5 Help Center

Czytaj więcej
Posted on the from Paul M.
Per G.
Per G.
User
Autor

thanks - I have found a new webhost!

Czytaj więcej
Posted on the from Per G.