WebSite X5Help Center

 
Jim C.
Jim C.
User

Poll Object any help to make it work?  en

Autor: Jim C.
Visitado 489, Seguidores 2, Compartilhado 0  

Hi All,

I recently bought the Poll Object, however I have not been able to get it to work. I have looked on the forum for any set up instructions etc. but have not found any.

My webserver uses the mariaPHPMyAdmin SQL database and being honest, it is beyond me how to set it up. I did try many years ago to understand Access but gave up as it was just giving me a massive headache! I can “open” a database on the server but that is as far as it goes.

The problems that I have are:

Figuring out where the “Writing Access Folder” is in the server (see attached jpeg).

How to get the Poll Object to communicate with the database.

I fully appreciate that Incomedia would not be able to assist with my inability to set up the database and I fully understand that.

However, I am hoping that other users have set up the Poll Object and hopefully can explain to me in very basic steps how to get it to work and how to set up the mariaPHPMyAdmin SQL database.

Any assistance would be appreciated, but please be gentle on me.

Jim

Publicado em
9 RESPOSTAS - 1 CORRIGIR
Andre E
Andre E
Moderator

Hello Jim,

This is not hard, it sounds worse then it is to get it working.

The folder you don't need.

You do need to set a databse at your host, as I understand you know how to do that.

You have localhost all set and so on, what's importand is that the database you use, is only used once, so only for 1 item in x5, nothing more.

So you created an empty database, you filled in the information.

Then set the name in the name in the oll object, and select the databse.

Then set your questions and all the rest in the poll object.

Then upload and check online.

That's it.

Ler mais
Publicado em de Andre E
Andre E
Andre E
Moderator

But it does not work I see and you followed all steps.

you don't need to connect to the databse using SQL, this does x5 all for  you.

If it does not work, remove databse, make a new one, add this and try again.

It's importand that the name password, adress and so on from the database are correct.

Ler mais
Publicado em de Andre E
Jim C.
Jim C.
User
Autor

Hi Andre E,

Thank you for your usual prompt response, I have removed the existing database as suggested by you and created a new database, however as I have no experience of creating databases, I may not have done it correctly, if so please bear with me.

See attached jpeg:

  1. Server: localhost Database: cl56-jimc Table: Poll
  2. Set up database ??????????
  3. Data Management set up in X5
  4. Poll set up in X5
  5. Online error message when trying to use the Poll Object.

I suspect that I may be doing something wrong with the database set up, but what I don’t know. If this is the case I would probably need step-by-step instructions, or if possible, a working example of the database set up. I  can usually figure things out from a working example.

I certainly appreciate any help that you can provide me and thank you for your time and patience.

Jim

Ler mais
Publicado em de Jim C.
Henry H.
Henry H.
User

Hola la el procedimiento es correcto salvo el crear la tabla, deje la base de datos en blanco no añada ninguna tabla, esta misma la crea website x5 en Data Saving alli se escribe el nombre de la tabla

Ler mais
Publicado em de Henry H.
Andre E
Andre E
Moderator

Hello Jim,
You need to create the databse online on you portal of your webserver/webprovider.

There you have an option to create a database.

Remove all items in x5 from database

create a new one at your host (seee the faq of your host) You will get then the information you need to fill in in x5, (host name database name username and password, these items are only for the databse. The description in x5 is something you can give yourself a name just for own knowing what database it is, name it Poll if you make it for the poll object. but any other name works.

Then select this name in the poll object (only the databse name.)

Then it should work.

Ler mais
Publicado em de Andre E
Jim C.
Jim C.
User
Autor

Hi Henry H,

Hola la el procedimiento es correcto salvo el crear la tabla, deje la base de datos en blanco no añada ninguna tabla, esta misma la crea website x5 en Data Saving alli se escribe el nombre de la table

Google translate:

Hello the procedure is correct except to create the table, leave the database blank do not add any table, this is created by website x5 in Data Saving there is written the name of the table.

Google translate:

Gracias por sus comentarios, he intentado dejar la base de datos en blanco como sugirió, sin embargo, X5 insiste en que se ingresen estos datos, que se obtienen de la sección Administración de datos en Configuración avanzada. X5 no le permitirá avanzar si los campos de guardado de datos están en blanco.

Pido disculpas si he entendido mal sus comentarios traducidos por Google.

Thank you for your feedback, I have tried leaving the database blank as you have suggested, however X5 insists that this data is entered, which it gets from the Data Management section in Advanced Settings. X5 will not allow you to progress if the data saving fields are blank.

I apologise if I have misunderstood your feedback translated by Google.

Jim

Ler mais
Publicado em de Jim C.
Jim C.
Jim C.
User
Autor

Hi Andre E,

Finally got it to work OK, I was making two errors:

1.Instead of just creating a database on the server, I was also creating the table, however you don’t need to do     that as X5 creates it for you.

2.When I initially set up the database on the server, I had to give a user name and password, the database then   created a user name database of cl56-jimc

When I was setting up the details in Data Management in X5, I was using the initial user name that I gave to set up the database on the server rather than the created user name database of cl56-jimc see below:

There is one other issue that I have noticed, when you place the cursor over the bar chart a box appears see below, but only shows four letters out of the five, E is cut off.

The website is at www.jimcosgrove.co.uk

Once again many thanks for all your help and support.

Jim

Ler mais
Publicado em de Jim C.
Andre E
Andre E
Moderator

Great,
I had a feeling the user name was not from database but i good not see that offcource, that's why i posted to use this from databse.

And Henry stated that table is not needed as well.

Anyway, thanks for the feedback again, and glad it works now.

Best regards.

Ler mais
Publicado em de Andre E
Jim C.
Jim C.
User
Autor

Hi Henry H,

Thank you for your feedback, I apologise, as I did not fully understand what you were telling me. I did do as you suggested and left the database blank, but it still did not work but that was due to me using the wrong user name.

Instead of just creating a database on the server, I was also creating the table, however you don’t need to do that as X5 creates it for you as you quite rightly said.

When I initially set up the database on the server, I had to give a user name and password, the database then created a user name database of cl56-jimc.

When I was setting up the details in Data Management in X5, I was using the initial user name that I gave to set up the database on the server rather than the created user name database of cl56-jimc.

Thank you for your help.

Jim.

Google translate:

Gracias por sus comentarios, me disculpo, ya que no entendí completamente lo que me estaba diciendo.Hice lo que me sugirió y dejé la base de datos en blanco, pero aún así no funcionó, pero se debió a que usé el nombre de usuario incorrecto.

En lugar de solo crear una base de datos en el servidor, también estaba creando la tabla, sin embargo, no es necesario que lo haga, ya que X5 la crea para usted como lo ha dicho correctamente.
Cuando configuré inicialmente la base de datos en el servidor, tuve que dar un nombre de usuario y contraseña, luego la base de datos creó una base de datos de nombres de usuario de cl56-jimc.
Cuando estaba configurando los detalles en Data Management en X5, estaba usando el nombre de usuario inicial que le di para configurar la base de datos en el servidor en lugar de la base de datos de nombres de usuario creada de cl56-jimc.

Gracias por tu ayuda.

Jim.

Ler mais
Publicado em de Jim C.