WebSite X5Help Center

 
Saravanan A.
Saravanan A.
User

Search field takes long time reports empty screen  en

Autor: Saravanan A.
Besucht 754, Followers 1, Geteilt 0  

Search field on my website built on X5 PRO does not work since long.My domain hosting is set to latest PHP 7.3.30 version.Is there any settings to follow in X5 PRO.

Thank you

Gepostet am
19 ANTWORTEN - 3 NüTZLICH
Esahc ..
Esahc ..
Moderator

Saravanan, is the domain name in your upload screen the same as your actual website?

If this is different (eg your website is https://yourwebsite.com but WX5 thinks it is http://yourwebsite.com) this can affect search functionality and a number of other objects/features.

Is it possible to post a link to your site here with a description of what you are looking for so we can check?

Mehr lesen
Gepostet am von Esahc ..
Saravanan A.
Saravanan A.
User

Thank you for the reply.

Here is the link for my website :

https://www.alselectro.com/

Search field box is not responding.In previous version it was ok.

Mehr lesen
Gepostet am von Saravanan A.
Esahc ..
Esahc ..
Moderator

Saravanan, you say it used to work in an earlier version. Which version was that?

Have you ever tried removing the search field and adding it again in case something got corrupted in the upgrade? Perhaps add it to the footer and see if it works from there (unfortunately you can only test this when online)

The only other potential fault I can think of is old code on your site. If you have the time and patience I recommend previewing your website, select CTRL+preview and then do a FULL upload of your site (not new and changed)

Since I can not see what might be the issue I have marked your post for Incomedia's attention.

PS I tried to look at this issue on your website through my mobile and it was nearly impossible. I strongly suggest you make it a responsive site.

Mehr lesen
Gepostet am von Esahc ..
Claudio D.
Claudio D.
Moderator
Nutzer des Monats IT

sei su Host Windows...

quasi sicuramente il problema è quello

Con Host Linux hai migliori performance e compatibilità

Mehr lesen
Gepostet am von Claudio D.
Esahc ..
Esahc ..
Moderator

For anyone following

Claudio

you are on Windows Host ...this is almost certainly the problemWith Host Linux you have better performance and compatibility

Mehr lesen
Gepostet am von Esahc ..
Saravanan A.
Saravanan A.
User
Autor

Earlier it was ok with X5 EVO.

After upgrading to PRO the Search field is not working.

Thanks for your suggestion Esahc ..to make the sit responsive on mobile view.But search field problem is not solved.

Mehr lesen
Gepostet am von Saravanan A.
Esahc ..
Esahc ..
Moderator

Saravanan, if it used to work on the same hosting it should work now. You can use the hosting file manager (or hosting control panel, filezilla etc) to remove every file/folder in your hosting directory and then do a full upload. I will be very surprised if this does not fix the issue.

Mehr lesen
Gepostet am von Esahc ..
Saravanan A.
Saravanan A.
User
Autor

Destination folder while uploading is set to root as seen in image1.

Do I need to change this?

Also while while uploading I get an initial error as in image2.Is this anyway affecting the search?

Thank you for your consistent support

Mehr lesen
Gepostet am von Saravanan A.
Saravanan A.
Saravanan A.
User
Autor

Uploading set to Root as seen in image

Mehr lesen
Gepostet am von Saravanan A.
Esahc ..
Esahc ..
Moderator

Saravanan, I see nothing wrong with the setup in er2.jpg (many hosts are configured this way), but your write permissions could well be the issue. Perhaps you can contact your host and have this rectified?

Mehr lesen
Gepostet am von Esahc ..
John S.
John S.
User

There is a problem as described in this post. The problem is in v. 2021.3.3

I reported it and sent a project to incomedia.

They could see the problem.

This problem is solved in v. 2021.3.4

Mehr lesen
Gepostet am von John S.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator

...!... meanwhile, delete the text string that was mistakenly entered in HEAD...!...

.

Mehr lesen
Gepostet am von  ‪ KolAsim ‪ ‪
Saravanan A.
Saravanan A.
User
Autor

Tried all suggestions, but Search bar is not reporting any result.I think it is problem with version 2019.3.17.

If I upgrade to 2021.4 , will the problem be solved?

As my website is dependent on Search Bar.

Mehr lesen
Gepostet am von Saravanan A.
John S.
John S.
User

I repeat:

John S.
There is a problem as described in this post. The problem is in v. 2021.3.3 I reported it and sent a project to incomedia. They could see the problem. This problem is solved in v. 2021.3.4

I guess it goes also for the versions newer than 2021.3.4 - but one cannot be surelaughing

Mehr lesen
Gepostet am von John S.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Saravanan A.
Tried all suggestions, but ... ... ... 

...!... no! ... ... the error I reported to you earlier has not yet been corrected...!...

.

Mehr lesen
Gepostet am von  ‪ KolAsim ‪ ‪
Saravanan A.
Saravanan A.
User
Autor

Text string under head removed.That doesn't help.Same empty results after taking long time to search. 

Mehr lesen
Gepostet am von Saravanan A.
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator

... maybe it will depend on what Claudio(Apache / Linux) said ...
... we will have to wait for the opinion of the STAFF ...
... anyway, the important thing is that the whole site must be in order, because now it is not ...

.

Mehr lesen
Gepostet am von  ‪ KolAsim ‪ ‪
John S.
John S.
User

Again - it is a known problem - solved in later version.

Is my posts appearing as white text on white background on other devices than mine?????

Mehr lesen
Gepostet am von John S.
Axel  
Axel  
User
John S.
Is my posts appearing as white text on white background on other devices than mine?????

text in in black with whit bg ! wink

Mehr lesen
Gepostet am von Axel