WebSite X5Help Center

 
Andy A.
Andy A.
User

Database set up  en

Author: Andy A.
Visited 759, Followers 2, Shared 0  

Are there any gudes on setting up a database for the on line store?

I see you can manage stock from the store but need to activate sned data to database before setting up a products available quantity.

I am totally new to this section and would like some advice on how this is done?

Many thanks in advance

Posted on the
60 ANSWERS
Incomedia
Stefano G.
Incomedia

Hi Andy,

I believe our official guide could prove very useful to you in a situation like this, check this out:

http://help.websitex5.com/en/v16/pro/cart_order_ht.htm

You can also access the guide from inside the software by pressing F1 wherever you are in WebSiteX5.

If you still have trouble with it let me know.

In short: you need to create a databaseby using the information from your webhosting, who should be providing you with the database name, password and host address. You then just fill in the database section in the program.

This should be about all, feel free to try this out. Should you have any further doubt please get back to me here so that I might further help you out with it

Thank you

Stefano

Read more
Posted on the from Stefano G.
Andy A.
Andy A.
User
Author

Hi Stefano.

Many thanks for the info. I have set up the database on our server and think I have it working. The only section I cant find is in the help file it says to display quantities in stock on the product cards select the "Show availability" option, but I can't see this anywhere? I will then be able to test if all working OK once Ithis is selected.

Thank you

Andy

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

I have the database showing in my control panel but not able to show any stock in the database, I have added stock in the availability section of the cart but this is still showing as "0" even after upload. If I choose "update" in the product list I get a connection error, it is not possible to complete the operation.  

Read more
Posted on the from Andy A.
Incomedia
Stefano G.
Incomedia

Hi Andy.

Are you talking about the X5 control panel or the hosting's control panel?

If you're talking about the hosting's one, I recommend you test it out with the X5 Database testing tool first.

Navigate to www.yourwebsitesname.com/admin and insert the Admin credentials given at Step 1 -> Access Management inside the software. Then navigate to the test section and see what the Database test says.

Please report that here to me so that we might look further into this. Eventually, post a screenshot of that

Thank you

Stefano

Read more
Posted on the from Stefano G.
Andy A.
Andy A.
User
Author

Hi Stefano.

I have tested with X5 control panel and says OK...

but still quantities say "0"

Thank you

Andy

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

This shows what I get when I try "Update"

Read more
Posted on the from Andy A.
Wsx5.afsoftware.fr  
Wsx5.afsoftware.fr  
User

Hey Andy,

Here https://wsx5.afsoftware.fr/viewforum.php?f=108 you have many tutorial about e-Commerce implementation and also documentation about stock management.

Another tool very usefull could be found here https://wsx5.afsoftware.fr/viewtopic.php?f=110&t=85 which is complementary to your actual project.

You can manage all database informations and also to have somes statistics, dashboard, export (PDF, CSV, XLS ...) printing ... and more

Regards

https://wsx5.afsoftware.fr

Read more
Posted on the from Wsx5.afsoftware.fr  
Incomedia
Stefano G.
Incomedia

Hi Andy.

The fact that the quantity wasn't updated after the upload ( which is the precise moment when this should happen ), it might mean that the Database didn't successfully create the table it needs. The update button instead is needed when you want to synchronize the quantities FROM your website TO your software. Not the other way, be careful. In order to update the quantities FROM your software TO your website, you need to export the website.

At this point, proceed like this:

Try and contact your hosting again, and ask them to check if tables were created in your Database. If those weren't then something probably went wrong with the connection, and you might need to ask the hosting to check if they have any log that show exactly what went wrong

After you get a response for this, keep me posted here

Thank you

Stefano

Read more
Posted on the from Stefano G.
Andy A.
Andy A.
User
Author

Hi Stefano.

I have asked host supplier and also I can check fro our phpMyAdmin section and there are no tables created.

Thanks

Andy

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

Here is the conversation with our host...

  • Jack B

    ‎15‎:‎22‎:‎35

    There have not been any set up on our side

  • Andy Addy

    ‎15‎:‎23‎:‎31

    This is why the quantities are not updating then. Is there a section on cPanel etc where I can tell when or if these tables are or have been created ?

  • Jack B

    ‎15‎:‎23‎:‎43

    Yep - you can check in cPanel > phpMyAdmin

  • Andy Addy

    ‎15‎:‎25‎:‎28

    So is this a software problem at my end or an issue with acces permissions at your side ?

  • Jack B

    ‎15‎:‎27‎:‎40

    You have 100% been whitelisted our side - I cannot see anything here that would prevent that access

  • Andy Addy

    ‎15‎:‎28‎:‎22

    OK thanks I will get back to the software suppliers and pursue this further....

  • Jack B

    ‎15‎:‎28‎:‎42

    No problem - thanks Andy

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

I have also tried to set up a user log in database and have the same problem, no tables created ?

Any further advice?

Regards

Andy

Read more
Posted on the from Andy A.
Incomedia
Stefano G.
Incomedia

Hi Andy,

If you're sure that all of the data inserted in the Data management category inside the software is correct, try this still.

Try and change the prefix for the generate table that you inserted into the software with something different, and export again ( you can find this in the Shopping cart section ) :

Should it still not be working after the export, let me know here and I will proceed to turning your topic private, as I might need to perform tests on your project directly

Thank you

Stefano

Read more
Posted on the from Stefano G.
Andy A.
Andy A.
User
Author

Hi Stefan.

Have tried as suggested but still no tables created?

Thanks

Andy

Read more
Posted on the from Andy A.
Incomedia
Stefano G.
Incomedia

Hi Andy.

At this point I'm lead to believe that something might be off with your hosting specifically. If after an export the tables do not get created, it most probably mean that either the Database credentials or some kind of permission wasn't setup correctly.

Would it be possible for you to try and upload your website on a free, different and temporary hosting?

If so, test these same functionalities there, and see if those work for you

Eventually, contact their hosting's support too for guidance

Let me know the result here so that we might look deeper into this

Thank you

Stefano

Read more
Posted on the from Stefano G.
Andy A.
Andy A.
User
Author

Hi Stefano.

I now have the user log in working, orders database tables working but i cant get any items to show in stock, any advice please ?

Thanks

Andy

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

Also how to get quantity in stock to show on each card on the site..

Read more
Posted on the from Andy A.
Incomedia
Stefano G.
Incomedia

Hi Andy.

In order to change the availability for each product, you need to specificy that inside the software and then perform an export online. If you managed to get all the rest to work it is weird that simply this just won't. Are you aware of what tables are currently present in your Database, as to confirm that it has been created correctly?

Also, how did you manage to get the other tables to be generated?

Please double check all of this and keep me posted

Thank you

Stefano

Read more
Posted on the from Stefano G.
Andy A.
Andy A.
User
Author

Hi Stefano.

Firstly appologies about the double post. I will set the other as resolved.

I have a screen shot of the list of tables created if this helps.

Thank you

Andy

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

I have tried to change the quantities as you described each time and on all items and uploaded several times but still no stock shows and if you try to order on line it tells you the item is not in stock.

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

Have re named the tables prefix name and re uploaded now i have more tables than before but still no quantities ?

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

Have now deleted all tables, re set the prefix to test_ and now no tables in the database at all

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

Database must take some time to regenerate as I now have test- prefix tables showing again but no quantities ?

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

X5 is generating the tables i assume as they appear after web site exported...

Read more
Posted on the from Andy A.
Incomedia
Stefano G.
Incomedia

Hi Andy.

Yes, the tables should get generated right after the export of the files on your online server. That is the moment when the software starts writing data into the Database.

I find it weird that you're having these many issues getting some tables to show up. Do you perhaps have the possibility of getting a different, free and temporary hosting just to try and export the same website there and see if everything works out correctly?

I believe something might be blocking the correct generation of the tables on your hosting, and this test would really help this analysis out

Keep me posted on this

Thank you

Stefano

Read more
Posted on the from Stefano G.
Andy A.
Andy A.
User
Author

Hi.

I am struggling to find a suitable free host where I can simply upload the site. Surely though if X5 is writing the tables, it should also write to the tables as well as it has full permissions and access. ?

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

I have the tables showing and created but still not putting stock into the tables... very frustrating..

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

Permissions must be set correct as the user register section works fine ?

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

Have also tried exporting as a csv and importing to the databse but get an error "Invalid column count in CSV input on line 1"

Read more
Posted on the from Andy A.
Incomedia
Stefano G.
Incomedia

Hi Andy.

The CSV issue is a totally different one, so let's keep that for later now.

If the tables can be generated correctly, that part we can safely say that it is working correctly.

As you stated before, it should not have any particular problem updating the quantities too. What version of the software are you using right now? v16 or v17? Have you tried with both?

Since we've received no report of any specific issue with this, I'm still lead to believe some kind of misconfiguration is to be blamed here. Again, your hosting should have access to the Database logs that identify exactly why the data is not being inserted at Export time, or if no request is reaching them at all.

The best would still be to just find a free hosting where you can upload the site temporarily just for testing this.

Altervista is an example of this, and should provide all the necessary configuration to test this out freely.

Try it out and let me know the result

Thank you

Stefano

Read more
Posted on the from Stefano G.
Andy A.
Andy A.
User
Author

Hi Stefano.

I am using V17.0.6.

Will try using V16 and check results.

Will also see if I can upload to the server you suggested, will keep you posted..

Thanks

Andy

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

I cant open in V16 as this is now converted into V17.

The host does not log remote databases.

I have tried to set up an account with Altervista but not having much success.

Think i will abandon this project.

Andy

Read more
Posted on the from Andy A.
John S.
John S.
User

Hello Andy

Just read this thread.

You should be aware that the stock-quantity is special. This is not created on the server, but is "uploaded" from X5 and is therefore outside.

You have to, in CPanel to allow access to database from your IP ( your Pc's IP ).

Does this give any meaning to you?

You could also see here : https://wsx5.afsoftware.fr/viewtopic.php?f=108&t=43 for a guide. If you are not a member already, then join - it's free.

Kind regards

John S.

Read more
Posted on the from John S.
Andy A.
Andy A.
User
Author

Hi John.

Yes I understand the quantities are updated in X5 then uploaded but even though I update the quantities and export this still doesn't update the quantities. Also I have my IP on a white list with my providor.

I have done all the steps described in your document and this still doesn't alter any quantities.

I still think this is an X5 issue as the data for the log in section works absolutely fine ?

Regards

Andy

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

Screenshot of quantities section I am using

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

The quantities are not showing up on the cards on each page of stock either and if you try to order an item it says item is out of stock

Read more
Posted on the from Andy A.
Wsx5.afsoftware.fr  
Wsx5.afsoftware.fr  
User

Hey Andy,

Try to do an order
Check if the tables are populated
May be the mecanism will be started with the db to manage stock

Change stock fro the produt(s) previsously ordered.
Click update button..

Upload website.

Important: does your web page were are your products is in .HTML or .PHP ?

if not .PHP the stock will work never !!!
In this case Incomedia need to help you to find the issue

Hope this helps

https://wsx5.afsofwtare.fr

Read more
Posted on the from Wsx5.afsoftware.fr  
Andy A.
Andy A.
User
Author

Hi.

If I try an order then it tells me out of stock

Not sure what you mean about tables being populated ?

When I click the update button I get a connection error: it is not possible to complete the operation.

I also dont understand what you mean about the page where products are is in html or php? It is a page I created in X5 with the cart on it so I assume html ?

Regards

Andy

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

Looking on the FTP Export list I can see a php and a html page for each of the pages created which have a form, cart etc on them.

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

Looking on the live version I can see the page is a php 

Read more
Posted on the from Andy A.
Wsx5.afsoftware.fr  
Wsx5.afsoftware.fr  
User

Hey Andy,

Not sure what you mean about tables being populated ?
populated = check if the order is registered into tables into the database.

Please check here: https://wsx5.afsoftware.fr/viewtopic.php?f=7&t=38 regarding your message:

When I click the update button I get a connection error: it is not possible to complete the operation.yell

If the configuration is ok, in this case the ISP has blocked any access from external system to the database. In this case the database can be reached just only from website. And the update button cannot works... NEVERyell

Pls try to delete all files on your website and tu updload again.

normally the webpage should be in .PHP. With .HTML stock is not manageable.

Regards

https://wsx5.afsoftware.fr

Read more
Posted on the from Wsx5.afsoftware.fr  
Andy A.
Andy A.
User
Author

Hi.

Have deleted and re uploaded.. no change.

All configurations correct in database settings and my IP address is on our providors white list.

Cant be populating to table. Tables being created but no products inserted (populated)

Screen shot showing database settings in X5 and also the PHP Admin screen from my server

Regards

Andy

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

screen shot

Read more
Posted on the from Andy A.
Wsx5.afsoftware.fr  
Wsx5.afsoftware.fr  
User

Andy,

Does your user configured into your parameters has right to write into the database. !!!

You can test by.

click on your database (amwarkup_store) into phpMyAdmin

Into SQL tab try to create a table like:

CREATE TABLE AFS_TEST (
column1 int
)

And click on 'Execute'.

the table is created.

And your table is here

Hope this helps

Regards

https://wsx5.afsoftware.fr

Read more
Posted on the from Wsx5.afsoftware.fr  
Andy A.
Andy A.
User
Author

Hi ..

Yes the user has all access rights and also done the test you suggested (see screen shot)

Yes this all works OK so far ?

Andy

Read more
Posted on the from Andy A.
Wsx5.afsoftware.fr  
Wsx5.afsoftware.fr  
User

Andy,

Sorry, I have not anymore info to help you.yell

Now it's time to have a full support from Incomedia. 

And I am curious to know the solution ...

Hello Jipé can you pls drop a message to the support to help Andy.


Regards

https://wsx5.afsoftware.fr

Read more
Posted on the from Wsx5.afsoftware.fr  
Andy A.
Andy A.
User
Author

Many thanks for trying, i am at a loss myself as to why this is not working?

Cheers

Andy

Read more
Posted on the from Andy A.
Incomedia
Stefano G.
Incomedia

Hi Andy.

I'm really sorry about this issue you're experiencing, but considering that all of the other features are working just as expected, and no other report on this has been filed by any user yet, I'm still of course led to believe that some kind of important misconfiguration is to be blamed here, which messed up the functionalities between the software and the hosting.

At the moment, in order to sort this out for your project, you will have to test this on a different hosting, as mentioned above:

The best would still be to just find a free hosting where you can upload the site temporarily just for testing this.

At the moment, I'm afraid there is not much else here to help us individuate exactly what seems to be going wrong with this operation, and I'm sorry about not being able to help you further without this step

Keep me posted if you manage

Thank you

Stefano

Read more
Posted on the from Stefano G.
Andy A.
Andy A.
User
Author

Hi Stefano.

I have created an account with Altervista but this appears only to be a Blog site?

I will persivere and see if I find another to test this on. I still find it strange that I can do the log in OK but not the quantities. I guess you don't do teamviewer type support ?

Thanks

Andy

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

Have created a new account on naother server.

Tables wont create on the free server..

InfinityFree is the server I have finally got an account running on.

Loosing the will to live trying to set up this cart... yell

Read more
Posted on the from Andy A.
Atom S.
Atom S.
User

Hi Andy,

I have the same problem. I have the same problem.

Greets,

Atomprof

Read more
Posted on the from Atom S.
Luan Thanh T.
Luan Thanh T.
User

Hi Andy. 

This is a common  problem. The issue between your webwebs x5 and database permission.

Which host provider do you use?

I can help you with it.

Regards 

Luan

Read more
Posted on the from Luan Thanh T.
Andy A.
Andy A.
User
Author

Hi.

The log in section writes to the tables OK just not the cart etc..

We use Smart hosting

https://www.bestwebhosting.co.uk/

Regards

Andy

Read more
Posted on the from Andy A.
Luan Thanh T.
Luan Thanh T.
User

Email me the screenshot of control panel when you login your host. I am not sure on this provider.

Most provider is using cpanel. 

Regards

Luan

***

Read more
Posted on the from Luan Thanh T.
Andy A.
Andy A.
User
Author

Hi Luan.

Screenshot to follow..

Regards

Andy

Read more
Posted on the from Andy A.
Luan Thanh T.
Luan Thanh T.
User

Andy tries this method.

Go to File Manager and delete your website folder permanently ( dont move to trash)

then go to Database wizard create new database account and check all permission.

Go to your website x5 change new database setting.

This should be work. I have similar problem with your server controlpanel.

Regards

Luan

Read more
Posted on the from Luan Thanh T.
Andy A.
Andy A.
User
Author

Hi Luan

Have tried all you said, no luck.

Although like I said the register and log in section all works correctly.

I have tried to find a free host as Stefano has suggested to try upload to a different server but I am not having much success down this road either.

Cheers

Andy

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User
Author

After all this trouble attempting to set up the cart i think i am going to have to resort to 3rd party software ..

Read more
Posted on the from Andy A.
Luan Thanh T.
Luan Thanh T.
User

Can you login your website admin dash board?

Read more
Posted on the from Luan Thanh T.
Andy A.
Andy A.
User
Author

Hii Luan,

Yes I can log into admin dashboard

Read more
Posted on the from Andy A.