WebSite X5Help Center

 
Mr. Doctor Dust Mite  .
Mr. Doctor Dust Mite .
User

Php 7.2 support  en

Author: Mr. Doctor Dust Mite .
Visited 94, Followers 1, Shared 0  

PHP 5.x is unsecure. Wx5 should only support 7.x and above for security reasons. Most hosting providers discontinued support of PHP 5.x for those security reasons and will no longer install....

Wx5 should move to PHP 7.2.6 or higher. 7.4 is current, but 7.x is supported. PHP does not support below 7.1 currently.

PHP 5.x went out the window in 2014

Please bring the product current for security reasons.

Posted on the
3 ANSWERS
Luis S.
Luis S.
User

Wow, I thought this was already taken care of surprised

Read more
Posted on the from Luis S.
Aleksej H.
Aleksej H.
Moderator
Best User of the month RU

Hello. I checked many times. Sites work on PHP 7.0, 7.1, 7.2, 7.3.

Read more
Posted on the from Aleksej H.
Paul M.
Paul M.
Moderator
Best User of the month EN

Hello Mr. Doctor Dust Mite,

I concur with Aleksej and Luis that there is no issue with WebSite X5 when it comes to PHP security.

I have spent hours poring over the source code.  It is very well-coded.  If you know of any security loopholes please advise, but I cannot find any.

WebSite X5 has supported PHP 7.x for many months now.  The software requires a minimum of PHP 5.6 to operate correctly, but the onus is quite rightly on the user to ensure that they use the most recent version of PHP available to them.  This is something which WebSite X5 (Incomedia) has no control over, for obvious reasons.

Kind regards,

Paul

Search the WebSite X5 Help Center (multilingual)

Read more
Posted on the from Paul M.