WebSite X5Help Center

 
Reginaldo Almeida Standupweb
Reginaldo Almeida Standupweb
User

Emails, php, script mail, outlook, office 365, locaweb, microsoft  pt

Author: Reginaldo Almeida Standupweb
Visited 190, Followers 1, Shared 0  

Pessoal, crítico urgente

já testamos diversas vezes, e minha ultima atualizaçao, do WSx5 professional, continua o defeito de entregas de email.

por favor, qual PHP considerar, 5.6 ou 7 superior

mesmo testando script interno no servidor, tudo funciona, utilizando o formulário do website x5, nao recebemos email, até a atualizacao do 2019.2 estava tudo normal. 

Nos padroes, microsoft outlook on-line, office 365, locaweb Brasil, não recebem os scripts do formulário

Isso é terrível, estou perdendo muito nos clientes!

Nos ajude ai por favor

Posted on the
10 ANSWERS
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator

(It > Pt) ... use o email do remetente associado ao mesmo servidor de domínio que o site e o protocolo SMTP PHP Mailer ...
... você pode executar todo o TEST MAIL no painel ADMIN:
www.seusite.br/admin/

.

Read more
Posted on the from  ‪ KolAsim ‪ ‪
Reginaldo Almeida Standupweb
Reginaldo Almeida Standupweb
User
Author

o mesmo já estava assim, sempre utilizamos conforme sua descrição, e sempre testamos via /admin

mas, não funciona, e executando um scripit direto no servidor com um pacote basico, send, o email funciona normal, mas via formulário da incomedia, não funciona!

Read more
Posted on the from Reginaldo Almeida Standupweb
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator

... no painel ADMIN, tudo é suave, PASS /  VERDE ...?...
... verifique se há PHP/5.6 + > PHP/7+  ...?...
... execute todo o TEST MAIL e também verifique SPAM...

Read more
Posted on the from  ‪ KolAsim ‪ ‪
Reginaldo Almeida Standupweb
Reginaldo Almeida Standupweb
User
Author

no arquivo: -> class.phpmailer.php

<?php
/**
* PHPMailer - PHP email creation and transport class.
* PHP Version 5.5.

if (ini_get('mail.add_x_header') == 1
and 'mail' == $this->Mailer
and stripos(PHP_OS, 'WIN') === 0
and ((version_compare(PHP_VERSION, '7.0.0', '>=')
and version_compare(PHP_VERSION, '7.0.17', '<'))
or (version_compare(PHP_VERSION, '7.1.0', '>=')
and version_compare(PHP_VERSION, '7.1.3', '<')))

anexo imagem do painel admin

Read more
Posted on the from Reginaldo Almeida Standupweb
Incomedia
Stefano G.
Incomedia

Hello Reginaldo

No update was performed on the Emailing part of the software in the newest v2019.3 so I don't really believe that the update from .2 to .3 could be the cause for which the emails are no longer arriving. If you're using the PHPMailer system to send emails and the emails aren't working (plus you're receiving a server error saying that the email couldn't be instantiated) I am afraid that something must have changed at server-level.

Do you still have your v2019.2 project? If yes, could you upload it inside a subfolder and test the Contact Form?

Does it work from there?

Contact your hosting provider and make sure that you're able to send the emails using the method you've currently configured.

Also, how did you set up the Contact Form? Could you attach a screenshot of that too?

keep me posted here

Thank you

Stefano

GOOGLE TRANSLATE ---

Olá Reginaldo

Nenhuma atualização foi executada na parte de email do software na versão mais recente da v2019.3, portanto, não acredito que a atualização de .2 para .3 possa ser a causa pela qual os emails não estão mais chegando. Se você estiver usando o sistema PHPMailer para enviar e-mails e os e-mails não estiverem funcionando (além de receber um erro no servidor dizendo que o e-mail não pôde ser instanciado), receio que algo deva ter mudado no nível do servidor.

Você ainda tem seu projeto v2019.2? Se sim, você poderia enviá-lo dentro de uma subpasta e testar o formulário de contato?

Isso funciona a partir daí?

Entre em contato com seu provedor de hospedagem e verifique se você pode enviar os e-mails usando o método que você configurou atualmente.

Além disso, como você configurou o formulário de contato? Você poderia anexar uma captura de tela disso também?

mantenha-me informado aqui

Obrigado

Stefano

Read more
Posted on the from Stefano G.
Reginaldo Almeida Standupweb
Reginaldo Almeida Standupweb
User
Author

Non posso aspettare il centro assistenza
tutti i moduli della versione Professional 2019.3.14 vengono interrotti
Versione PHP (versione minima richiesta 5.6.0): trovata sul mio server -> 5.6.40

[2020-02-10 06:02:13] Impossibile creare un'istanza della funzione di posta.
[2020-02-10 06:02:13] Impossibile creare un'istanza della funzione di posta.
[2020-02-10 01:32:48] Impossibile creare un'istanza della funzione di posta.
[2020-02-10 01:32:48] Impossibile creare un'istanza della funzione di posta.
[2020-02-10 01:00:22] Impossibile creare un'istanza della funzione di posta.
[2020-02-10 00:53:38] Impossibile creare un'istanza della funzione di posta.
[2020-02-10 00:53:30] Impossibile inviare e-mail con script interno
[2020-02-10 00:48:48] Impossibile inviare e-mail con script interno
[2020-02-10 00:48:47] Impossibile inviare e-mail con script interno
[2020-02-10 00:48:12] Impossibile inviare e-mail con script interno
[2020-02-10 00:48:11] Impossibile inviare e-mail con script interno

Read more
Posted on the from Reginaldo Almeida Standupweb
Incomedia
Stefano G.
Incomedia

Hello Reginaldo

I've read the post you published on your other topic.

I'm not sure I understand correctly though. Did you verify that those modules cause the error to happen? So if you turn those off the error disappears?

What if you try to upgrade your PHP to 7.x. Does it work then?

Please test this and keep me posted. PHP 7 should provide a good boost in performance to your website 

Keep me posted here after

Thank you

Stefano

GOOGLE TRANSLATE ---

Olá Reginaldo

Eu li a postagem que você publicou sobre seu outro tópico.

Não tenho certeza se entendi corretamente. Você verificou se esses módulos causam o erro? Então, se você desativá-los, o erro desaparece?

E se você tentar atualizar seu PHP para 7.x. Funciona então?
Por favor, teste isso e me mantenha informado. O PHP 7 deve fornecer um bom impulso no desempenho do seu site

Mantenha-me informado aqui depois

Obrigado

Stefano

Read more
Posted on the from Stefano G.
Uilian Caetano
Uilian Caetano
Moderator

Bom dia Stefano, 

Realmente o website x5 sempre deu erro em hospedagem da Locaweb.

Eu na ultima versão usava a configuração SCRIPT PADRÃO, mas parou de funcionar após a atualização do software.

Eu testei todas versões do PHP desde a 5.6 a 7.2 disponível no servidor.

também fiz todos os teste de configuração disponível dentro do sistema para envio e nenhuma funcionou.

em um outro servidor meu que tem cPanel que não é no data center da Locaweb funciona normal os script de envio de e-mail.

Reginaldo só concluíndo a locaweb deve estar bloqueando alguma coisa, pois se fosse algum erro do Website X5 aconteceria que em nenhum servidor daria certo.

Bom minha opnião eu sempre tive problemas na locaweb com formulário do Website X5.

Read more
Posted on the from Uilian Caetano
Reginaldo Almeida Standupweb
Reginaldo Almeida Standupweb
User
Author

[quote="Uilian Caetano"]
[quote="Uilian Stefano"]

Bom dia, grupo!

Relato aqui pessoal que, é verdadeiro o fato que não está claro o uso aqui da versão do PHPMAILER.

Onde é o campo de inserir o email que vai remeter, realizar o envio do email para a caixa de correio.

Conforme forum diversos, utilizar o SMTP ou mail autenticado, demora um pouco mais a validação e pode conter falhas
de segurança, então o uso do phpmailer é melhor; (porem locaweb e kinghost) tem problemas com isso.

Os maiores do Brasil, Locaweb e como a KingHost, relatou verificando a documentação do formulário da incomedia websitx5 pro
que tem que definir claramente a documentação do PHP, versão e se pode ter mais de um destinatário de caixa de entrada.

Confirmo aqui que em outros posts, já veio acontecendo o problema nos formulários da WEBSITE X5

Reforço que ao chegar aqui em meados da versão 7-8 do websitex5, o que nos atraiu a atenção foi a facilidade de
construção de formulários e sua eficácia. Isso garante um bom visual e a confiabilidade de chegar o email ao cliente.
( também é fato que já deveriam melhorar os objetos para formulário, tipos, formatos e layouts; concluindo, precisamos continuar a
confiabilidade.

Conversando com o pessoal da KINGHOST e a infeliz LOCAWEB, a mesma informa que, para usar a versão do formulário da website X5,
devem usar como padrão, SMTP utilizando o conta de email do domínio para envio do próprio. exemplo, uma conta autenticada; pois há algum erro
no script de enviar o phpmailer.

como relatado nos posts principal e anteriores, assim que entrou essa penultima vesão e ultima, veio occorendo essa dor de cabeça.


Segue uma imagem de configuração básica!

quem é o endereçador, quem é que envia para o php mail, por favor nos informe aqui para os leigos de leitura da documentação.
?? /usr/sbin/ pergunta está na imagem

qual a versão estável? segundo forum deve ser a PHP 7.2?

Informaram também que, o arquivo (class.phpmailer.php), entre outros, devem realizar melhorias como versão PHP, /mod_pagespeed /mod_security

PHPMailer\PHPMailer; 5.5 e 5.6 é obsoleto e devem ser utilizado a estável 7.2

Pois o SOFTWARE da incomédia, WEBSITE X5, tem que prever lá na chamada, do tipo de formulário como, POST ou GET, também se o mesmo vai utilizar
serviços de email de terceiros, pois para definição de 'root@localhost'; pois existem fatos de o HOST, ser somente de HOSPEDAGEM, e a utilização de emails MX,
sem em outra instância fora, tipo: GSuit (google gmail versão pro) Exchange (microsoft office 365 online), mesmo definindo pelo HOST, o email não está chegando no destino e vice-versa.

Informo que na hospedagem compartilhada como KINGHOST eles não tem public ( $DKIM_domain ) não utilizam DKIM, como alguns outros provedores também não utilizam, mas outros diversos utilizam.
( tem que rever as políticas )

simples, diversas investigações foram realizadas, tivemos que fazer pois tem clientes desistindo, imaginem não chegar o email de seu futuro cliente?

aguardamos a revisão acima das considerações, e afirmo, outros posts já relataram o mesmo, e voces dizem que não houve mudanças nos códigos de formulários, então, vamos rever a política do PHP e certificações externas de formulários internacionais e também do Brasil. (locaweb https://www.infomoney.com.br/mercados/acao-da-locaweb-estreia-na-bolsa-com-disparada-de-16/ e KingHost)

lembre-se que tem diversos posts falando do mesmos, seguem alguns:

https://helpcenter.websitex5.com/en/post/222115

https://helpcenter.websitex5.com/en/post/221391

https://helpcenter.websitex5.com/en/post/222116

outro detalhe, para quem usa WP, alguma landing page, e ou serviços do WP, na KingHost entre outros, que está com dificuldades de acesso e lentidão,  no arquivo (wp-config.php) devem conter o código abaixo:

<?php

// SSL + Varnish
define('FORCE_SSL_LOGIN', true);
define('FORCE_SSL_ADMIN', true);
define('CONCATENATE_SCRIPTS', false);
if (isset($_SERVER['HTTP_X_FORWARDED_PROTO']) && strpos($_SERVER['HTTP_X_FORWARDED_PROTO'], 'https') !== false) {
$_SERVER['HTTPS'] = 'on';
}


/**
* The base configuration for WordPress

e os arquivos .json, solicitem a versão do seu PHP do seu host servidor para acima de 7.

Lembre-se que enquanto a website x5 não cuida do PHPMailer, voces deverão utilizar o chato do SMTP autenticado.

sem mais para o momento.

Read more
Posted on the from Reginaldo Almeida Standupweb
Carlos Amaral
Carlos Amaral
Moderator

Hola Reginaldo,

No entiendo bien el problema, has actualizado tu version de PHP a 7 o superior? Porque con eso seguro solucionas el problema...

Saludos colega!

Carlos A.

Read more
Posted on the from Carlos Amaral