WebSite X5Help Center

 
Ross P.
Ross P.
User

How do you add Facebook messenger to a webpage  en

Author: Ross P.
Visited 768, Followers 1, Shared 0  

Have been requested by a client to add Facebook Messenger to their website and have added the HTML code required to the page, but when opening the page the Facebook Messenger app does not always show up. Has anyone had experience with setting these up that could help please.

The website is https://rollestonbouncycastles.co.nz/ and on the contacts page under bookings.

I also have a code box on the page for Googlr Map - this wouldn't affect the Facebook code..would it?

Regards

Ross

Posted on the
11 ANSWERS - 4 USEFUL
Paul M.
Paul M.
Moderator

Hello Ross,

I don't use Facebook Messenger and have never embedded the code on a website, but I've had a quick look at the official guidance on your behalf this morning.  The first thing I notice is that you absolutely must whitelist your domain with Facebook.  Have you done this?

https://developers.facebook.com/docs/messenger-platform/discovery/facebook-chat-plugin/

https://developers.facebook.com/docs/messenger-platform/reference/messenger-profile-api/domain-whitelisting

Kind regards,

Paul

Search the WebSite X5 Help Center

Read more
Posted on the from Paul M.
Ross P.
Ross P.
User
Author

Hi Paul

Yes the domain name has been white listed, as per below but I have not added this anywhere on the website as assume it is only something to do with the Facebook page.

https://l.facebook.com/l.php?u=https%3A%2F%2Fwww.rollestonbouncycastles.co.nz%2F&h=AT24UfE2-coqdv92AnabEQBKwJYvie1jI8m7ammJmosN34dBHL1fL5uUr1yJWFqOoh6_paPB2NThnEdhnxdy6yTyIkuul4rN6bUx_fHvs4T0neaS7wvhlLvRcxCNYvFsXA

Thanks for looking that up 

Have attached an image of the code I have added.

Kind regards

Ross

Read more
Posted on the from Ross P.
Andy A.
Andy A.
User

Ross, script from FB, must be copied into  page properties a scustom code  and in the "after opening the body tag" on homepage..see screenshot below. if you go to kjwservices.co.uk  should be visible there on load  I also edited Code to match the design of website..  eg. black and white.. If you need a hand,  give me a shout..  

Cheers 

Andy A.

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User

OOp just noticed, you want it on the contacts page -  same principle, as you can add to any page you want,  just copy the script as above in page properties on Contacts/Bookings page.

On another note, and just an Observation, I would "Hide" the email address using protection as Web crawlers will inundate the email address with Spam..

Read more
Posted on the from Andy A.
Paul M.
Paul M.
Moderator

I've had a closer look at your page, Ross, and this time I notice that you currently have the code from Facebook added twice...  once just after the opening body tag, and secondly in an HTML Object.

Try removing one or the other, as the code should only appear on your page once.

Read more
Posted on the from Paul M.
Ross P.
Ross P.
User
Author

Thanks Andy & Paul for your help, it is really appreciated.

As mentioned Paul I have now deleted the HTML Object and just have it loaded after the opening body tag.

Andy thanks for you offer of help which I will check out with my client as to see if he wants the code to be customised. I have also added the code to the Home page and the Castles page but they do not appear on the site (like your one does). Not sure if this takes a while after uploading or not.

Once again thank you very much for your help.

Have a great day and stay safe and well.

Cheers Ross

Read more
Posted on the from Ross P.
Andy A.
Andy A.
User

Ross,

It should be almost immediate.  From within FB  check the guide again, and thereis an option to email yourself the code and guide.  that may help to identify the issue. I will check from this end  again..Nothing like a bit of real time testing...

Read more
Posted on the from Andy A.
Andy A.
Andy A.
User

I did a bit of digging at code, and if you look at code  side by side with mines, Your page on left/My WebX5 on right..   it appears to be slightly different referencing Install_ email as opposed to setup_tool.  If i was  a master coder, i wouldnt be using webX5  but knowa bit about it...  see below..  I would  check the set up and guide, remove all expert code and  try again..  see if you can get it working,  if not  the offer is there .. i can even  connect remotely if required if you get stuck,  though time difference is a bit apart... LOL

Read more
Posted on the from Andy A.
Ross P.
Ross P.
User
Author

Hi again Andy. I think I have found the problem in that my client has Whitelisted the site as https://www.rollestonbouncycastles.co.nz when it should be https://rollestonbouncycastles.co.nz

I have requested he whitelist the website correctly and asked if he wants the chat form customised.

Thanks again for you help, its' been really helpful.

Cheers and have a great day.

Ross

Read more
Posted on the from Ross P.
Andy A.
Andy A.
User

Ross,

I just checked and Messenger Pop up is working on contact page and Homepage as expected..   Good to see you got there in the end...

Read more
Posted on the from Andy A.
Ross P.
Ross P.
User
Author

Hi Andy

Just finished it tonight with the message etc. and pleased it is working, but a lot of the credit for it must go to you for all you help and assistance. I really have appreciated your guidance so THANK YOU very much.

All the best

Ross

Read more
Posted on the from Ross P.