WebSite X5Help Center

 
Francesco C.
Francesco C.
User

Problema importazione 13to14 vers. (errore su menù)  it

Auteur : Francesco C.
Visité 2281, Followers 1, Partagé 0  

Nella nuova versione 14, ho importato un progetto della 13. A differenza delle altre importazioni con le versioni successive, ci sono stati minor problemi. Per ora, l'unico riscontrato è che in una determinata pagina il menù in alto scompare improvvisamente una volta visualizzata la pagina.

Il progetto l'ho caricato in un'area test: http://www.ellebiweb.it/testsiti/labanda/ e la pagina interessata è quella dei contatti: http://www.ellebiweb.it/testsiti/labanda/contatti.html

p.s. per trovare le impostazioni del menù .. ho trovato delle serie difficoltà .. a differenza delle altre versioni (forse ci sono scorciatoie che ancora non conosco!).

Qualcuno ha qualche idea sul possibile problema ?

Grazie a tutti e buona giornata

Posté le
22 RéPONSES - 2 UTILE
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Meilleur utilisateur du mois PL

... elimina l'oggetto contenente "Lascia il tuo commento" ...

.

Lire plus
Posté le de  ‪ KolAsim ‪ ‪
Francesco C.
Francesco C.
User
Auteur

Grazie, come al solito, Kolasim.

Indicazione corretta. Ma la domanda sorge spontanea ... come mai nella versione 13 non aveva questo problema (ancora visibile al link: http://www.labandaderpanino.it/contatti.html) e nella 14 restituisce questo errore ?

Lire plus
Posté le de Francesco C.
Giuseppe Guida
Giuseppe Guida
User

Il menú ora non lo trovi piú in Struttura del Modello ma lo puoi inserire in Header nel Contenuto del Modello tramite il nuovo oggetto Menú e posizionarlo come vuoi alle varie risoluzioni. Per il "vecchio"  menú su scroll della pagina devi invece agire sui valori nella sezione "Sticky Bar". 

Lire plus
Posté le de Giuseppe Guida
 ‪ KolAsim ‪ ‪
 ‪ KolAsim ‪ ‪
Moderator
Meilleur utilisateur du mois PL
Francesco C.
Grazie, come al solito, Kolasim. Indicazione corretta. Ma la domanda sorge spontanea ... come mai nella versione 13 non aveva questo problema (ancora visibile al link: http://www.labandaderpanino.it/contatti.html) e nella 14 restituisce questo errore ?

... infatti hai ragione anche tu; ...ho scoperto dello script che interferiva, ma per la causa scatenante non saprei...

... magari attendi lo STAFF che adesso che si sa potrebbe risalire al problema per risolverlo...

.

ciao

.

Lire plus
Posté le de  ‪ KolAsim ‪ ‪
Francesco C.
Francesco C.
User
Auteur
Giuseppe Guida
Il menú ora non lo trovi piú in Struttura del Modello ma lo puoi inserire in Header nel Contenuto del Modello tramite il nuovo oggetto Menú e posizionarlo come vuoi alle varie risoluzioni. Per il "vecchio"  menú su scroll della pagina devi invece agire sui valori nella sezione "Sticky Bar". 

Grazie Giuseppe per le indicazioni. Come avevo scritto .. con non poche difficoltà .. ma alla fine le ho trovate. Mi metto nei panni di qualche neofita che non ha mai approcciato a Website, potrebbe avere maggiori difficoltà.

@Kolasim ... attendiamo fiduciosi !!!

Lire plus
Posté le de Francesco C.
Incomedia
Riccardo P.
Incomedia

Buongiorno Francesco,

può darsi che lo script inserito interferisca nella nuova versione. Prova ad andare sul sito del fornitore dello script e vedere se c'è una versione più aggiornata a reinserire.

Fammi sapere.

Lire plus
Posté le de Riccardo P.
Francesco C.
Francesco C.
User
Auteur
Riccardo P.
Buongiorno Francesco, può darsi che lo script inserito interferisca nella nuova versione. Prova ad andare sul sito del fornitore dello script e vedere se c'è una versione più aggiornata a reinserire. Fammi sapere.

Ho aggiornato lo script fornito da terze parti, ma il problema rimane.

Lire plus
Posté le de Francesco C.
Incomedia
Riccardo P.
Incomedia

Buongiorno Francesco,

per analizzare meglio l'anomalia mi serve il tuo progetto .iwzip. Puoi caricarlo online usando il servizio: https://wetransfer.com/ e scrivendomi qui il link per il download.

Grazie.

Lire plus
Posté le de Riccardo P.
Francesco C.
Francesco C.
User
Auteur

Se puoi darmi una mail, lo preferisco. 

Lire plus
Posté le de Francesco C.
Claudio D.
Claudio D.
Moderator
Meilleur utilisateur du mois ES

Francesco , nel tuo post di apertura , scegli impostazioni (l'ingranaggio) e metti il post come "privato"

così verrà visto solo dallo STAFF (solo lo STAFF, neppure noi moderatori...) ...

e poi dopo esserti assicurato che sia privato , metti qui il link...

Lire plus
Posté le de Claudio D.
Francesco C.
Francesco C.
User
Auteur

Grazie @claudio

Lire plus
Posté le de Francesco C.
Francesco C.
Francesco C.
User
Auteur

Ecco il link per il download

www.ellebiweb.it/LaBandaderPanino.rar

Lire plus
Posté le de Francesco C.
Incomedia
Riccardo P.
Incomedia

Buongiorno Francesco,

grazie del progetto. Non noto anomalie e nella pagina che hai indicato il menu appare correttamente. Forse era solo un problema di cache del browser.

Lire plus
Posté le de Riccardo P.
Francesco C.
Francesco C.
User
Auteur

Proverò a ricaricarlo nuovamente e ci riaggiorniamo!!

Grazie

Lire plus
Posté le de Francesco C.
Francesco C.
Francesco C.
User
Auteur
Riccardo P.
Buongiorno Francesco, grazie del progetto. Non noto anomalie e nella pagina che hai indicato il menu appare correttamente. Forse era solo un problema di cache del browser.

No Riccardo, ho caricato online il progetto (quello che hai visionato!) e potrai constatare di persona online che il menù "scompare"

http://www.labandaderpanino.it/contatti.html

Per farvi controllare il codice lascerò l'errore online

Lire plus
Posté le de Francesco C.
Incomedia
Riccardo P.
Incomedia

Buongiorno francesco,

si effettivamente in quella pagina il menu scompare. Ti chiedo solo un altro favore, dovresti ricaricare online il progetto .iwzip così da ridarmi il link per il download che quello presente qui non è più disponibile.

Grazie.

Lire plus
Posté le de Riccardo P.
Incomedia
Riccardo P.
Incomedia

Buongiorno Francesco,

in quella pagina ci sono due oggetti html con del codice personalizzato che interferisce. Se li cancelli il menu si vede correttamente. Probabilmente ci sono degli errori all'interno di quegli oggetti.

Lire plus
Posté le de Riccardo P.
Francesco C.
Francesco C.
User
Auteur

Si Riccardo, questo lo avevo già capito. Io, comunque, lo ritengo un bug,  perché nella versione 13 erano presenti gli stessi codici e non c'era nessuna anomalia. 

Lire plus
Posté le de Francesco C.
Incomedia
Riccardo P.
Incomedia

Buongiorno Francesco,

nella versione 14 il css è cambiato e anche i nomi alle classi e id, è possibile che del codice personale che prima andava bene ora interferisca. Dovresti provare a modificarlo e verificare cosa c'è che interferisce

Lire plus
Posté le de Riccardo P.
Francesco C.
Francesco C.
User
Auteur

Grazie Riccardo, ho preferito togliere lo script ... e proverò con i vostri nuovi aggiornamenti se cambia qualcosa.

Riccardo P.
Buongiorno Francesco, nella versione 14 il css è cambiato e anche i nomi alle classi e id, è possibile che del codice personale che prima andava bene ora interferisca. Dovresti provare a modificarlo e verificare cosa c'è che interferisce
Lire plus
Posté le de Francesco C.