WebSite X5Help Center

 
Alfonso P.
Alfonso P.
User

Mal funcionamiento en algunas versiones de PHP  es

Auteur : Alfonso P.
Visité 108, Followers 1, Partagé 0  

Tengo una web realizada con v16 que en la última actualización de contenidos, han dejado de funcionar los enlaces hacia el blog.

He hablado con mi empresa de hosting y su respuesta ha sido la siguiente:

  • Informarle que, el problema reside en que su página web o alguno de los plugins instalados no son compatibles con la versión que tiene activa de PHP en su Hosting, la 7.1.
  • Puede realizar la prueba de modificar dicha versión por la 5.6 y verá que todas las noticias vuelven a ser accesibles sin problema alguno.
  • Recomendamos actualizar el software de esta web y sus plugins, módulos y temas que pueda tener instalados para ver si se soluciona, en caso contrario, puede contactar con el proveedor de este software web o bajar la versión de PHP en su hosting hasta solucionarlo.

He bajado la versión de PHP mi hosting a la 5.6 y la web me ha funcionado bien, pero otras webs me han dejado de funcionar.

El caso es que la primera web, la que no funcionaba hasta bajar la versión de PHP, ha estado funcionando hasta ahora bajo la versión PHP 7.1.

Me parece entender que con la versión 16 de X5 no debería tener este tipo de problema, pero lo tengo.

¿Podría actualizar mi web para que funcionase correctamente con la versión PHP 7.1? Si no fues así, ¿podría tener algún tipo de solución?

Gracias.

Posté le
3 RéPONSES
Carlos Amaral
Carlos Amaral
Moderator
Meilleur utilisateur du mois ESMeilleur utilisateur du mois PT

Hola Alfonso,

El problema es que si usas para todas tus webs el mismo servidor, pero vas actualizando la version de WebSite X5 y no puedes modificar la version de php para cada pagina, si dejas sitios hechos en versiones viejas siempre tendras el problema de las versiones de php.

Lo que puedes hacer (yo lo hago) es que cada vez que sale una actualizacion del programa, abro todos mis proyectos, los vuelvo a guardar para que queden actualizados y los actualizo en el servidor.

Con eso siempre estaran con la ultima tecnologia en cuanto a codigo, y version de php sin problemas.

Saludos colega...

Carlos A.

Lire plus
Posté le de Carlos Amaral
Alfonso P.
Alfonso P.
User
Auteur

Hola de nuevo.

He pasado la web a la versión del X5 PRO 2019 2.4 y tengo el mismo problema.

Pero igualmente, debería funcionar con la versión de PHP 7.1, ¿verdad?. Ha estado funcionando con la 7.1 varios meses.

Actualmente tengo mi hosting con la versión de PHP 7.1 y he puesto código en el archivo .htaccess para que esta web funcione con una versión más antigua .

Te paso una imagen con el mensaje de error. 

Lire plus
Posté le de Alfonso P.
ALEJANDRO VALENTI
ALEJANDRO VALENTI
User

Hola tu problema esta por permisos de escritura en tu servidor. Chequea con ellos los permisos y se te soluciona el problema.

Lire plus
Posté le de ALEJANDRO VALENTI