WebSite X5Help Center

 
Michael P.
Michael P.
User

Does WebSite X5 pro support MySQL 5.5 for the database???  en

Auteur : Michael P.
Visité 148, Followers 1, Partagé 0  

I am putting up a new ecommerce website and have activated the MySQL database with my web hosting service (Hostway.com). When I upload my site from WebSite X5pro I get an error:  "The following tests failed: MySQL Database settings( )."

When I read "What are the minimum requirements for the server?" it says... "Websites created with WebSite X5 are compatible with Windows and Linux servers. Only for some advanced functions, PHP 5.6 and MySQL 5.6 are also required."

Hostway, my service, says they only support MySQL 5.5.39 but support PHP 7. Is the lack of support for MySQL 5.6 causing the error? Hostway says they will not upgrade to 5.6 for me.

Thank you for your help

Posté le
2 RéPONSES - 1 CORRECT
Wsx5.afsoftware.fr  
Wsx5.afsoftware.fr  
User

Yes tongue-out they support more ....

here on my localhost:

And to my provider

If your provider does not offer upgrade, it's probably time to find other one !!! foot-in-mouth

Enjoy !

https://wsx5.afsoftware.fr

Lire plus
Posté le de Wsx5.afsoftware.fr  
Paul M.
Paul M.
Moderator
Meilleur utilisateur du mois EN

Hello Michael,

Unfortunately WebSite X5 is not compatible with MySQL 5.5 or below.

I see you have opened a previous thread along similar lines.  I will close that thread so that you can continue here if necessary, with all relevant information in one place.

Any U.S. based hosting with support for MySQL 5.6 (and PHP 5.6 or above) should be fine for use with WebSite X5.  Sometimes a WebSite X5 project will work straight out of the box when uploaded to such a server, and other times some minor tweaking and configuration is necessary.  However, we can help you with that if you run into any issues. 

Kind regards,

Paul

Search the WebSite X5 Help Center

Lire plus
Posté le de Paul M.