WebSite X5Help Center

 
Michael H.
Michael H.
User

Contact form not working  en

Autore: Michael H.
Visite 257, Followers 1, Condiviso 0  

Hi,

I have created a new website for my friend and when I have created a contact us for (shown below) and attempting to submit a test email it comes back with the below message.

Can you please provide me with some assistance into where I am going wrong?

I am hosting the website on my SYNOLOGY NAS box, PHP7 and PHP7.2 are installed and configured as they should be.

 

Cheers mike

Postato il
20 RISPOSTE - 3 UTILI - 1 CORRETTO
Paul M.
Paul M.
Moderator
Utente del mese EN

Hello Michael,

WebSite X5 Pro includes a built-in online control panel which can help you diagnose the cause of such a problem:

https://help.websitex5.com/en/v2019.2/pro/index.html?imp_pannello_controllo.htm

https://help.websitex5.com/en/v2019.2/pro/index.html?pannello_controllo.htm

Please follow the instructions in the links above, and run the email tests in the Website Test Section of the control panel.

You can of course revert to us once you have done so, should you need further help and assistance.

Kind regards,

Paul

Search the WebSite X5 Help Center

Leggi di più
Postato il da Paul M.
Michael H.
Michael H.
User
Autore

Hi Paul,

I have already tried to access the Admin page on my website and it also comes up with the 500 error page.

Any suggestions?

Cheers

Mike

Leggi di più
Postato il da Michael H.
Paul M.
Paul M.
Moderator
Utente del mese EN

What directory permissions do you currently have set for read and write access on the WebSite X5 folders on your NAS?

Leggi di più
Postato il da Paul M.
Michael H.
Michael H.
User
Autore

its all set to read/write permissions on the NAS folder

Leggi di più
Postato il da Michael H.
Michael H.
Michael H.
User
Autore

Please see permissions below...

Leggi di più
Postato il da Michael H.
Michael H.
Michael H.
User
Autore

Hi Paul,

This is all new to myself, so some step by step guides would be superb. I am learning as i go along and i really appreciate your assistance

Leggi di più
Postato il da Michael H.
Paul M.
Paul M.
Moderator
Utente del mese EN

In WebSite X5 Step 1 Settings > Advanced > Data Management, what do you have entered in the 'Server folder with write access' field?

Leggi di più
Postato il da Paul M.
Michael H.
Michael H.
User
Autore

Please see below...

Leggi di più
Postato il da Michael H.
Paul M.
Paul M.
Moderator
Utente del mese EN

Are you able to execute simple PHP scripts on the NAS at the present moment?  I don't mean WebSite X5 PHP scripts, but scripts of your own, or test scripts (phpinfo for example).

What does the NAS error log say about the 500 error?  It should provide some detail as to why script execution failed.

Leggi di più
Postato il da Paul M.
Michael H.
Michael H.
User
Autore

When you say PHP scripts does this mean like PHPMyAdmin and PHPbb etc? If so yes they all work as normal

Leggi di più
Postato il da Michael H.
Paul M.
Paul M.
Moderator
Utente del mese EN

Can you download the attached file and upload it inside the root directory of your WebSite X5 project on the NAS, so that it is accessible at the following URL:

http://thewhiskandpickle.co.uk/phpinfo.php

Please advise when you have done this.

Leggi di più
Postato il da Paul M.
Michael H.
Michael H.
User
Autore

Hi Paul, 

This has been uploaded to the root of the project as requested.

Getting error 500 when clicking on the link.

Leggi di più
Postato il da Michael H.
Paul M.
Paul M.
Moderator
Utente del mese EN

Unfortunately that means that PHP is not configured correctly on your NAS, Michael.

I notice in your opening post you mentioned PHP7 and also PHP7.2  -  did you install two differing versions on the same NAS?

Leggi di più
Postato il da Paul M.
Paul M.
Paul M.
Moderator
Utente del mese EN

Your link is now working!  What did you just do?  Whatever it was, don't change it!

Leggi di più
Postato il da Paul M.
Paul M.
Paul M.
Moderator
Utente del mese EN

Your online control panel is also now displaying as it should.  You should be OK from here on in, Michael.

Leggi di più
Postato il da Paul M.
Michael H.
Michael H.
User
Autore

Hi Paul,

Right i have managed to work it out..

Basically there was an update to the PHP 7.2 but it never updated the webstation on the NAS. I have now enabled this to the latest firmware and it is now accessible.

Thank you so much for you help on this. 

Sorry for being a novice on this

Cheers

Mike

Leggi di più
Postato il da Michael H.
Paul M.
Paul M.
Moderator
Utente del mese EN

You should now delete the phpinfo file from the server, for security reasons.

Leggi di più
Postato il da Paul M.
Paul M.
Paul M.
Moderator
Utente del mese EN

You're welcome, glad it's sorted.  No need to apologise.  Good luck with your website!

Leggi di più
Postato il da Paul M.
Michael H.
Michael H.
User
Autore

Hi Paul,

Another issue when uploading my database...

Setup...

Any suggestions?

Leggi di più
Postato il da Michael H.