WebSite X5Help Center

 
Michael H.
Michael H.
User

Contact form not working  en

Автор: Michael H.
Просмотрено 221, Подписчики 1, Размещенный 0  

Hi,

I have created a new website for my friend and when I have created a contact us for (shown below) and attempting to submit a test email it comes back with the below message.

Can you please provide me with some assistance into where I am going wrong?

I am hosting the website on my SYNOLOGY NAS box, PHP7 and PHP7.2 are installed and configured as they should be.

 

Cheers mike

Размещено
20 Ответы - 3 Полезно - 1 Корректно
Paul M.
Paul M.
Moderator
Лучший пользователь месяца EN

Hello Michael,

WebSite X5 Pro includes a built-in online control panel which can help you diagnose the cause of such a problem:

https://help.websitex5.com/en/v2019.2/pro/index.html?imp_pannello_controllo.htm

https://help.websitex5.com/en/v2019.2/pro/index.html?pannello_controllo.htm

Please follow the instructions in the links above, and run the email tests in the Website Test Section of the control panel.

You can of course revert to us once you have done so, should you need further help and assistance.

Kind regards,

Paul

Search the WebSite X5 Help Center

Читать больше
Размещено От Paul M.
Michael H.
Michael H.
User
Автор

Hi Paul,

I have already tried to access the Admin page on my website and it also comes up with the 500 error page.

Any suggestions?

Cheers

Mike

Читать больше
Размещено От Michael H.
Paul M.
Paul M.
Moderator
Лучший пользователь месяца EN

What directory permissions do you currently have set for read and write access on the WebSite X5 folders on your NAS?

Читать больше
Размещено От Paul M.
Michael H.
Michael H.
User
Автор

its all set to read/write permissions on the NAS folder

Читать больше
Размещено От Michael H.
Michael H.
Michael H.
User
Автор

Please see permissions below...

Читать больше
Размещено От Michael H.
Michael H.
Michael H.
User
Автор

Hi Paul,

This is all new to myself, so some step by step guides would be superb. I am learning as i go along and i really appreciate your assistance

Читать больше
Размещено От Michael H.
Paul M.
Paul M.
Moderator
Лучший пользователь месяца EN

In WebSite X5 Step 1 Settings > Advanced > Data Management, what do you have entered in the 'Server folder with write access' field?

Читать больше
Размещено От Paul M.
Michael H.
Michael H.
User
Автор

Please see below...

Читать больше
Размещено От Michael H.
Paul M.
Paul M.
Moderator
Лучший пользователь месяца EN

Are you able to execute simple PHP scripts on the NAS at the present moment?  I don't mean WebSite X5 PHP scripts, but scripts of your own, or test scripts (phpinfo for example).

What does the NAS error log say about the 500 error?  It should provide some detail as to why script execution failed.

Читать больше
Размещено От Paul M.
Michael H.
Michael H.
User
Автор

When you say PHP scripts does this mean like PHPMyAdmin and PHPbb etc? If so yes they all work as normal

Читать больше
Размещено От Michael H.
Paul M.
Paul M.
Moderator
Лучший пользователь месяца EN

Can you download the attached file and upload it inside the root directory of your WebSite X5 project on the NAS, so that it is accessible at the following URL:

http://thewhiskandpickle.co.uk/phpinfo.php

Please advise when you have done this.

Читать больше
Размещено От Paul M.
Michael H.
Michael H.
User
Автор

Hi Paul, 

This has been uploaded to the root of the project as requested.

Getting error 500 when clicking on the link.

Читать больше
Размещено От Michael H.
Paul M.
Paul M.
Moderator
Лучший пользователь месяца EN

Unfortunately that means that PHP is not configured correctly on your NAS, Michael.

I notice in your opening post you mentioned PHP7 and also PHP7.2  -  did you install two differing versions on the same NAS?

Читать больше
Размещено От Paul M.
Paul M.
Paul M.
Moderator
Лучший пользователь месяца EN

Your link is now working!  What did you just do?  Whatever it was, don't change it!

Читать больше
Размещено От Paul M.
Paul M.
Paul M.
Moderator
Лучший пользователь месяца EN

Your online control panel is also now displaying as it should.  You should be OK from here on in, Michael.

Читать больше
Размещено От Paul M.
Michael H.
Michael H.
User
Автор

Hi Paul,

Right i have managed to work it out..

Basically there was an update to the PHP 7.2 but it never updated the webstation on the NAS. I have now enabled this to the latest firmware and it is now accessible.

Thank you so much for you help on this. 

Sorry for being a novice on this

Cheers

Mike

Читать больше
Размещено От Michael H.
Paul M.
Paul M.
Moderator
Лучший пользователь месяца EN

You should now delete the phpinfo file from the server, for security reasons.

Читать больше
Размещено От Paul M.
Paul M.
Paul M.
Moderator
Лучший пользователь месяца EN

You're welcome, glad it's sorted.  No need to apologise.  Good luck with your website!

Читать больше
Размещено От Paul M.
Michael H.
Michael H.
User
Автор

Hi Paul,

Another issue when uploading my database...

Setup...

Any suggestions?

Читать больше
Размещено От Michael H.