WebSite X5Help Center

 
Philip P.
Philip P.
User

Update causes admin to malfunction  en

Author: Philip P.
Visited 467, Followers 1, Shared 0  

The new update wich requires php 5.6 causes new uploads to not show the shopping cart in the admin area. Everything is workig but I cannot access invoices to process, the dashboard is missing.

Please provide a fix.

I have updated the hosting to php 5.6.33 deleted the site and reinstalled. The same problem exists.

My prior sites installed with php 5.4 continue to function normally so i will be unable to update until this is sorted, and may have to roll back to sort out unless you provide a fix. The dashboard area is missing altogether from the admin area.

cheers

Posted on the
12 ANSWERS - 1 CORRECT
Andre E
Andre E
Moderator

Is your browser up to date?

Try a different browser just for test.

Read more
Posted on the from Andre E
Philip P.
Philip P.
User
Author

tried firefox, and IE its the update as I have 4 other sites not updated withthe update on php 5.4 and they all work... it lacks the shopping cart.. i will add analytics and see if that tweaks anything, but as is the shopping cart is missing, attache dis what it shoul dlook like...

Read more
Posted on the from Philip P.
Philip P.
Philip P.
User
Author

I've added the analytics, picture attached. What's missing is the shopping cart management.

I've refreshed the shopping cart in the program by just savin git, I'll try adding an item to see if it updates, but currently the shpping cart works in the site but I have no means of processing invoices in th eadmin due to its absence...

Read more
Posted on the from Philip P.
Philip P.
Philip P.
User
Author

No I've added a new product and it is not updating the admin area.

So this has only happened since I updated the program, I then made a site change and updated then updated the php, deleted the site and reinstalled completely. 

It does not reinstall with the shopping car tin admin...

A Fix please... cheers

Read more
Posted on the from Philip P.
Andre E
Andre E
Moderator

Strange, i did a full upload of my test site in 17.06, no problems with the admin panel.

PHP version is currently 7.2

I can go down to php 5.5 , tested admin panel with 5.5, still works.

V17 should run on PHP7

Do you have a shop on the other sites? Do they run with the same provider?

Read more
Posted on the from Andre E
Philip P.
Philip P.
User
Author

Yes all sites run off the same shared hosting provider.  They all work but this new upload does not have the shopping cart in the admin panel. 

Read more
Posted on the from Philip P.
Philip P.
Philip P.
User
Author

I will try an update on a trial site I have already as all my other sites are working. If they work I will assume the project is corrupted somehow and have to re-create it.

For information it has also demonstrated the quirk of coming up with a server error when login in, but that is due to the fact that it logs in to the admin not in the subsite folder admin but in the hosting site domain folder but does not process the orders, so I'm assuming it is somehow got some information somewhere corrupting its processes.... currently it comes up with a server error but is login in the main host admin on the adminuser provided for the subsite...

when updating the trial site, I simply added a product, I wrote over everything and it workd just fine, it is only this site at the moment posing the issue so I am assuming corruption somehow... Let me try on eof the backups maybe and see if I can save myself a re-creation.....

Read more
Posted on the from Philip P.
Andre E
Andre E
Moderator

Else try to export the project, import the exported project, clear your webserver of all files, then do a full upload.

fresher then that is only possible if you start from scratch. LOL.
Hop this helps!

Read more
Posted on the from Andre E
Philip P.
Philip P.
User
Author

Not working... I tried a completely new site and just created one product and it didnt show on the admin area...

i also exported to disk to no avail...

Read more
Posted on the from Philip P.
Philip P.
Philip P.
User
Author

I'm going to revert to php 5.4 reinstall version 16 after uninstalling and see if it resolves...

Read more
Posted on the from Philip P.
Andre E
Andre E
Moderator

Can you send me this test project? i will test it with my provider.

just to be sure that I follow the correct steps, if I get your project,

I upload it,

goto the website adress  (that has been set  correctly in step 1) check this !!!!

put /admin behend the the website adres

login,

and then there will be no shopping  feature?

THX

Read more
Posted on the from Andre E
Philip P.
Philip P.
User
Author

yes, but I seem to have resolved it. I will revisit another post if I experience more issues...

I kept getting admin server errors and it logging in to the main domain admin with the user. Not sure why.

All my other sites work, I however noticed this particular project was not sending to a database but dtata by email, so I amended that and shopping cart shows up, logical really. But it didnt explain the admin error, however for now I have had a reinstall, redone the site etc, currently it seems ok so I may venture to version 17 again as i think th elack of shopping cart was simply due to not sending to database, that usually flags up as an issue in the programme  mind but didnt... likely a setup configuration issue...

thanks for the input..

Read more
Posted on the from Philip P.