WebSite X5Help Center

 
Nikolay Z.
Nikolay Z.
User

Added fonts still disappear - and frequently  en

Author: Nikolay Z.
Visited 408, Followers 2, Shared 0  

Added fonts disappear all the time. In earlier versions, this occurred after an incorrect shutdown of the program. And in V17 this happens nearly every day, no matter how the program worked.
 I launch X5 - and YES, there are no fonts again. To add them every day has become a routine.

Why can't you fix it once and forever?

Posted on the
7 ANSWERS
Esahc ..
Esahc ..
Moderator

Nikolay, the fonts are now linked to a project and not WX5, so any new project will not have the fonts embedded by default. How are you adding the fonts? Google fonts (recommended) or web fonts.

Is this what is happening or are you opening existing projects and finding the fonts have disappeared?

Read more
Posted on the from Esahc ..
Nikolay Z.
Nikolay Z.
User
Author

When I find the fonts have disappeared, all text formatted with added fonts becomes looking like  Times New Roman.

Then I select a text, choose "Add fonts" from the menu and add:  one Google font - Oswald and one font from my hard drive - Bebas neue bold. Then, after site preview  the fonts become correct on all the pages.

This is what I do a few times a week.

Read more
Posted on the from Nikolay Z.
Esahc ..
Esahc ..
Moderator

How odd.

When the fonts are successfully installed, could you go to step 5 and export project to create an iwzip, then once created, restart WX5 and import the project (this will not overwrite existing project).

Work on this new project and let us know if the fonts become stable?

Read more
Posted on the from Esahc ..
Nikolay Z.
Nikolay Z.
User
Author

I do it usually - exporting project to the cloud folder to work at work and at home.

May be the matter is that it is very old projec? I created it in 2010 ±.

Now it has about 200 pages, so I can not re-write it from scratch in v17.

Read more
Posted on the from Nikolay Z.
Esahc ..
Esahc ..
Moderator

You are not working off the cloud or across a network are you?

I have experienced instability and strange behaviour even just having one drive synchronising a folder

 I have found it necessary to work local and then copy the iwzip to OneDrive.

Read more
Posted on the from Esahc ..
Nikolay Z.
Nikolay Z.
User
Author

I began working local - the same problem. Nearly every day the added fonts fisappear. 

Read more
Posted on the from Nikolay Z.
Esahc ..
Esahc ..
Moderator

Nikolay - nearly every day?

Can I confirm you are closing the project on your PC and then reopening it on the same PC the next day?

Or does this isue only occur when you open the project from an iwzip, usb or cloud storage?

Read more
Posted on the from Esahc ..