WebSite X5Help Center

 
Peter R.
Peter R.
User

New user, many problems. Stock levels and language  en

Author: Peter R.
Visited 192, Followers 2, Shared 0  

Several problams, these are the main two:

1.  Shop stock availability.  I have to upload the web pages via SSH and not FTP, so I save to local disk and upload to the web server via WinSCP.  All 4 databases (shop, users, blog and statistics) are up and running as is the writable folder (all "PASS" in the test website page).
The server is running MariaDB; the "shop.shopproducts" table is shown as "Empty set", yet I have 3 products set up in X5 (after upload to the web server), all with "Quantity to add" set to positive values above the "Warn" levels.
The cart/x5cart.js file on the server includes the 3 items with the 'offlineAvailableItems' populated with the values to add from X5.
The shop page will not allow stock to be placed into the basket - "No stock" message.
The admin page is not displaying any non-stock items  (database table empty).

For some reason, the stock is not getting from the web site to the database; yes, I could manually add it to the database, field-by-field, but I have over 1000 items :(

2.  Language.  I administer in English for a Slovenian audience.  Setting the site language to "SI" changes the admin page to Slovene (which I don't understand), but leaves the shopping basket columns titled "Description", "Price", "VAT" and "Quantity".  The Slovene users get English and the English administrator gets Slovene :(

I really hope someone can urgently assist with these major problems.

Many thanks in advance.

Peter

Posted on the
18 ANSWERS - 1 USEFUL
Paul M.
Paul M.
Moderator
Best User of the month EN

Hello Peter,

Welcome to WebSite X5...  a few thoughts...

It's possible to upload to the server via the SSH protocol using the built-in FTP client in WebSite X5...  please see the screenshot below:

If not using the built-in facility then great care must be taken when exporting the project to the server.  Check in particular the WebSite Address (URL) setting in Step 5 Export to disk, as shown in this next screenshot:

This should point to the root directory of your WebSite X5 project on the web.

There have been one or two issues with MariaDB in the past.  It's not vanilla MySQL, and WebSite X5 is only guaranteed to work correctly when using MySQL.  However, if you search the forum you might find various useful pointers to get everything working satisfactorily using MariaDB.  These posts in particular might be helpful:

https://helpcenter.websitex5.com/en/post/183521

https://helpcenter.websitex5.com/en/post/213483

As regards the language issue, can you clarify further what you have done so far?  Do you mean that you have used the Language Content Management screen to set your language preferences?

https://help.websitex5.com/en/v2019.2/pro/index.html?gestione_lingue.htm

Kind regards,

Paul

Search the WebSite X5 Help Center (multilingual)

Read more
Posted on the from Paul M.
Aleksej H.
Aleksej H.
Moderator
Best User of the month RU

Hello.
1) For the experiment, temporarily disable your antivirus and firewall.Try resynchronizing data from the database.Sometimes on the hosting block requests from WebSite X5 to the database.Check that this does not happen.

Read more
Posted on the from Aleksej H.
Peter R.
Peter R.
User
Author

Guys

Thanks for the quick response.

I currently do not have an FTP server on my web server, hence why I have to use a different product for uploading (WinSCP).

I have the website address within "Export to disk" set to the website "http://www.rumble.si"  I presume this is how it should be?

"http://www.rumble.si" is my test site which is points to my local web server on the local DNS server. (Long story short - been waiting for optical for 12 years now, so my old & outdated site is currently hosted remotely.  Piping now installed for optical, so I am preparing to bring the web site "home".)

I really don't see MariaDB as being the source of the problem here; all the other databases are being correctly populated.  I will check the posts you linked, thank you.

On the 1.Settings/Advanced/Shopping Cart/Product List page, when I press the [Update] button, I get the message "Download successfully completed" (almost instant).  I presume this is connecting to the web site and initiating the DB update?  If this is the case, is there any way that this could be manually initiated?

This is the X5 page after an update:

(Not sure if the inage was included)

With regard to the language:

1 Settings/General/Content Language.

When set to SI-Slovenian, the shop headers are in English and admin is in Slovene :(  There may be other text elsewhere which is also not translated.  It would also be "nice" if the column header "VAT" could be changed to "VAT (included)" or "Price" to "Price (including VAT)".  As it stands, it reads as though VAT will be in addition to the Price.

Actually, it would be so much better if you allow the user to define the column headings.  And even the columns which appear (e.g. "Nett", "VAT", "Gross").  The tools are already in the program to allow this.

@Aleksej  Sorry, I don't fully understand your suggestion. 

FWIW, I have a CentOS 7 VM hosting my web server.  The MariaDB only allows access to locahost users.

If X5 is attempting to access the web server database directly from my PC, that is not going to happen, and in any event a relevant failure message whould be displayed (or at least I would hope that is the case).

Question: the [Update] message "Download successfully completed" - what does that actually mean?  And why is X5 downloading?  And where from?  (I really am trying to understand this)

Thanks again.

Peter

Read more
Posted on the from Peter R.
Peter R.
Peter R.
User
Author

I have now opened up user access to remote users onthe local network:

Read more
Posted on the from Peter R.
Peter R.
Peter R.
User
Author

Sorry, I can't figure out how to insert a small image into a post :(

Read more
Posted on the from Peter R.
Peter R.
Peter R.
User
Author

Just one more snippet of information:

I can telnet to the web server database on port 3306 from the PC which hosts X5, and receive a response from MariaDBE

( :) )

Peter

Read more
Posted on the from Peter R.
Aleksej H.
Aleksej H.
Moderator
Best User of the month RU

"@Aleksej Sorry, I don't fully understand your suggestion"- When you try to synchronize stock availability, what message do you receive?

Read more
Posted on the from Aleksej H.
Peter R.
Peter R.
User
Author
Aleksej H.
"@Aleksej Sorry, I don't fully understand your suggestion"- When you try to synchronize stock availability, what message do you receive?

Read more
Posted on the from Peter R.
Peter R.
Peter R.
User
Author

And this is the result:

It creates the table and columns but not the entries.

Peter

Read more
Posted on the from Peter R.
Peter R.
Peter R.
User
Author

If I DROP the table and press [Update]:

The table and columns are re-created, but not the product rows.

Peter

Read more
Posted on the from Peter R.
Peter R.
Peter R.
User
Author

OK, getting to understand this more now :)

X5 simply connects via HTTP and GETs cart/x5cart.php which should then update the products file.

In the above image, 192.168.1.11 is the web server and 169 is my PC.

So it looks like I will have to figure out what's going wrong in x5cart :(

In theory, it should be possible to point the browser at that file to get an update, but that didn't work for me yesterday.

Peter

Read more
Posted on the from Peter R.
Aleksej H.
Aleksej H.
Moderator
Best User of the month RU

Perhaps you should contact the developers of the program?Should I send them a request?

P.S. Have you tried to upload the site to another hosting with MySQL?

Read more
Posted on the from Aleksej H.
Peter R.
Peter R.
User
Author

Aleksej

I have now found that there is a different table - "dynamicproducts" that is not being created and therefore cannot be updated.  I am currently back-tracing to find the initiating function.

I think I should be able to modify the php code to do what is necessary :crossed-fingers:

I also tried to FTP the site to my FTP server and then copy it to my web server.  Same result.

As for MySQL, that will not be installed on my web server, so there is little point in testing it.

I really do appreciate your input in this, thank you :)

Peter

Humm.  Thoughts.  Maybe if I create the table manually, it may then be able to update?  Worth a try.

Read more
Posted on the from Peter R.
Incomedia
Stefano G.
Incomedia

Hi Peter

I'm not sure I fully understand all that is not working right with the stock functionality for you at the moment, but I believe I might able to at least guide you in the right direction for it.

First of all, don't create the tables manually. The software will do this for you. Creating them manually might lead to issues when the software actually tries to write into them.

Secondly, if I understood correctly you're exporting your files locally and then moving them to a server. This will not work with stocks quantities. A logic is used to update the quantities for the stock when you upload your website online through the software and through the software only. Failing to do so will result in no actual stock being added:

Finally, the Update button works in the following way. If you currently have a stock quantity online and you want to sync the quantities with your software, you use the Update button. It doesn't work the other way around. It is used so that inside the software, the same quantities you have online are downloaded into the software as well. This does not update the online quantities

I hope I've been helpful

Stefano

Read more
Posted on the from Stefano G.
Peter R.
Peter R.
User
Author

Hi Stefano

Thank you for your reply.

I have now managed to "Upload the Website to Internet" and the stock update is now working, thank you :)

My query with regard to the language; I wonder if it would be possible to make the shopping cart headings user-definable?  That way I can use the appropriate terms in the language I choose.

Many thanks again.

Peter

Read more
Posted on the from Peter R.
Peter R.
Peter R.
User
Author

Stefano

Just one other thought:  The order number contains letters (example: ***19).  Would it be possible to have this as numeric only so that it can be used as a reference for bank payment?  And can that order number be used as a variable in text (for example, in the payment details email)?

Thanks

Peter

Read more
Posted on the from Peter R.
Peter R.
Peter R.
User
Author

There's also a problem with admin/shopping cart/charts.  The Y axis starts from 1, which doesn't display items where only one has been sold (see the right-hand column):

Peter

Read more
Posted on the from Peter R.
Incomedia
Stefano G.
Incomedia

Hi Peter

I'll try to address these issues one by one

1_ The language: This issue looks indeed weird. I'd like to ask you to verify something for me first. Go to Step 1 as indicated in my screenshot. You should be able to manually modify whatever text you wish inside the standard generated file for whatever language you wish. Take a look there:

2_ I have to confirm that for the moment, the way the order number is generated cannot be customized. It will be automatically generated according to the software's logic with no possibility of editing. Several idea topics have been opened on this but there's still no news on this particular matter

3_ If I'm not mistaken, only the items which have been sold at least once should appear there and that is why the bottom of the Y axis is marked as 1. Please verify this and let me know if this seems to be incorrect for you

Thank you

Stefano

Read more
Posted on the from Stefano G.