WebSite X5Help Center

 
rob G.
rob G.
User

X5 on Windows arm  en

Author: rob G.
Visited 138, Followers 1, Shared 0  

Hello everybody,

X5 is currently not working on Windows ARM.

Would it be possibile to make X5 also compatible for Windows ARM, that would help a lot.

Thanks,

Rob

Posted on the
7 ANSWERS - 2 USEFUL
Jiper 85
Jiper 85
Moderator
Best User of the month FR

Hi Rob,

For all purposes...

We had a discussion on this topic on the French forum: https://helpcenter.websitex5.com/en/post/236244
This is Incomedia's response:

I must admit that I really cannot understand how the v2019 could be working with an ARM processor. It could be that whatever x86 emulator you're using supports older Visual Studio C++ libraries that v2019 uses and that v2020 is incompatible with but I must confirm that WebSite X5 is in no way compatible with ARM technology and requires an x86 processor and compatible OS to run

Unfortunately, since your setup seems very peculiar and in general cannot support the environment the software is designed for, I am afraid I cannot be of help with this.

If possible, I would suggest using an OS that natively supports x86 architecture to make sure that the software works as intended

Thank you for your understanding

Stefano

Good luck,

J.P.

Read more
Posted on the from Jiper 85
rob G.
rob G.
User
Author

Hello all,

Im happy to report that X5 Evo 2020.3.7 is seamlessly working on a Macbook Pro with an M1 chip running MacOs Big Sur version 11.1 and enabled with Crossover Version 20.0.2 (20.0.2.33166) by Codeweavers. 

Thanks,

Rob

Read more
Posted on the from rob G.
Adrian B.
Adrian B.
User

Parallels is also working on the M1 issue, but only have windows working with a special test release that is unsupported.

I will have to check out crossover

Read more
Posted on the from Adrian B.
Adrian B.
Adrian B.
User

I could not finish the install of X5 Pro 2020.3.7 on M1 with crossover - kept stopping on net framework installation.... :(

Read more
Posted on the from Adrian B.
rob G.
rob G.
User
Author

Hello Adrian,

You have to install the ".Net framework 4.8" first within the Crossover bottle (choosed New Windows 10 bottle).

That package is default listed within the available apps within Crossover.

After you installed Net framework 4.8 within that specific bottle, you can install X5 within the same bottle.

Thanks,

Rob

Read more
Posted on the from rob G.
rob G.
rob G.
User
Author

better screenshot included

Read more
Posted on the from rob G.
rob G.
rob G.
User
Author

Within the recently released new build of Windows Arm on M1 (21296.1000), X5 is working out of the box.

Read more
Posted on the from rob G.