WebSite X5Help Center

 
Lauren W.
Lauren W.
User

Google tags not working  en

Author: Lauren W.
Visited 1093, Followers 1, Shared 0  

website www.laurenrathbone.com

I am having issues with tags (I think) I put in a whole list of short tags, long tags, page titles, description, and basically my SEO says "98%"
 

It has been about a month now and these SEO websites I go to are not showing any of my tags showing up (only one tag showed up but not sure from what page). I have used the google search console and other free SEO sites. My name does not even show up on the map for my location photography  (that is crazy because I have google business filled out. I understand this may because I am new to building up my SEO and my rankings were low. but I was wondering if there was a way to check and see why (or to check and make sure I did it right)

I have updated sitemap.xml also.  Any other ideas? 

Posted on the
2 ANSWERS - 1 USEFUL
Ro Partner
Ro Partner
User

you can remove <metaname="keywords"... (they have no value).

Improve <metaname="description", Page titles, internal links, Alt tag, add valuable content...

Read more
Posted on the from Ro Partner
Andre E
Andre E
Moderator

Hello Lauren,


It looks like you have filled in all possible items, the better you fill it in the better your SEO will be.

In the guide there is a lot of info, if you have not read this yet check it out, else this might be helpfull for other readers.

https://guide.websitex5.com/en/support/search?term=seo

But for google or other search engines to reflect your information it can take a while, more than a month is not very strange, but everytime you had a visit from search bots, they will improve and also the info on search engines will improve.

Sometime's it just takes patience.....refresh data regurly.

If you have some sites then we might be able to give more info, but as it is like you say and all is filled in correct then it will work.

Read more
Posted on the from Andre E