WebSite X5Help Center

 
Graham O.
Graham O.
User

Contact Form  en

Author: Graham O.
Visited 500, Followers 1, Shared 0  

Just uploaded an updated web site to replace the existing one and after checking the site there is an issue  with the contact form.  Never had one before and I thought it was set up correctly, but when testing it, the enquiry message is not sent to the club email address nor the auto reply to the sender.

I've tried to see if I can find what could be behind this and I noted that there is an issue with our host which is 123.  However I was not able to see if there was a work-around or if we just cannot use the contact form - or if I've messed up the settings.

I attach a screenshot of our contact form send object.

Posted on the
5 ANSWERS - 1 USEFUL - 1 CORRECT
Andre E
Andre E
Moderator

Hello Graham,

You can test in your admin panel if you have setup correct script and if mail works.

There several topics here with more info, i will add one later on.

Keep in mind that some hostings (more and more lately) block the use of other mail adresses then there own due to security risks. so try a mail adres from 123 itself or try the admin panel and test there and see what works best.

see here for instance:

https://helpcenter.websitex5.com/en/post/246445

Read more
Posted on the from Andre E
Graham O.
Graham O.
User
Author

Thanks for the prompt reply Andre.  The article you linked to gave me the answer.

"Important is that the php version at your host is at 8.0 or higher, please check in your admin panel from your hosting company."

I checked our hosting account and there is an icon to change the php version,but when I click on it, the page that loads is blank. Don't know if this is a glitch or if our package does not supprot v8.0. 

In the support pages I saw some screenshots of how to change the php in the contol panel, but v7 was the highest version shown.  Again, I don't know if this is an outdated support page, but the info was on 2 different pages.

so it seems that v8.0 is not available and the higest seems to be v7.3.  I think next step has to be an enquiry to 123 support.

Read more
Posted on the from Graham O.
Andre E
Andre E
Moderator

Hello Graham,

use mail from 123, as mentioned above try that first!

Read more
Posted on the from Andre E
Graham O.
Graham O.
User
Author

Turns out that our hosting package does not have an domain email as we did nor ues their site builder.  we can get one at what we see as an expensive add-on, so we are ditching the contact form and reverting to the e-mail link that has served us well with the old site.

Read more
Posted on the from Graham O.