WebSite X5Help Center

 
Maitrot G.
Maitrot G.
User

V17 - Pages protégées inaccessibles erreur... erreur 500  fr

Auteur : Maitrot G.
Visité 165, Followers 2, Partagé 0  

Bonjour

Après transfert de l'un de mes sites de V15 PRO à V17 PRO le dispositif "page protégée" qui, sur les versions précédentes fonctionnait parfaitement est en "Cette page ne fonctionne pas - Impossible de traiter cette demande via www.capeb-aube.net à l'heure actuelle. HTTP ERROR 500.

Merci de vos observations et suggestions

Très cordialement

Gérard Maitrot

Posté le
9 RéPONSES - 1 UTILES - 1 CORRECT
Jiper 85
Jiper 85
Moderator
Meilleur utilisateur du mois FR

Salut Gérard,

J'ai déplacé ta demande pour un meilleur suivi individuel, d'autant que sur l'autre page le demandeur n'a pas réagi depuis le 30 novembre dernier...

Je n'ai que des pages blanches sur ton site. Pas de message d'erreur... La page partenaires-1.php (identique partout) est le module de connexion zone privée ? 

Tu as vérifié le PHP actuel sur ton serveur après exportation de ta conversion ? Quelle version ? Pas de disparition de fichier .htacess ? (tu avais eu le souci avec la V12).

@Suivre,

J.P.

Lire plus
Posté le de Jiper 85
Maitrot G.
Maitrot G.
User
Auteur

Salut Jiper 85

Tout d’abord, merci de t’intéresser à mon problème.

Une précision : J’utilise Website X5 depuis sa version 10 et peut-être même avant…

C’est pourtant la première fois que je rencontre ce problème après transfert d’un contenu V13 pro, qui fonctionnait parfaitement, à la version 17 pro qui fonctionne nettement moins bien !

Les désordres de www.capeb-aube.net : Impossibilité d’accéder à /admin + page protégée inaccessible.

Afin de te permettre de parfaire ton analyse j’ai réintégré » bêtement » dans mon hébergement mutualisé ONLINE les deux fichiers que j’utilise habituellement, sans d’ailleurs en connaître l’utilité et sans en déchiffrer le contenu.

J’en ai fait la copie ci-dessous.

.htaccess

# http://documentation.online.net/fr/hebergement-mutualise/gestion-web/configuration-php?s[]=php5#activer_php5

# Pour faire parser les fichiers .php par PHP5

AddType application/x-httpd-php5 .php

RewriteEngine On

RewriteCond %{HTTP:HTTPS} !on

RewriteRule (.*) https://%{SERVER_NAME}/$1 [QSA,L,R=301]

Phpinfo.php

H&eacute;bergement <a href="http://www.online.net/">Online</a><br />

<a href="http://documentation.online.net/fr/hebergement-mutualise/gestion-web/configuration-php?s[]=php5

">Lien</a> vers la documentation.<br />

<br /><br />

<?phpinfo();?>

Autre précision importante /

J’ai créé en quelques clics un NOUVEAU site basique directement depuis la version 17 PRO (une page d’accueil avec lien vers une page protégée).

Et là surprise, tout fonctionne : /admin OK + Accès page protégée OK.

Il semble donc que nous sommes en présence d’un bug de transfert d’une version V13 PRO ou antérieure à la version 17 PRO.

Qu’en penses-tu, sachant qu’un autre site client, auquel je ne m’étais pas encore intéressé en détail, présente les mêmes désordres après transfert V13 PRO vers V17 PRO avec de plus impossibilité d’envoyer le contenu d’un formulaire de contact…

Merci de tes observations et recommandations.

Toujours aussi cordialement

Gérard Maitrot

Lire plus
Posté le de Maitrot G.
Jiper 85
Jiper 85
Moderator
Meilleur utilisateur du mois FR

Hello Gérard,

Il s'agit peut-être d'un problème de PHP. On lit sur le lien que tu indiques :

https://documentation.online.net/fr/web/web-hosting/web-management/configure-php?s[]=php5#activer_php5

Problèmes connus

Erreurs 500

Il peut y avoir plusieurs causes, en voici certaines:

Erreur dans le fichier .htaccess

Vous pouvez obtenir cette erreur à cause de votre fichier .htaccess pour les raisons, non exhaustives, suivantes :

  • présence d'une directive non autorisée
  • présence d'une erreur de syntaxe
  • fichier .htaccess transféré en binaire, en lieu et place du transfert texte
  • absence d'une ligne vide finale

Vous pouvez stopper l'erreur 500 en renommant votre fichier .htaccess en htaccessX.txt

Vous devrez ensuite créer un fichier .htaccess vide et y rajouter une à une les directives jusqu'à trouver la responsable de l'erreur 500.

Je signale ton souci au support car je ne maîtrise pas les codes pour savoir ce qui pourrait causer ce dysfonctionnement. Tu pourrais aussi contacter le support de ton hébergeur ? 

Attendre le passage d'un technicien.

J.P.

Lire plus
Posté le de Jiper 85
Maitrot G.
Maitrot G.
User
Auteur

Rebonjour Jiper 85

Encore merci pour ces nouvelles infos

S'agissant du support de mon hébergeur, ces derniers considèrent que ce genre de diagnostic n'entre-pas dans leurs attributions... Sympa !

Je teste mon fichier .htaccess sur la base de tes recommandations.

Cordialement

GGMA

Lire plus
Posté le de Maitrot G.
Maitrot G.
Maitrot G.
User
Auteur

Bonjour Jiper 85

Je reviens sur mon problème après avoir testé plusieurs possibilité quand à ses origines.

J'ai ainsi créé un site basique avec V17 PRO qui fonctionne parfaitement.

Manifestement mes hébergements ne sont donc pas à l'origine de ces bugs.

Selon mon modeste diagnostic il s'agit d'un problème de tranfert des versions V14 PRO et V15 PRO vers les versions V16 PRO et maintenant V17 PRO.

Bug particulièrement pénalisant si l'on considère qu'il neutralise purement et simplement le /admin, le dispositif "pages protégées" et l'envoi de formulaires de contact. Autant dire que les sites concernés sont inutilisables !

J'ai cru comprendre que tu étais en mesure de faire remonter des infos aux développeurs Websire X5.

Dans l'affirmative, merci d'être le porteur de ma réclamation

Très cordialement

Gérard Maitrot

Lire plus
Posté le de Maitrot G.
Jiper 85
Jiper 85
Moderator
Meilleur utilisateur du mois FR

Salut Gérard,

J'ai signalé ton souci le 9 janvier dernier... Reste plus qu'à attendre le passage d'un technicien Incomedia. 

@+, 

J.P.

Lire plus
Posté le de Jiper 85
Incomedia
Stefano G.
Incomedia

Hi Maitrot.

What version of PHP is currently installed on your server?

Since v17, at least PHP version 5.6 or higher is required on your hosting in order for all these functionalities you mentioned to work correctly.

Try checking that first with your hosting, and ask them to upgrade the version for you

Then, let me know if the situation improved

Keep me posted on this

Thank you

Stefano

GOOGLE TRANSLATE ---

Salut Maitrot.

Quelle version de PHP est actuellement installée sur votre serveur?

Depuis la v17, au moins la version 5.6 ou supérieure de PHP est requise sur votre hébergement pour que toutes les fonctionnalités mentionnées précédemment fonctionnent correctement.

Essayez d'abord de vérifier cela avec votre hébergement et demandez-leur de mettre à jour la version pour vous.

Ensuite, laissez-moi savoir si la situation s'est améliorée

Tenez-moi au courant

Je vous remercie

Stefano

Lire plus
Posté le de Stefano G.
Maitrot G.
Maitrot G.
User
Auteur

Bonjour Jiper 85, bonjour Stefano,

Problème(s) résolu(s) !!!

Il s'agissait bien, non pas d'un problème de logiciel V17 (milles excuses aux développeurs et tout autant à Jiper 85) mais du PHP de certains de mes hébergements. Dès que l'on passe en PHP 7.2, tout rentre dans l'ordre pour les sites développés jusqu'à la version 14 et transférés ensuite sur V 15, V16 et/ou V17.

Merci à tout ceux qui ont bien voulu me conseiller.

Très cordialement

Gérard Maitrot

Lire plus
Posté le de Maitrot G.
Jiper 85
Jiper 85
Moderator
Meilleur utilisateur du mois FR

Hello Gérard,

En voilà une bonne nouvelle ! Merci de clôturer la page à ton prochain passage en cliquand "Correct" sur la réponse de Stefano. Cela nous évite d'y revenir quand on fait un balayage des pages et peut être utile à un utilisateur confronté au même souci.

Bonne continuation,

J.P.

Lire plus
Posté le de Jiper 85