WebSite X5Help Center

 
Mike G.
Mike G.
User

Menu Object multiple columns not working  en

Auteur : Mike G.
Visité 609, Followers 2, Partagé 0  

I am developing a new website in my test area and have used a menu object on row 1.

I have 19 pages in a level on the site for classes and I want to have 2 columns.

I have defined multiple columns on this page for the level menu with a maximum of 10 but it does not go into 2 columns, it just makes the background wider.

http://www.sunrise-arts.co.uk/i-motion/ab-attack-rotherham.html

On the other class pages I have left the menu object as 1 column to show the difference.

I have set row 1 as sticky

<style>
#imPageRow_1 {position: -webkit-sticky; position:fixed; left:auto; z-index: 40;}
</style>

but removing this makes no difference so it is not that.

Help would be appreciated. thanks. Mike.

Posté le
15 RéPONSES - 1 UTILES
Aleksej H.
Aleksej H.
Moderator

Hello.I don’t remember when the settings appeared, but in new versions of the program you can enable the display of menu items in several columns and specify the number of menu items in one column.

Lire plus
Posté le de Aleksej H.
Mike G.
Mike G.
User
Auteur

Yes that is what I have done, on the level menu I specified 'Arrange in multiple columns' with 'Max Items per column' to 10 but it doesn't work. It just makes the background wider and still shows 19 items in the column.

Lire plus
Posté le de Mike G.
Aleksej H.
Aleksej H.
Moderator

Try unloading the site again (completely).

If you have added any styles or scripts to the code, then try to remove them first.

Lire plus
Posté le de Aleksej H.
Mike G.
Mike G.
User
Auteur

Tried that, still only 1 column.

Started a new test site in basic layout, no extra code or scripts, put menu object at top of dummy class pages, specified multiple columns max 10 still doesn't work.

http://www.sunrise-arts.co.uk/testindex/page-5.html

Config image of level menu attached

Lire plus
Posté le de Mike G.
Aleksej H.
Aleksej H.
Moderator

Is everything OK in the preview? The problem is only on the hosting?

Lire plus
Posté le de Aleksej H.
Mike G.
Mike G.
User
Auteur

No it is wrong in the preview.

Lire plus
Posté le de Mike G.
Aleksej H.
Aleksej H.
Moderator

Unfortunately, I do not know how to help you.Perhaps the staff of Incomedia will be able to.But since the 16th version is no longer supported, this may also be a problem.

Lire plus
Posté le de Aleksej H.
Esahc ..
Esahc ..
Moderator

Mike, I created a project in v16 and a level with 19 pages, the menu functions exactly as it should in the header or in row 1`(meaning I cannot recreate your problem).

Have you tried simply deleting the menu object on one of the pages and creating a new one? The existing menu object that you probably copied to every page may have a corruption?

PS it appears you are entitled to move to v2019, why the reluctance?

Lire plus
Posté le de Esahc ..
Mike G.
Mike G.
User
Auteur

Hi, I tried in the latest version and got the same result (not working) I will do some more experiments. Maybe it is something to do with me using a menu in the header and a menu of a sub level on row 1 of the pages.

The reason I stay with V16 for my live sites is because the latest version does not display properly on an Ipad 2 or Mac with older versions of Safari. I know that those browsers are old, but many of my customers have them. Google webmaster tools also pick up the 'managed sites' with an incorrect looking picture of the homepage.

Lire plus
Posté le de Mike G.
Esahc ..
Esahc ..
Moderator

Mike - I too placed a menu on row 1 and it works fine.

Have you tried simply deleting the existing header menu and recreating it?

OR

Could it be related to you apparently using 3rd party code to fix the header and menu to the top of the page and so not require the sticky menu? Is this a template perhaps from X5TUTS?

Lire plus
Posté le de Esahc ..
Mike G.
Mike G.
User
Auteur

Hi, thanks to everyone for trying to help.

It is not related to code because I stripped that out and also I did a new test site with no added code. My template for my original site is just built using x5 layout not a 3rd party template.

I have done more testing and found this. If I put the top level menu at the top of a page it works like on this page:

http://www.sunrise-arts.co.uk/testindex/page-30.html

If the menu I add to the top of a page is a different level (in this case the level Rotherham ) with pages below the level 'classes' it does not work when I specify multiple columns. I am using v16 but also tried the latest version and still does not work.

http://www.sunrise-arts.co.uk/testindex/rotherham.html

Lire plus
Posté le de Mike G.
Esahc ..
Esahc ..
Moderator

Mike, you are quite right. The maximum enties per column works for the first set of pages below the menu, but not for pages in a 2nd level, even though the controls are there to allow setting this variable.

I set multicolumn, max 5 entries and a background colour for the menu. As you can see, WX5 allocates enough space (width) to accomodate 4 columns.

This post is marked for Incomedia's attention and you have obviously proven this is a bug. Can you create an iwzip of your test project and attach it here so that they can easily see and reproduce the problem (I recommend setting a contrasting background and max 5 entries per column - what was happening did not become obvious to me until I did this)

Lire plus
Posté le de Esahc ..
Mike G.
Mike G.
User
Auteur

Hi, thanks for that.

I am attaching my test site where the bug can be shown on the menu level 'rotherham' which has the menu on row 1 for all the pages set at multiple columns with a max of 5, but it doesn't work.

Lire plus
Posté le de Mike G.
Esahc ..
Esahc ..
Moderator

I am sure Incomedia will be able to acknowledge the problem.

Lire plus
Posté le de Esahc ..
Incomedia
Stefano G.
Incomedia

Hello everyone

I've verified the behavior carefully and can surely confirm that it seems to be quite odd.

For this reason, I reported the matter to the developers so that further analysis can be conducted on this.

At the moment, it seems like this will work correctly only if the Level menu select is in fact the top level Menu, but not any other level

I will be sure to notify you here as soon as news on this becomes available

Thank you

Stefano

Lire plus
Posté le de Stefano G.