WebSite X5Help Center

 
Nouterman Marceline
Nouterman Marceline
User

Formulaire de contact ne fonctionne pas  fr

Auteur : Nouterman Marceline
Visité 1930, Followers 1, Partagé 0  
Mots-clés :: contact,formulaire

Bonsoir JP, me revoici au sujet de mon du formulaire de contact.   mon serveur (LWS.fr) est bien configuré en php 5. J'ai tenté les changements lus dans d'autres post : dans préférences "changer post en get et scritp standard en bas niveau" et bien sûr de nombreux ctrl aperçu. Et malgré mes nombreuses ré-exportations, il ne fonctionne toujours pas.  J'ai lu aussi que tu conseillais de vider le serveur et de réexporter le tout Cela signifie-t-il que je dois initialiser ou il y a-t-il une autre méthode. Je n'ai pas encore ré-exporter tout le site. J'attendais ta réponse au cas où tu me donnerais une autre consigne de changement. Merci de te proccuper encore de ce problème.

Marce

Posté le
19 RéPONSES
JiPeR 48
JiPeR 48
Moderator

Re... Je viens d'envoyer un message via le formulaire de contact pour voir... Il est parti sans erreur manifeste. Avais-tu prévu une réponse automatique ? As-tu vérifié si les messages n'arrivent pas dans la boîte des spams ?

Essaie de faire une copie écran de la conception de ton formulaire qu'on puisse y jeter un oeil sur ton prochain message ici.

@Suivre, ...J.P.

Lire plus
Posté le de JiPeR 48
Nouterman Marceline
Nouterman Marceline
User
Auteur

Oui, il est censé envoyer un message de bonne réception. Et je n'ai effectivement pas reçu "ta requête". Peux-tu m'expliquer comment on fait une capture d'écran? Embarassed (j'ai honte) Merci

Lire plus
Posté le de Nouterman Marceline
Nouterman Marceline
Nouterman Marceline
User
Auteur

Finalement, je me suis souvenue que j'avais vu le mot "capture" dans le logiciel Xnvue. j'ai donc fait un essai dis-moi si c'est bien ça.

Lire plus
Posté le de Nouterman Marceline
Nouterman Marceline
Nouterman Marceline
User
Auteur

Et ça.

Lire plus
Posté le de Nouterman Marceline
JiPeR 48
JiPeR 48
Moderator

C'est bien.... Cool -

Essaie de décocher "Adresse email de l'expéditeur" à gauche dans la fenêtre, et dans "Destination adresse email" tu n'en mets qu'un pour le moment. Tu exportes la mise à jour et tu testes.

Dans la fenêtre message où tu as mis "Entrez votre texte ici" ça concerne le texte du message que tu devrais recevoir (exemple : message en provenance du site Internet...)

Tu pourrais aussi activer le contrôle "Captcha" pour éviter des éventuels messages indésirables (spams).

Tiens nous au courant... @+, ...J.P.

Lire plus
Posté le de JiPeR 48
Nouterman Marceline
Nouterman Marceline
User
Auteur

Hé non, ça n'a pas marché...demain matin je ré-exporterai tout le site.

Je ne me souviens pas d'avoir mis la phrase "entrez votre texte ici" dans la fenêtre message, il me semble que c'était déjà là???

J'ai supprimé le contrôle "Captcha" pour simplifier les manoeuvres, je le rajouterai quand le formulaire fonctionnera.

A demain, Merci  M.

Lire plus
Posté le de Nouterman Marceline
JiPeR 48
JiPeR 48
Moderator

Hello Marce, ce matin en me réveillant il m'est revenu en mémoire un problème identique chez un utilisateur de LWS... Nous avions vu ce problème sur l'ancien forum qui est verrouillé mais consultable. Voilà le lien :

http://forums.incomedia.info/websitex5/viewtopic.php?t=23821 (le tout sur 2 pages et copies écrans de l'auteur pour expliquer ce qu'il a fait...)

ça ne coûte de rien d'essayer... Wink...

@+et bon début de semaine, ...J.P.

Lire plus
Posté le de JiPeR 48
Nouterman Marceline
Nouterman Marceline
User
Auteur

Merci pour toutes ces suggestions JP. Mon tableau Php  chez LWS semble avoir les bonnes cases cochées. 

Avant de faire une nième tentative d'exportation de tout le site, je voulais te demander si il est normal d'avoir toujours un dossier "captcha" dans la liste des dossiers à exporter?

Lire plus
Posté le de Nouterman Marceline
JiPeR 48
JiPeR 48
Moderator

Bizarre, bizarre.... Avant tout essaie de supprimer ton formulaire et tu en refais un tout neuf et tout simple, avec dans les préférences "Script standard" et envoyer en tant que "Post", puis CTRL-Aperçu et exportation puis tests en ligne...

Si ça ne fonctionne toujours pas tu essaies les autres scripts, les uns après les autres.

Pour le dossier "Captcha" je pense que c'est normal. Peux pas vérifier, tous mes projets ont en un dans mes formulaires...Laughing

Bon courage..., J.P.

Lire plus
Posté le de JiPeR 48
Nouterman Marceline
Nouterman Marceline
User
Auteur

Hélàs pas de bonne nouvelle.... ça ne marche toujours pas...j'ai une furieuse impression de tourner en rond Yell.  Ce formulaire de contact est capital pour mes réservations. il me semble avoir exploré toutes les pistes proposées...que faire? ça marchait impeccable dans la version 7.

Une petite parenthèse : je voulais ouvrir le panneau de contrôle WS avec monsite.com/admin pour le diagnostique de la version Php du serveur, cela n'a pas marché. L'dresse ouvre une page de recherche classique avec des sites qui n'ont rien à voir

 Et autre question : dans l'aide du formulaire de contact section envoi, on peut lire:

"Par défaut, le programme utilise comme email de l'expéditeur celui du destinataire qui, dans ce cas, correspond au gérant du site"

Où rentre-t-on l'adresse mail du "gérant du site".

J'espère toujours en explorant d'autres pistes tomber sur le petit détail qui m'aurait échappé.

Et J'espère que tu auras une autre idée.

Marce

PS : le nouveau formulaire est toujours en ligne

Lire plus
Posté le de Nouterman Marceline
Nouterman Marceline
Nouterman Marceline
User
Auteur

C'est ça que je voulais envoyer évidemment! Smile

Lire plus
Posté le de Nouterman Marceline
JiPeR 48
JiPeR 48
Moderator

Salut Marce... C'est la galère !! Cry

Si tu n'as pas accès à ton panneau d'admin pour contrôler le PHP, j'ai bien peur que le problème vienne de là.

Essaie de revoir les copies écran des messages de l'ancien forum pour contrôler toutes les coches de ton PHP, sachant qu'habituellement il faut environ 48 heures pour que les modifications soient prises en compte.

Sinon contacte ton fournisseur pour lui demander de te confirmer si tu es bien en PHP 5 et sinon qu'il le fasse rapidement, ou qu'il te donne la manipulation à faire. Je ne vois pas d'autre solution pour le moment.

Bon courage en attendant, ...J.P.

Lire plus
Posté le de JiPeR 48
Nouterman Marceline
Nouterman Marceline
User
Auteur

Salut JP, contente de te retrouver,

Est-ce que tu veux dire que l'accès au panneau d'admin a un rapport avec la configuration Php du serveur? Parce que si j'ai bien compris, c'est dans ce panneau que WS t'indique ta configuration Php. Il faudrait donc y avoir accès quelle que soit cette configuration

Et quand tu parles des coches Php, ce sont (sont-ce Wink) celles du tableau de bienvenue à "préférence"? parce que là il me semble avoir essayer toutes les combinaisons, j'ai même essayé "get" au lieu de "post" et là j'ai eu une réponse au mail de l'expéditeur mais pas la demande dans ma boîte. Je veux bien recommencer les opérations, mais si il faut attendre 48 h entre chaque......Frown (tu confirmes?)

Je fais confirmer par LWS.

à bientôt, Marce

Lire plus
Posté le de Nouterman Marceline
JiPeR 48
JiPeR 48
Moderator

Hello, la vérification du PHP en lançant ton panneau "Admin" aurait permis de voir quelle est la version du PHP en cours sur ton serveur... Rien à voir avec le reste sur le logiciel...

Je voulais parler de ton panneau d'administration du PHP sur ton serveur, comme nous l'avons vu sur le sujet de l'ancien forum que je t'avais indiqué. Il faut tout essayer...Wink. Pour les 48 heures ça ne concernait qu'une éventuelle modification du PHP sur le serveur et non à partir du logiciel.

Si tu as eu une réponse de l'expéditeur c'est que ça commence à prendre forme. Vérifie bien ton formulaire. J'ai fait un test depuis ton site pour voir. Tu me diras si tu as reçu quelque chose.

@+, ...J.P.

Lire plus
Posté le de JiPeR 48
Nouterman Marceline
Nouterman Marceline
User
Auteur

Je n'ai rien reçu du site, par contre voici la réponse de LWS

Bonjour,
Votre compte est bien sous php 5.
Vous avez la possibilité de modifier certains paramètres PHP via votre espace client directement, selon la procédure expliquée ci dessous :
http://wiki.lws-hosting.com/doku.php/comment_modifier_la_configuration_php_de_mon_hebergement_web_mutualise
Si toutefois vous désirez modifier d'autres paramètres PHP, alors cela ne sera pas possible de le faire sur votre formule : vous pourrez le faire uniquement sur une formule de type VPS, dont vous pouvez trouver les détails ici : http://www.lws.fr/serveur_dedie_linux.php
Nous restons à votre disposition pour tout renseignement supplémentaire.
Cordialement,
L'équipe LWS

Par contre, en relisant TRES attentivement l'ancien forum je me suis aperçue qu' une des cases cochées chez moi en "on" était en "off" chez lui. J'ai donc fait le changement. Comme tu disais, il y a un délai pour que le changement soit effectué. Donc attendre un petit peu et espérer que ça marche.Laughing

Et j'ai finalement eu accès au panneau admin de WS voici ce qu'il dit (et confirme)

LogoutVersion - PHP: 5.3.15-1~dotdeb.0 PASS

Support session PASS

 Chemin du dossier public PASS

 Paramètres MySql PASS

A plus tard, Marce

Lire plus
Posté le de Nouterman Marceline
JiPeR 48
JiPeR 48
Moderator

Hello Marce, je vois que tes paramètres du panneau admin sont bons (tout est au vert en PASS).

Attendons donc le délai d'activation de ta modif pour voir... @+, ...J.P. 

Lire plus
Posté le de JiPeR 48
Nouterman Marceline
Nouterman Marceline
User
Auteur

Bonjour JP,

Il s'est passé quelque chose, mais pas exactement ce qu'on espérait : Le mail de réception de la demande est bien arrivée  à l'adresse indiquée dans le  formulaire mais pas reçu la demande dans ma boîte mail.  Si tu es dans le coin, par quel changement me conseilles-tu d'intervenir?  Je remets la capture de mon formulaire.

Merci, Marce

Lire plus
Posté le de Nouterman Marceline
Nouterman Marceline
Nouterman Marceline
User
Auteur

Bon ben, tu ne le croiras pas , J'ai réexporter le site après un CTRL aperçu et nettoyage des caches internet et ça ne marche plus Yell. J'y comprends rien, j'ai rien changé aux paramètres!

Je fais un exportation totale?????

Lire plus
Posté le de Nouterman Marceline
JiPeR 48
JiPeR 48
Moderator

Salut Marce... Toujours rien qui fonctionne ? Tu peux effectivement tenter une exportation complète après nettoyage du serveur. Tu ne vires que les dossiers et fichiers relatifs à WX5 Evolution. Attention aux fichiers de l'hébergeur s'il en existe : je ne connais pas le fonctionnement chez LWS, mais chez moi par exemple j'ai un dossier "Logs" que je ne touche pas...

Puis tu tentes les différents scripts du formulaire pour voir...

Pense à sauvergarder ton projet avant tout, on ne sait jamais...

Bon courage encore, car je ne vois pas ce qui bloque ton formulaire Cry

@+, J.P.

Lire plus
Posté le de JiPeR 48