WebSite X5Help Center

 
Tom G.
Tom G.
User

A2 Hosting and Shopping Cart  en

Author: Tom G.
Visited 421, Followers 1, Shared 0  

On the created web page with e-commers, "Add to cart" button doesn't work when ran from the server.

It works fine using software's Preview.

The page passes Control Panel's WEBSITE TEST:


As a provider I'm using "a2 Hosting".

What would you suggest me to do? Anyone using "a2 Hosting" and gets to the cart screen without problems?

Posted on the
15 ANSWERS - 2 USEFUL - 1 CORRECT
Aleksej H.
Aleksej H.
Moderator

Hello.

"What would you suggest me to do? " - change PHP 7.3 to 7.1.

"Anyone using "a2 Hosting" and gets to the cart screen without problems?" - when I recorded a video course on creating a site in this program, I tested the site on this hosting. When i used PHP 7.3 - I had some problems. Then I switched to 7.1 and everything began to work normally.

Read more
Posted on the from Aleksej H.
Tom G.
Tom G.
User
Author

Thank you, Aleksej, for your response.

I have changed PHP to version 7.1.27.

But it didn't help...

Read more
Posted on the from Tom G.
Aleksej H.
Aleksej H.
Moderator

What is the site address?

Read more
Posted on the from Aleksej H.
Esahc ..
Esahc ..
Moderator

Tom, you have cleared the cache (ctrl+f5) in your browser (or tried a different browser)?

Read more
Posted on the from Esahc ..
Tom G.
Tom G.
User
Author

Yes, I cleared the cache @Esahc, (ctrl+f5) in Mozilla Firefox browser didn't help...

BUT IN EDGE and IE11 IT WORKS!!!

@Aleksej, the page is my first test of "shopping cart" and it's temporarily put here.

After clicking "ADD TO CART" it's supposed to go to cart page, but it doesn't. That is in Mozilla Firefox. As I said, it works in Edge and IE11.

So, the problem seems to be Firefox...

Read more
Posted on the from Tom G.
Esahc ..
Esahc ..
Moderator

Worked for me with firefox. . . 

Read more
Posted on the from Esahc ..
Tom G.
Tom G.
User
Author

Links are in post just above yours (addressed to @Aleksej)...

Read more
Posted on the from Tom G.
Tom G.
Tom G.
User
Author

Well - no more Esahc post I'm responding to...

Read more
Posted on the from Tom G.
Esahc ..
Esahc ..
Moderator

Sorry Tom, I started writing the wrong question, hid it and rewrote it not realising it was temporarily visible. . . . 

Found the link, tried it out, received confirmation, all thru firefox :-)

(hopefully you received an order confirmation - BTW, it is my real email address, feel free to use it :-)

Read more
Posted on the from Esahc ..
Incomedia
Stefano G.
Incomedia

Hi Tom.

I can confirm that after testing on Firefox on your test website, the button worked just fine for me.

Did you already solve the issue on your own? Did you test this from different devices?

Perhaps something specific is going on with your browser. Perhaps some extension?

Keep me posted on this should anything new come up

Thank you

Stefano

Read more
Posted on the from Stefano G.
Tom G.
Tom G.
User
Author

No, Stefano, it's plain Mozilla Firefox Developer Edition ver. 67.0.

I found something else, though.

When adding (or trying to) to the shoping cart, there are little arrows on the quantity.

Here is how it loooks in Firefox:

In Edge, these are missing:

In Chrome, they appeare and can be used when cursor positioned on it.

Read more
Posted on the from Tom G.
Aleksej H.
Aleksej H.
Moderator

I checked in:

  1. Mozilla Firefox 66.0.1 (x64)
  2. Google Chrome 73.0.3683.86 (x64)
  3. Opera 58.0.3135.118
  4. Internet Explorer 11.648.17134.0
  5. MS Edge 17.17134
  6. Yandex 19.3.0.2485

Windows 10 x64. Everything is working fine. Try clearing your browser’s cache and restarting it. You may have some extensions installed in Mozilla Firefox.

Read more
Posted on the from Aleksej H.
Aleksej H.
Aleksej H.
Moderator

"No, Stefano, it's plain Mozilla Firefox Developer Edition ver. 67.0." - maybe problem in version.

Here is how it loooks in Mozilla Firefox 66.0.1 (x64) (stable version):

Read more
Posted on the from Aleksej H.
Tom G.
Tom G.
User
Author

YES, GUYS!!! It's Firefox Developer Edition v67!

In Firefox Quantum (not the Developer Edition) all works fine!

Thank you ALL for your input!

=Tom=

Read more
Posted on the from Tom G.
Aleksej H.
Aleksej H.
Moderator

It's my pleasure.Glad your problem is solved.

Read more
Posted on the from Aleksej H.