WebSite X5Help Center

 
Paul G.
Paul G.
User

Minimal requirement for php and mysql settings for any wx5 Website  en

Author: Paul G.
Visited 107, Followers 1, Shared 0  

Hi

I am looking for the minimal requirements (May 2022) for both PHP and MySQL and also the MySQL settings.

I have a problem with a new website (WX5 v2022.1.6) on a new server. In the WX5 manager I keep receiving there is a problem with MySQL settings. It seems to work fine, though.
When I upload the site to my other server (same webhosting but different server) I pass the MySQL requirements.

The only difference I can see is that the PHP on the new server is 5.6.40 while my other server has 7.0.33. MySQL version of MariaDB on the server is the same.

My guess is that PHP version 5.6.40 needs to be upgraded. But how to convince the provider? I need something in writing....

Thanks in advance for any assistance or help on this one.

Kindest regards, Paul

Posted on the
3 ANSWERS
Aleksej H.
Aleksej H.
Moderator
Best User of the month EN

Hello. Here are the minimum requirements for the server (guide.websitex5.com/en/support/solutions/articles/44001791318-what-are-the-minimum-requirements-for-the-server-).

"My guess is that PHP version 5.6.40 needs to be upgraded. But how to convince the provider?" - You don't need to convince him. You are his client. PHP 5.6 - not supported for a long time. This is a very outdated version. It is slower and less secure. Last updated in January 2019 (www.php.net).

Also read this (www.digitalcanvas.com/blog/is-php-5-6-still-supported).

You don't have to prove yourself right. Just ask for the option to use PHP 7.4 or 8.0. If you get a refusal - change hosting.

Read more
Posted on the from Aleksej H.
Paul G.
Paul G.
User
Author

Hi Aleksej,

Sorry for the late reply. Had other urgent things to see to, unfortunately :(

I figured as much that 5.6.40 was depricated. I could not find a sufficient answer to my problem here on the community site.

I just wrote the support staff of my provider a mail with the request to upgrade the version. 
As soon as I receive a reply, I will let you know what their answer is.

Thank you very much for your reply and help!

Greetings, Paul.

Read more
Posted on the from Paul G.
Aleksej H.
Aleksej H.
Moderator
Best User of the month EN

"I figured as much that 5.6.40 was depricated. I could not find a sufficient answer to my problem here on the community site." - Yes you are right. This is an old version.

Read more
Posted on the from Aleksej H.