WebSite X5Help Center

 
Paul G.
Paul G.
User

Object html code/css attached files bug?  en

Author: Paul G.
Visited 130, Followers 1, Shared 0  

Hi, I found out that there is a possible bug in the Object for HTML Code/CSS working with attached files.
I am using Dutch version of WebsiteX5 Pro 2020.1.12.

I admit, this was the first time I ever needed to enclose multiple files to the HTML Code object.
When you attach files to the object, they have /files as a server path (suggested). My object worked fine until I wanted to put all the files nicely together : .js in the /js subfolder and .css in the /css subfolder of my website in order to keep a clear structure. 
I changed all instances to the new folder in every file necessary, every .js and the .css was altered to the correct folder (/js or /css) and after this, the whole HTML Code object no longer worked. 

After checking, rechecking and trying out for about 1 hour, everything worked again... only after changing all references to any subfolder back to "/files".

Just for information, but if you retain /files as server path, it is not really necessary to be able to change the server path on the site.

Posted on the
2 ANSWERS
Aleksej H.
Aleksej H.
Moderator

Hello. I sent a notification about your question to the company employees, expect an answer from them here in the comments.

Read more
Posted on the from Aleksej H.
Incomedia
Stefano G.
Incomedia

Hello Paul

if I understand correctly, you're saying that specifying whatever other folder here:

Will break the linking of these files? 

Did the mentioned folder exist or not? 

Keep me posted on this so that I might perform further checks

Thank you

Stefano

Read more
Posted on the from Stefano G.